View Issue Details

IDProjectCategoryView StatusLast Update
0012211ScribusImport / Exportpublic2018-04-30 13:06
Reporterchristoph_s Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionfixed 
Platformx86_64OSOpenSUSE 64 BitOS Version13.1
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0012211: Severe issues with ODG file
DescriptionThe attached ODG file reveals several issues with the current ODG importer:

1) While Scribus asks for a font replacement (for a font that's actually installed on the system!), the text isn't imported at all, and neither is the custom style.

2) The ODG file comprises layers, none of which are recognised by Scribus if the document has been *opened* (as opposed to imported).
Currently: 
Layers are recognized if:
* drag/deop text-test.odg in to an empty canvas.
* File > Open

Layers dont show up if:
* drag/drop text-test.odg in to a pre-opened SLA
* File > Import > Get Vector File 

3) In the Document Outline, an non-existent item called "Polygon1" is listed.
 Per Franz: this Polygon1 is on the Master Page, it is there to handle OOs PageBackground property.
TagsODF
PatchNo

Relationships

related to 0005179 new SXD/ODG test cases 
related to 0012074 assignedfschmid Missing warning if an ODG file contains unsupported features 

Activities

christoph_s

2014-04-12 05:30

administrator  

text-test.odg (10,666 bytes)

fschmid

2014-04-12 09:43

administrator   ~0031678

Just some comments about the issues:
1) Text is imported now, the reason why the importer asks for a replacement is that OO has the font as "Astron Boy" where Scribus has the font as "Astron Boy Regular".
3) this Polygon1 is on the Master Page, it is there to handle OOs PageBackground property.

christoph_s

2014-04-12 19:05

administrator   ~0031679

The text style is still not imported. Everything else works now.

christoph_s

2014-04-13 05:35

administrator   ~0031680

Additional information:

The "text style" is actually a subset of the graphics object style. It's called "Meine Vorlage".

Kunda

2016-01-27 21:55

manager   ~0038468

In regards to 2)
Layers are recognized:
* drag/deop text-test.odg in to an empty canvas.
* File > Open

Layers dont show up if:
* drag/drop text-test.odg in to a pre-opened SLA
* File > Import > Get Vector File

Kunda

2016-01-27 22:01

manager   ~0038469

So what's left is to address:
1a) Font issue has to do with how Scribus recognizes the font name? Do we need to do anything about this?
1b) Style not being imported still looks like an issue

2) I specified in 0012211:0038468 what are the conditions when Layers are recognized and when not. What's the verdict?

3) Do we want to keep the label Polygon for the function that it's used for which is to hold OOs PageBackground property. Can we rename it to that, meaning change Polygon to "PageBackground" so it's more clear?

Issue History

Date Modified Username Field Change
2014-04-12 05:30 christoph_s New Issue
2014-04-12 05:30 christoph_s Status new => assigned
2014-04-12 05:30 christoph_s Assigned To => fschmid
2014-04-12 05:30 christoph_s File Added: text-test.odg
2014-04-12 09:43 fschmid Note Added: 0031678
2014-04-12 09:43 fschmid Status assigned => resolved
2014-04-12 09:43 fschmid Fixed in Version => 1.5.0svn
2014-04-12 09:43 fschmid Resolution open => fixed
2014-04-12 19:05 christoph_s Note Added: 0031679
2014-04-12 19:05 christoph_s Status resolved => assigned
2014-04-13 05:35 christoph_s Note Added: 0031680
2014-07-03 19:32 Kunda Target Version 1.5.0 => 1.5.1
2015-11-29 14:06 Kunda Target Version 1.5.1 => 1.5.2
2016-01-23 17:15 cbradney Target Version 1.5.2 => 1.5.4.svn
2016-01-27 21:42 Kunda Tag Attached: ODF
2016-01-27 21:51 Kunda Patch => No
2016-01-27 21:51 Kunda Description Updated View Revisions
2016-01-27 21:55 Kunda Note Added: 0038468
2016-01-27 21:57 Kunda Description Updated View Revisions
2016-01-27 22:01 Kunda Note Added: 0038469
2016-01-27 22:03 Kunda Description Updated View Revisions
2016-01-30 23:39 Kunda Relationship added related to 0012074
2016-01-30 23:39 Kunda Relationship added related to 0005179
2018-04-30 13:06 jghali Target Version 1.5.4.svn =>