View Issue Details

IDProjectCategoryView StatusLast Update
0012250ScribusImport / Exportpublic2016-01-18 19:28
ReporterJLuc Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.5.1svn 
Summary0012250: SVG arrows not imported
DescriptionSVG imports ignores the svg arrows at the end of the lines.
The line is imported, not the arrows.

See sample SVG.
TagsNo tags attached.
PatchNo

Relationships

related to 0012771 closedfschmid Some patterns imported to incorrect level and therefore aren't visible 
child of 0002931 acknowledged Metabug: SVG 

Activities

JLuc

2014-04-21 16:57

developer  

svg arrow.svg (2,694 bytes)

FirasH

2014-04-21 19:16

developer   ~0031748

With Scribus 1.5.0 SVN (19075) the arrow is imported as expected.
I'll upload a screenshot that compares Scribus 1.4.x to 1.5.x import + how Inkscape 0.48.x and 0.48+devel sees the SVG.

FirasH

2014-04-21 19:16

developer  

SVGArrowImportScribus.png (99,867 bytes)
SVGArrowImportScribus.png (99,867 bytes)

FirasH

2014-04-21 19:16

developer  

SVGArrowImportInkscape.png (115,214 bytes)
SVGArrowImportInkscape.png (115,214 bytes)

christoph_s

2014-04-22 07:15

administrator   ~0031754

Franz, if this can't be backported to 1.4.4, please close this bug.

JLuc

2014-04-23 16:14

developer   ~0031775

Last edited: 2014-04-30 17:01

View 5 revisions

Hmmm sometime, some arraws aren't imported, sometime i dont reproduce.
The same SVG loads ok when its the first object in a new doc. It loads without arrows when its in a long heavy doc.

(Maybe related, maybe not : when sent to the printer, a 13 pages document with various SVG included had some issues as for the RIP : not errors, but some rendering issues. 1) some polygons and lines rendered as dashed when they should have rendered as solid lines (note : there are 2 really dashed lines very close to these polygons and lines, and the wrong rendering used this dash style as if contaminated) 2) some little text frames did not render at all
As a fix, I sent the PDF for these 2 pages only, and most of these issues were fixed, except one line that kept being rendered as dashed. )

JLuc

2014-04-23 16:24

developer  

test arrows.svg (1,380,073 bytes)

JLuc

2014-04-23 16:44

developer   ~0031777

Last edited: 2014-04-30 16:42

View 4 revisions

Allways reproduced :

Other issue with SVG arrows : open "test arrows.svg" (second uploaded SVG), ungroup SVG, see : most of the arrow heads have rotated or un-rotated and are not in their right place and orientation anymore.

After this, try in same document, load "svg arrow.svg" (first uploaded SVG): it has no visible arrows.

JLuc

2014-04-30 16:38

developer   ~0031832

Last edited: 2014-04-30 16:43

View 2 revisions

This is confirmed on an other machine, with the scribus friend's PPA :

On a new document, right click + "paste file" "test arrows.svg" (second SVG uploaded document), ungroup SVG, see : most of the arrow heads have rotated or un-rotated and are not in their right place and orientation anymore.

After this, try in same document, load "svg arrow.svg" (first SVG uploaded document): it has no visible arrows.

JLuc

2014-04-30 16:40

developer  

Kunda

2014-08-12 20:41

manager   ~0033238

1st) Cannot recreate original problem on OSX 10.8.5 1.5svn r19415. Console shows: "unsupported SVG feature: overflow"
2nd) Can confirm that ungrouping the image causes the same issue. This SVG also throws an "unsupported SVG feature: overflow"

ale

2015-11-29 10:27

manager  

werehere.svg (27,013 bytes)

ale

2015-11-29 10:29

manager  

no-arrow.sla (446,912 bytes)

ale

2015-11-29 10:30

manager   ~0037728

if i load werehere.svg into no-arrow.sla i get the red path without arrow head.

if i load werehere.svg into a new file i get the arrow head and i can copy paste the full grahpic into the no-arrow.sla file.

ale

2016-01-17 18:09

manager   ~0038218

importing werehere in a new page in no-arrow.sla still does not work...

still as described above.

JLuc

2016-01-17 19:21

developer   ~0038219

I confirm its not fixed.

with my files : when "svh arrows.svg" is imported into "test arrows.svg", its arrows do not show.

Same with ale's files : when "werehere.svg" is imported into "no-arrow.svg", its arrows do not show.

fschmid

2016-01-17 22:20

administrator   ~0038222

Please try again, just committed another fix for the arrows

Kunda

2016-01-18 13:45

manager   ~0038240

This looks fixed on OSX 10.10.5 1.5.1svn r20696

ale

2016-01-18 19:22

manager   ~0038256

yep, seems to be working now!
thanks franz!

Kunda

2016-01-18 19:28

manager   ~0038257

Closing

Issue History

Date Modified Username Field Change
2014-04-21 16:57 JLuc New Issue
2014-04-21 16:57 JLuc File Added: svg arrow.svg
2014-04-21 19:16 FirasH Note Added: 0031748
2014-04-21 19:16 FirasH File Added: SVGArrowImportScribus.png
2014-04-21 19:16 FirasH File Added: SVGArrowImportInkscape.png
2014-04-22 07:14 christoph_s Assigned To => fschmid
2014-04-22 07:14 christoph_s Status new => assigned
2014-04-22 07:15 christoph_s Note Added: 0031754
2014-04-23 16:14 JLuc Note Added: 0031775
2014-04-23 16:21 JLuc Note Edited: 0031775 View Revisions
2014-04-23 16:23 JLuc Note Edited: 0031775 View Revisions
2014-04-23 16:24 JLuc File Added: test arrows.svg
2014-04-23 16:44 JLuc Note Added: 0031777
2014-04-29 17:12 JLuc Note Edited: 0031777 View Revisions
2014-04-29 17:15 JLuc Note Edited: 0031777 View Revisions
2014-04-30 16:38 JLuc Note Added: 0031832
2014-04-30 16:40 JLuc File Added: ungrouped svg arrows and other without-arrow-end arrow.png
2014-04-30 16:42 JLuc Note Edited: 0031777 View Revisions
2014-04-30 16:43 JLuc Note Edited: 0031775 View Revisions
2014-04-30 16:43 JLuc Note Edited: 0031832 View Revisions
2014-04-30 17:01 JLuc Note Edited: 0031775 View Revisions
2014-08-12 20:41 Kunda Note Added: 0033238
2014-08-12 20:42 Kunda Relationship added child of 0002931
2015-11-29 10:27 ale File Added: werehere.svg
2015-11-29 10:29 ale File Added: no-arrow.sla
2015-11-29 10:30 ale Note Added: 0037728
2015-11-29 17:46 Kunda Patch => No
2015-11-29 17:46 Kunda Target Version => 1.5.2
2016-01-17 10:50 fschmid Status assigned => resolved
2016-01-17 10:50 fschmid Fixed in Version => 1.5.1svn
2016-01-17 10:50 fschmid Resolution open => fixed
2016-01-17 18:09 ale Note Added: 0038218
2016-01-17 19:21 JLuc Note Added: 0038219
2016-01-17 22:20 fschmid Note Added: 0038222
2016-01-18 13:45 Kunda Relationship added related to 0012771
2016-01-18 13:45 Kunda Note Added: 0038240
2016-01-18 14:10 Kunda Target Version 1.5.2 => 1.5.1
2016-01-18 19:22 ale Note Added: 0038256
2016-01-18 19:28 Kunda Note Added: 0038257
2016-01-18 19:28 Kunda Status resolved => closed