View Issue Details

IDProjectCategoryView StatusLast Update
0012319ScribusShape Drawingpublic2015-11-25 16:44
ReporterFirasH Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0012319: Wrong resizing/preview of more items selected
DescriptionIf more items are selected simultaneously, resizing might lead to bad preview and also wrong behavior of resized items.
Steps To ReproduceA - Selected area is bigger than the item:

0) Create a new document
1) Insert an item (not a Text/Image/Render Frame or Table)
2) Insert a Shape (square) so that when selected simultaneously with the item the selected canvas area is bigger
3) Select the Item and then, while pressing shift, select the Shape
4) Resize the group moving the selection handles
5) The item (which was selected before) preview is as big as the whole selection

If the item is a Polygon (5 corners) or Arc also its size will be changed, going out of the frame (until a change is applied as single item). Basically items which have that free space on one or more sides of the frame.

B - Selection area is smaller than the item:
Repeat the same steps except for
2) Insert a Shape that is smaller than the item and inside of its selection area

In this case rather than increasing the size of the item, this is reduced.
Additional InformationScribus 1.5.0 SVN (19123)

Video: https://www.dropbox.com/s/owqfb1xq0273gr9/ItemsResize.mp4
TagsNo tags attached.
Patch

Relationships

related to 0013563 confirmed Resizing 2 items (one of which is rotated) leads to wrong canvas placement (semi-fixed) 

Activities

FirasH

2014-05-20 13:13

developer   ~0031881

Scribus 1.5.0 SVN (19128): The issue is partially fixed, but at the same time brings out new issues. In the following note I'll include a more detailed description.

Issue History

Date Modified Username Field Change
2014-05-17 19:34 FirasH New Issue
2014-05-20 05:03 fschmid Assigned To => fschmid
2014-05-20 05:03 fschmid Status new => assigned
2014-05-20 10:34 fschmid Status assigned => resolved
2014-05-20 10:34 fschmid Fixed in Version => 1.5.0svn
2014-05-20 10:34 fschmid Resolution open => fixed
2014-05-20 13:13 FirasH Note Added: 0031881
2014-05-27 20:01 cbradney Status resolved => closed
2015-11-25 16:44 FirasH Relationship added related to 0013563