View Issue Details

IDProjectCategoryView StatusLast Update
0012320ScribusUndo/Redopublic2019-11-04 15:59
ReporterFirasH Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.5Fixed in Version1.5.6.svn 
Summary0012320: Undo/Redo does not restore properly a flipped Spiral
DescriptionUndo/Redo is not able to restore a flipped Spiral. Saving, closing and reopening the document or editing the Spiral properties restores the Spiral as it should be.
Steps To Reproduce0) Create a new document
1) Insert a Spiral
2) Select the Spiral and Properties > X,Y,Z > Flip horizontally or vertically
3) Undo
Nothing seems to happen.

4-A) Double-click on the Spiral and edit its properties or simply change the frame size.
The Spiral is correctly restored.

4-B) Save the document, close and reopen it
The Spiral is correctly restored.

The Spiral horizontal/vertical flip is saved correctly, so the problem is likely related to a wrong update of the Canvas.
Additional InformationScribus 1.5.0 SVN (19128)

Similar issues with Spiral:
0012223

(not sure if related to this fix: 0012318)
TagsNo tags attached.
Patch

Relationships

related to 0012223 resolvedjghali Undo is not able to restore properly a rotated Spiral 
child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

Kunda

2014-07-08 02:50

manager   ~0032566

Confirmed 1.5.0 SVN r19330 (OSX 10.8.5)

Issue History

Date Modified Username Field Change
2014-05-20 17:01 FirasH New Issue
2014-07-07 15:15 FirasH Relationship added related to 0012223
2014-07-08 02:50 Kunda Note Added: 0032566
2014-07-08 02:50 Kunda Status new => confirmed
2014-07-08 02:50 Kunda Target Version => 1.5.1
2014-07-09 01:20 FirasH Relationship added child of 0012500
2015-11-29 13:56 Kunda Target Version 1.5.1 => 1.5.2
2016-01-23 17:14 cbradney Target Version 1.5.2 => 1.5.3
2016-01-23 17:15 cbradney Target Version 1.5.3 => 1.5.4.svn
2016-05-15 23:11 Kunda Target Version 1.5.4.svn => 1.5.5
2019-11-04 15:59 jghali Assigned To => jghali
2019-11-04 15:59 jghali Status confirmed => resolved
2019-11-04 15:59 jghali Resolution open => fixed
2019-11-04 15:59 jghali Fixed in Version => 1.5.6.svn