View Issue Details

IDProjectCategoryView StatusLast Update
0012382ScribusBuild Systempublic2015-06-05 20:57
Reporterale Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0012382: proposal for a development splash screen
Descriptionhaving nightly DMGs and an homebrew recipe are a good thing!

but i fear that some (or many) people will start working with scribus and ignore the fact that they are using a development version (and -- as an example -- write bad reviews or comments related to their experience)

so, i'm proposing a specific splashscreen for the dev version...

two examples are attached. with or without cultural reference.
TagsNo tags attached.
Patch

Activities

ale

2014-06-12 20:09

manager  

Scribus15svn_Splash.png (150,665 bytes)
Scribus15svn_Splash.png (150,665 bytes)

ale

2014-06-12 20:10

manager  

Scribus15svn_Splash_NOC.png (137,516 bytes)
Scribus15svn_Splash_NOC.png (137,516 bytes)

Kunda

2014-06-12 23:13

manager   ~0032117

Mentioned on the ML http://lists.scribus.net/pipermail/scribus/2014-June/050428.html
Some other related issues that have been discussed:

FirasH has pointed out that on machines that use SSD the splash screen
is almost invisible (because loading speed is so fast). So I think we may
need to go a little extra than just altering the Splash screen.

Ideas:
1. Append to the title of the Scribus window "Experimental Build not to be
used in Production Environment" (or some variant)
2. Embed in the grey background behind the canvas (perhaps diagonally
repeating) a watermark that says something like 'Experimental Build'. This
would be repeated redundantly.

ale

2014-06-13 05:13

manager   ~0032131

well, if the first proposal is accepted (or any variation of it containing mr. adams text), i will be pleading for a button in the toolbar (or status bar or a main menu), with the words "DON'T PANIC" in large, friendly, letters. it would show a dialog explaining what a development version is and would have links to the wiki and this bug tracker.

Kunda

2014-06-13 05:18

manager   ~0032132

@ale this "Don't Panic' button makes sense because it encourages folks to fill out bug reports and educates them in the process . Also perhaps there could be a list of known issues that would be listed that we know of that people could decide if they wanted to run this in production or not.

Kunda

2015-03-28 02:20

manager   ~0034775

I still vote that we should do this for svn versions

Kunda

2015-06-05 20:57

manager   ~0035329

It was a good idea but not likely due to lack of response.

Issue History

Date Modified Username Field Change
2014-06-12 20:09 ale New Issue
2014-06-12 20:09 ale File Added: Scribus15svn_Splash.png
2014-06-12 20:10 ale File Added: Scribus15svn_Splash_NOC.png
2014-06-12 23:13 Kunda Note Added: 0032117
2014-06-13 05:13 ale Note Added: 0032131
2014-06-13 05:18 Kunda Note Added: 0032132
2015-03-28 02:20 Kunda Note Added: 0034775
2015-06-05 20:57 Kunda Note Added: 0035329
2015-06-05 20:57 Kunda Status new => closed
2015-06-05 20:57 Kunda Resolution open => won't fix