View Issue Details

IDProjectCategoryView StatusLast Update
0013169ScribusGeneralpublic2016-01-18 14:10
ReporterFirasH Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.2
Product Version1.5.1svn 
Target Version1.5.1Fixed in Version1.5.1svn 
Summary0013169: Items with rotation between 91° and 269° are wrongly placed on canvas after Ungroup
DescriptionItems with rotation between 90° and 270° are wrongly placed on canvas after Ungroup.
Steps To Reproduce0) Create a new document
1) Insert an Item
2) Insert another Item
3) Apply a Rotation between 90° and 270° to one of the Items
4) Group the Items
5) Ungroup the Items

Items are wrongly placed on canvas.
Additional Information1.5.1.svn (20197)
TagsNo tags attached.
PatchNo

Relationships

related to 0012354 closedfschmid Ungrouping items rotated/grouped/welded places them wrongly 
child of 0003812 acknowledged Metabug: Grouped objects 

Activities

Kunda

2015-06-26 20:22

updater   ~0035525

Firash, can reproduce and refining to say that rotation has to be between 91° - 269°
1.5.1svn r20210

watfa albadi

2015-10-20 09:12

reporter   ~0036725

brother,can reproduce and but the rotate between 272 and 49
1.5.1svn and it will work with out crash.


regards wh..

Kunda

2015-10-20 12:52

updater   ~0036731

Hi Watfa,
Thanks for the feedback. This bug isn't labeled as a Crash bug.

watfa albadi

2015-10-21 07:47

reporter   ~0036770

Last edited: 2015-10-21 07:51

can reproduce and put the rotate between 272 and 49
1.5.1svn r12400 and it will work well

regards wh..

Kunda

2015-10-21 12:57

updater   ~0036777

Hi watfa,
Not fully certain what you are saying. Let me try to understand:
1) The rotation bug occurs between 272° and 49° (not what the bug title says)
2) This is a regression since you can not reproduce running r12400.
Is that right ?

FirasH

2016-01-17 14:11

developer   ~0038217

Thanks fschmid!
Fixed in 1.5.1.svn (20690).

Issue History

Date Modified Username Field Change
2015-06-24 16:31 FirasH New Issue
2015-06-26 20:22 Kunda Note Added: 0035525
2015-06-26 20:22 Kunda Status new => confirmed
2015-06-26 20:23 Kunda Relationship added child of 0003812
2015-07-26 05:37 Kunda Summary Items with rotation between 90° and 270° are wrongly placed on canvas after Ungroup => Items with rotation between 91° and 269° are wrongly placed on canvas after Ungroup
2015-10-04 23:29 Kunda Target Version => 1.5.2
2015-10-20 09:12 watfa albadi Note Added: 0036725
2015-10-20 12:52 Kunda Note Added: 0036731
2015-10-21 07:47 watfa albadi Note Added: 0036770
2015-10-21 07:50 watfa albadi Note Edited: 0036770
2015-10-21 07:51 watfa albadi Note Edited: 0036770
2015-10-21 12:57 Kunda Note Added: 0036777
2016-01-17 11:00 fschmid Status confirmed => resolved
2016-01-17 11:00 fschmid Fixed in Version => 1.5.1svn
2016-01-17 11:00 fschmid Resolution open => fixed
2016-01-17 11:00 fschmid Assigned To => fschmid
2016-01-17 11:03 FirasH Relationship added related to 0012354
2016-01-17 14:11 FirasH Note Added: 0038217
2016-01-17 14:11 FirasH Status resolved => closed
2016-01-18 14:10 Kunda Target Version 1.5.2 => 1.5.1