View Issue Details

IDProjectCategoryView StatusLast Update
0013187ScribusOS-MacOSXpublic2018-04-30 12:39
ReporterKunda Assigned Tocbradney  
PriorityhighSeveritymajorReproducibilityhave not tried
Status confirmedResolutionfixed 
PlatformMacOSXOSYosemiteOS Version10.10.3
Product Version1.5.1svn 
Target Version1.5.5Fixed in Version1.5.1svn 
Summary0013187: OSX Bug: Unable to access Preferences in Russian Interface
DescriptionSwitch to russian and then try to open Preferences. Locked out
I needed to start Scribus from the command line to fix this:
~$path/to/Scribus -l en
Steps To Reproduce1) Open preference
2) Change Interface language to Russian
3) Exit preferences
4) Exit Scribus
5) Open Scribus (UI will now be in Russian)
6) Try to open Prefences (cmd+, or 4th item in Scribus Dropdown)
Either one triggers the Properties Panel not Preferences

TagsNo tags attached.
PatchYes

Relationships

parent of 0013380 closedcbradney [Regression] CLI flag -l <language> doesn't work 

Activities

Kunda

2015-06-30 01:08

updater  

scribus-ru.m4v (510,515 bytes)

Kunda

2015-06-30 01:08

updater   ~0035569

Uploaded Screencast

Kunda

2015-07-01 23:36

updater   ~0035613

Last edited: 2015-07-01 23:37

View 3 revisions

Quick way to test from CLI:
~$path/to/Scribus -l ru
and then when you want to get back to english close Scribus and run this:
~$path/to/Scribus -l en

Kunda

2015-09-26 21:17

updater   ~0036403

Need someone on OSX running 1.5.1 to confirm this please

GarryP

2015-09-28 12:20

developer   ~0036423

Using Scribus Version 1.5.1.svn 25 July 2015 - SVN Revision: 20320 Build ID: C-C-T-F-C1.14.2-Mac/-64bit Using Ghostscript version 9.16
I can't replicate the error.
The Preferences dialog appeared as expected after changing the language to Russian.
Changing the language back to English (UK) worked as expected too.

Kunda

2015-09-28 15:02

updater   ~0036424

Last edited: 2015-09-28 15:03

View 3 revisions

GarryP, i updated the instructions on how to reproduce. Could you check again.

Also might want to:
brew update && brew upgrade --all && brew reinstall --HEAD scribus --verbose


Kunda

2015-09-28 17:25

updater   ~0036426

Oh no...
I'm trapped in Russian localization
~$path/to/Scribus -l en_US
doesn't restart in english

cbradney

2015-09-28 18:27

administrator   ~0036428

Kunda, please submit a bug and get berteh? to check and fix the language selection from command line. Thanks

Kunda

2015-09-28 20:45

updater   ~0036435

Bug submitted: 0013380

Kunda

2015-09-30 19:50

updater   ~0036459

Alex P. updated Russian localization via Transifex. Need to upload that to SVN

Kunda

2015-10-01 21:12

updater   ~0036462

Last edited: 2015-10-01 21:13

View 2 revisions

Craig,
So I moved the Transifex russian .ts file in to
/Users/blah/Applications/Scribus.app/Contents/share/scribus/translations/
but oddly enough all the files were *.qm

Just a sidenote:
I wondered and so I renamed the .ts file to .qm and I can't reproduce the bug. But russian translation doesn't work now.

Kunda

2015-10-22 21:58

updater  

for_use_scribus_scribus_ru.ts (1,181,149 bytes)

Kunda

2015-10-22 21:58

updater   ~0036847

Uploaded Prokoudine's .ru update to fix the bug

Kunda

2015-10-31 18:28

updater  

for_use_scribus_scribus_ru.qm (707,639 bytes)

Kunda

2015-10-31 18:30

updater   ~0037136

Ran lrelease on the .ts file to generate a .qm file.
Can you commit please.
Tagging this as a 'patch'

cbradney

2015-10-31 20:37

administrator   ~0037137

we dont commit qm files, the build process converts ts to qm.

Kunda

2015-10-31 21:08

updater   ~0037138

Craig, Apologies. My intention was to expedite the process by streamlining it.

cbradney

2015-11-04 21:52

administrator   ~0037226

ts file committed

Kunda

2015-11-04 22:02

updater   ~0037227

Committed by Craig in r20527
ts file translations by Alex Prokoudine

Kunda

2015-11-05 02:28

updater   ~0037231

Updating RU .ts file didn't fix issue.
When I start scribus from CLI with:
$scribus -l ru

and press cmd+,
I get this menu (see attached menu) instead of the PP appearing/disappearing

Kunda

2015-11-05 02:29

updater  

ru-issue.png (71,384 bytes)
ru-issue.png (71,384 bytes)

Kunda

2016-03-25 13:43

updater  

Russian.gif (4,168,396 bytes)

Kunda

2016-03-25 13:48

updater   ~0039412

Last edited: 2016-03-25 13:48

View 2 revisions

Uploaded new gif showing some different behavior.
1)start scribus via CLI
$scribus -l ru

2) press
cmd + ,

3) Instead of the Preferences menu I think the Marks menu opens
4) Close the menu
5) repeat step 2
6) PP palette will either close or open depending on what state it's in
7) repeat step 2
8) same behavior as in step 6

See updated screencast Russian.gif

Kunda

2016-03-25 13:49

updater   ~0039413

utnik, Would you please test on OSX and report? Thanks!

utnik

2016-03-25 15:07

updater   ~0039414

tested with scribus1.5.1svn (21004) on macOS 10.11.4
- the 4th menu item ('preferences') opens 'document setup'
- 'cmd' '+' does nothing
- after 'cmd' '+' 'preferences' in the menu opens 'properties'
…strange!

Kunda

2016-03-25 15:19

updater   ~0039415

utnik, thanks
BTw, it's cmd + ',' (comma)

Issue History

Date Modified Username Field Change
2015-06-30 00:59 Kunda New Issue
2015-06-30 01:08 Kunda File Added: scribus-ru.m4v
2015-06-30 01:08 Kunda Note Added: 0035569
2015-07-01 23:36 Kunda Note Added: 0035613
2015-07-01 23:37 Kunda Note Edited: 0035613 View Revisions
2015-07-01 23:37 Kunda Note Edited: 0035613 View Revisions
2015-07-01 23:38 Kunda Description Updated View Revisions
2015-07-09 23:16 Kunda Target Version => 1.5.1
2015-09-26 21:17 Kunda Note Added: 0036403
2015-09-28 12:20 GarryP Note Added: 0036423
2015-09-28 15:02 Kunda Note Added: 0036424
2015-09-28 15:02 Kunda Steps to Reproduce Updated View Revisions
2015-09-28 15:03 Kunda Note Edited: 0036424 View Revisions
2015-09-28 15:03 Kunda Note Edited: 0036424 View Revisions
2015-09-28 17:25 Kunda Note Added: 0036426
2015-09-28 18:27 cbradney Note Added: 0036428
2015-09-28 20:45 Kunda Note Added: 0036435
2015-09-28 20:46 Kunda Relationship added parent of 0013380
2015-09-30 19:50 Kunda Note Added: 0036459
2015-10-01 21:12 Kunda Note Added: 0036462
2015-10-01 21:13 Kunda Note Edited: 0036462 View Revisions
2015-10-04 14:31 cbradney Target Version 1.5.1 => 1.5.2
2015-10-22 21:58 Kunda File Added: for_use_scribus_scribus_ru.ts
2015-10-22 21:58 Kunda Note Added: 0036847
2015-10-22 22:24 Kunda Assigned To => cbradney
2015-10-22 22:24 Kunda Status new => assigned
2015-10-31 18:28 Kunda File Added: for_use_scribus_scribus_ru.qm
2015-10-31 18:30 Kunda Patch No => Yes
2015-10-31 18:30 Kunda Note Added: 0037136
2015-10-31 20:37 cbradney Note Added: 0037137
2015-10-31 21:08 Kunda Note Added: 0037138
2015-11-04 21:52 cbradney Note Added: 0037226
2015-11-04 22:02 Kunda Note Added: 0037227
2015-11-05 01:45 Kunda Status assigned => resolved
2015-11-05 01:45 Kunda Fixed in Version => 1.5.1svn
2015-11-05 01:45 Kunda Resolution open => fixed
2015-11-05 02:28 Kunda Note Added: 0037231
2015-11-05 02:28 Kunda Status resolved => confirmed
2015-11-05 02:29 Kunda File Added: ru-issue.png
2016-01-23 17:14 cbradney Target Version 1.5.2 => 1.5.3
2016-01-23 17:15 cbradney Target Version 1.5.3 => 1.5.4.svn
2016-03-25 13:43 Kunda File Added: Russian.gif
2016-03-25 13:48 Kunda Note Added: 0039412
2016-03-25 13:48 Kunda Note Edited: 0039412 View Revisions
2016-03-25 13:49 Kunda Note Added: 0039413
2016-03-25 15:07 utnik Note Added: 0039414
2016-03-25 15:19 Kunda Note Added: 0039415
2018-04-30 12:39 jghali Target Version 1.5.4.svn => 1.5.5