View Issue Details

IDProjectCategoryView StatusLast Update
0013255ScribusUsabilitypublic2016-11-11 22:54
Reporterrubo77 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.10
Product Version1.5.0 
Target VersionFixed in Version1.5.3.svn 
Summary0013255: Menus broken on high resolution screen
DescriptionWhen you set the overall zoom to 2x in your Settings ("Scale menues andd Titlebars") in unity-control-center the menues and dropdown boxes are huge and really hard to use
Steps To Reproduceset the value to 2 like in the attached image. Restart Scribus after applying the zoom setting.
TagsHiDPI
PatchNo

Relationships

duplicate of 0014023 closed 1.5.2svn HiDPI GUI font too small 
related to 0013204 closedfschmid Unusably tiny tool icons on HiDPI screen on Ubuntu Unity desktop 
related to 0013805 closedcbradney Scribus is mostly unusable on high ppi notebook displays 
related to 0013818 new HiDPI workaround: Ability to change Scribus UI icons size via right mouse button 

Activities

rubo77

2015-07-23 22:31

reporter  

rK9ep.png (120,064 bytes)
rK9ep.png (120,064 bytes)

cbradney

2015-07-25 06:23

administrator   ~0035887

Screenshot please, plus tell us what version of Qt you are using.

rubo77

2015-07-26 07:57

reporter   ~0035903

I added a Screenshot showing the problems.

$ qmake -v

QMake version 2.01a

Using Qt version 4.8.6 in /usr/lib/i386-linux-gnu

Kunda

2015-07-26 12:31

updater   ~0035904

Last edited: 2015-07-26 12:34

View 2 revisions

rubo, How can you be running 1.5 and still be using Qt4 ?
Can you show a screenshot for Scribus v1.5 (not 1.4.x) using Qt5.3 or higher?

Edit: clarity

rubo77

2015-07-27 22:08

reporter   ~0035920

Last edited: 2015-07-27 22:08

View 2 revisions

The screenshot is not 1.4 at all. I use scribus-trunk 1.5.1svn always

And I use Ubuntu 14.10, not possible to change qt

Can't you see the problem, when you set global zoom to 2x?

Kunda

2015-07-27 22:15

updater  

Kunda

2015-07-27 22:16

updater   ~0035922

rubo, thanks for screenshot. I've made the image smaller so it will display (needs to be under 500k to display in the Bugtracker).

Kunda

2016-03-10 13:37

updater   ~0039100

https://www.phoronix.com/scan.php?page=news_item&px=Cross-Platform-HiDPI-Qt-5.6

Kunda

2016-05-15 02:26

updater   ~0041067

andreasn1, please test this ticket as well. Thanks!

Kunda

2016-05-15 13:13

updater   ~0041082

Last edited: 2016-05-15 13:13

View 2 revisions

khaled, can you reproduce ?

user5122

2016-05-15 13:38

  ~0041085

The Hi-DPI patch that was applied should fix this, but I can’t test on Ubuntu right now.

Kunda

2016-05-15 19:19

updater   ~0041100

rubo, please retest this with the latest scribus 1.5.2svn
You can use the scribus-trunk PPA at https://launchpad.net/~scribus/+archive/ubuntu/ppa

Kunda

2016-05-16 16:52

updater   ~0041133

No response from OP. resolving this issue due to 0014004 and 0013204 being merged + closing 0014023

rubo77

2016-05-17 08:08

reporter   ~0041155

I will check tomorrow on 1.5.2

rubo77

2016-05-18 09:58

reporter   ~0041179

The same problem on 1.5.2svn~r21332~20160517~ppa53~ubuntu15.10.1

rubo77

2016-05-18 10:18

reporter   ~0041181

the Font-size on 0014023 is ok in Unity on Ubuntu 15.10, but 0013805 and 0013204 are still unsolved in 1.5.2svn~r21332~20160517~ppa53~ubuntu15.10.1

But I cannot reopen those tickets

jghali

2016-05-18 10:33

administrator   ~0041182

Last edited: 2016-05-18 10:33

View 2 revisions

13805 is a duplicate so must not be reopened. And 0013204 requires Qt 5.6 which ubuntu 15.10/16.04 do not have natively.

rubo77

2016-05-18 10:56

reporter   ~0041183

0013204 is not an issue only to QT5.6 because it is the same on my laptop. and still exists, but I cannot post this comment there. Why is 0013204 closed?

So 0013805 is a duplicate of this ticket here?

jghali

2016-05-18 11:34

administrator   ~0041185

Last edited: 2016-05-18 12:01

View 2 revisions

0013204 has been closed because it has been tested that it works and there are even screenshots posted for eg. in 0014068 that shows the fix works. But as mentionned previously, for the fix to work, Scribus must be compiled with Qt 5.6 headers. Compiling it with Qt 5.5 headers and using Qt 5.6 afterwards won't work.

jghali

2016-05-18 11:39

administrator   ~0041186

Consequence: as current Ubuntu distros do not have Qt 5.6, it is likely that you won't be able to get packages working correctly in respect to these HiDPI issues from PPAs.

Kunda

2016-05-18 12:03

updater   ~0041187

mapreri, what are the chances of getting the PPA for scribus-trunk to use Qt5.6 ?

user5122

2016-05-18 12:12

  ~0041190

What version of Qt due have? Versions before Qt 5.6 need an environment variable (export QT_DEVICE_PIXEL_RATIO=2) to enable hi-DPI mode. With Qt 5.6 it should work out of box.

mapreri

2016-05-18 12:31

developer   ~0041192

Kunda: < 0. I won't get the PPA to depend on a Qt that is not the one used in the system, because that can very very easily break other installed applications (besides, it would be prohibitive for me to maintain). Much less on a Qt version that is not even in the current development release.

Qt is not a random library that you can just backport and shrug hoping for the best.
(technically speaking, one could have 2 Qt installation, but I don't want/can't maintain that)

Kunda

2016-05-19 13:53

updater   ~0041216

mapreri, thanks for the elaboration and you position on the issue.

Thanks to Khaled, people can see that one can run Scribus trunk on Trusty, as Khaled got it to work for Travis-CI (https://github.com/scribusproject/scribus/blob/master/.travis.yml#L25-L34). It may be time for people to upgrade to Xenial <shrug>

Issue History

Date Modified Username Field Change
2015-07-23 22:31 rubo77 New Issue
2015-07-23 22:31 rubo77 File Added: rK9ep.png
2015-07-25 06:23 cbradney Note Added: 0035887
2015-07-26 07:57 rubo77 Note Added: 0035903
2015-07-26 07:57 rubo77 File Added: Arbeitsfläche1_0013200x1800_2015072609:35:43.png
2015-07-26 12:31 Kunda Note Added: 0035904
2015-07-26 12:34 Kunda Note Edited: 0035904 View Revisions
2015-07-27 22:08 rubo77 Note Added: 0035920
2015-07-27 22:08 rubo77 Note Edited: 0035920 View Revisions
2015-07-27 22:15 Kunda File Added: Arbeitsflache1_0013200x1800_2015072609_35_43-1.jpg
2015-07-27 22:16 Kunda File Deleted: Arbeitsfläche1_0013200x1800_2015072609:35:43.png
2015-07-27 22:16 Kunda Note Added: 0035922
2015-07-29 21:05 cbradney Relationship added related to 0013204
2015-11-05 13:18 Kunda Target Version => 1.6 milestone
2016-03-09 13:10 Kunda Tag Attached: HiDPI
2016-03-10 13:23 Kunda Summary Menues broken on high resolution screen => Menus broken on high resolution screen
2016-03-10 13:25 Kunda Relationship added related to 0013805
2016-03-10 13:37 Kunda Note Added: 0039100
2016-03-17 13:29 Kunda Relationship added related to 0013818
2016-05-15 02:26 Kunda Note Added: 0041067
2016-05-15 13:13 Kunda Note Added: 0041082
2016-05-15 13:13 Kunda Note Edited: 0041082 View Revisions
2016-05-15 13:38 user5122 Note Added: 0041085
2016-05-15 19:17 Kunda Tag Attached: #pending
2016-05-15 19:19 Kunda Note Added: 0041100
2016-05-16 16:52 Kunda Note Added: 0041133
2016-05-16 16:52 Kunda Relationship added duplicate of 0014023
2016-05-16 16:52 Kunda Status new => resolved
2016-05-16 16:52 Kunda Resolution open => duplicate
2016-05-16 16:52 Kunda Assigned To => Kunda
2016-05-16 16:52 Kunda Status resolved => closed
2016-05-16 16:52 Kunda Assigned To Kunda =>
2016-05-16 16:53 Kunda Target Version 1.6 milestone =>
2016-05-16 17:11 Kunda Tag Detached: #pending
2016-05-17 08:08 rubo77 Note Added: 0041155
2016-05-17 08:08 rubo77 Status closed => feedback
2016-05-17 08:08 rubo77 Resolution duplicate => reopened
2016-05-18 09:58 rubo77 Note Added: 0041179
2016-05-18 09:58 rubo77 Status feedback => new
2016-05-18 10:18 rubo77 Note Added: 0041181
2016-05-18 10:33 jghali Note Added: 0041182
2016-05-18 10:33 jghali Note Edited: 0041182 View Revisions
2016-05-18 10:56 rubo77 Note Added: 0041183
2016-05-18 11:34 jghali Note Added: 0041185
2016-05-18 11:39 jghali Note Added: 0041186
2016-05-18 12:01 jghali Note Edited: 0041185 View Revisions
2016-05-18 12:03 Kunda Note Added: 0041187
2016-05-18 12:12 user5122 Note Added: 0041190
2016-05-18 12:31 mapreri Note Added: 0041192
2016-05-19 13:53 Kunda Note Added: 0041216
2016-05-29 09:03 Kunda Status new => resolved
2016-05-29 09:03 Kunda Fixed in Version => 1.5.3.svn
2016-05-29 09:03 Kunda Resolution reopened => fixed
2016-05-29 09:03 Kunda Assigned To => Kunda
2016-05-29 09:24 Kunda Assigned To Kunda =>
2016-11-11 22:54 cbradney Status resolved => closed