View Issue Details

IDProjectCategoryView StatusLast Update
0013602ScribusImport / Exportpublic2016-04-28 00:42
ReporterJLuc Assigned Tofschmid  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version1.5.2.svn 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0013602: Crash on opening SLA with reference to item mark
DescriptionOpening the uploaded file crashes scribus.
It seems related to a "reference to item" mark (that displayed well on screen but that might have caused a crash beforehand).

I provide a backtrace.

The text in "p138 alt empty" has been deleted prior to reporting (without causing any change in the backtrace)
Additional InformationProgram received signal SIGABRT, Aborted.
0x00007ffff2e38cc9 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: Aucun fichier ou dossier de ce type.

(gdb) bt
#0 0x00007ffff2e38cc9 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
0000001 0x00007ffff2e3c0d8 in __GI_abort () at abort.c:89
0000002 0x00007ffff2e75394 in __libc_message (do_abort=do_abort@entry=1, fmt=fmt@entry=0x7ffff2f83b28 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
0000003 0x00007ffff2e8166e in malloc_printerr (ptr=<optimized out>, str=0x7ffff2f7fc19 "free(): invalid pointer", action=1) at malloc.c:4996
0000004 _int_free (av=<optimized out>, p=<optimized out>, have_lock=0) at malloc.c:3840
0000005 0x00007ffff74ba408 in QString::operator=(QString const&) () from /localbin/Qt5.5.0/5.5/gcc_64/lib/libQt5Core.so.5
0000006 0x0000000000a374f5 in Mark::setItemName (this=0x4498090, name=...) at /home/jluc/dev/scribus/svn/scribus/marks.h:62
0000007 0x0000000000a154e8 in PageItem_TextFrame::layout (this=0x4532a10) at /home/jluc/dev/scribus/svn/scribus/pageitem_textframe.cpp:1530
0000008 0x0000000000a1d747 in PageItem_TextFrame::layout (this=0x45168f0) at /home/jluc/dev/scribus/svn/scribus/pageitem_textframe.cpp:3152
0000009 0x0000000000a145b9 in PageItem_TextFrame::layout (this=0x461f1a0) at /home/jluc/dev/scribus/svn/scribus/pageitem_textframe.cpp:1323
0000010 0x0000000000caf863 in ScribusMainWindow::loadDoc (this=0x1bf9400, fileName=...) at /home/jluc/dev/scribus/svn/scribus/scribus.cpp:3737
0000011 0x0000000000ca040f in ScribusMainWindow::startUpDialog (this=0x1bf9400) at /home/jluc/dev/scribus/svn/scribus/scribus.cpp:2084
0000012 0x0000000000cf3c55 in ScribusCore::startGUI (this=0x1bfa5a0, showSplash=true, showFontInfo=false, showProfileInfo=false, newGuiLanguage=..., prefsUserFile=...)
    at /home/jluc/dev/scribus/svn/scribus/scribuscore.cpp:129
0000013 0x0000000000ceffa7 in ScribusQApp::init (this=0x7fffffffded0) at /home/jluc/dev/scribus/svn/scribus/scribusapp.cpp:372
0000014 0x0000000001277655 in mainApp (argc=1, argv=0x7fffffffe048) at /home/jluc/dev/scribus/svn/scribus/main_nix.cpp:74
0000015 0x00000000012775f6 in main (argc=1, argv=0x7fffffffe048) at /home/jluc/dev/scribus/svn/scribus/main_nix.cpp:54

[EDIT]
Editing the SLA enables to open the file :

- delete both
<Marks>
    <Mark label="PPP140" type="1" ItemID="213501392"/>
</Marks>

- and
<MARK label="PPP140" type="1"/>


And see : no more crash.

BTW PP140 exists :
<PAGEOBJECT XPOS="1440" YPOS="834.321850393701" OwnPage="1" ItemID="187686560" PTYPE="6" WIDTH="27.7183282858882" HEIGHT="32.1437007874016" FRTYPE="3" CLIPEDIT="1" PWIDTH="1" PLINEART="1" ANNAME="PPP140" path="M0 0 L27.7183 0 L27.7183 32.1437 L0 32.1437 L0 0 Z" copath="M0 0 L27.7183 0 L27.7183 32.1437 L0 32.1437 L0 0 Z" gXpos="1440" gYpos="834.321850393701" gWidth="0" gHeight="0" LAYER="0"/>


TagsNo tags attached.
PatchNo

Relationships

related to 0013987 confirmed Saving item marks seems to be buggy (split from 0013602

Activities

JLuc

2015-12-14 18:04

developer  

p138 alt empty.sla (138,133 bytes)

Kunda

2015-12-15 02:12

manager   ~0037921

Last edited: 2015-12-15 02:13

View 3 revisions

Signal 6 on OSX 10.10.5 1.5.1svn r20620

Scribus150Format::updateNames2Ptr() : wrong mark [ "PPP140" ] data - item [ 213501392 ] not exists - DELETING MARK
ASSERT: "size == 0 || offset < 0 || size_t(offset) >= sizeof(QArrayData)" in file /usr/local/opt/qt5/include/QtCore/qarraydata.h, line 54
Assertion failed: (false), function abort_on_error, file /tmp/scribus20151213-38310-z7gmrh/scribus/scribuscore.cpp, line 76.
Scribus Crash
-------------
Scribus crashes due to Signal 6
Calling Emergency Save


Kunda

2016-03-20 18:41

manager   ~0039294

Signal 11 now instead of Signal 6 (OSX 10.10.5 1.5.2svn r21098

added bt.txt

Kunda

2016-03-20 18:41

manager  

bt.txt (4,835 bytes)
Scribus150Format::updateNames2Ptr() : wrong mark [ "PPP140" ] data - item [ 213501392 ] not exists - DELETING MARK
Erase mark [ "PPP140" ] failed - was it defined?
pathForIcon: Unable to load icon /usr//local/Cellar/scribus/HEAD/Scribus.app/Contents/share/scribus/icons/1_5_1/testfill.png: File not found
setBestEncoding for  LiberationSans-Regular  with  675 glyphs, hasNames= 512 , POST size= 5182
Checking cmap  0 ( 0 , 3 , 0 ) format  4
found Unicode enc for Liberation Sans Regular as map 0 with 662 glyphs
Checking cmap  1 ( 1 , 0 , 0 ) format  6
Checking cmap  2 ( 3 , 1 , 0 ) format  4
found Unicode enc for Liberation Sans Regular as map 2 with 1324 glyphs
using Unicode enc for Liberation Sans Regular
load post 0 5182
setBestEncoding for  Wingdings-Regular  with  226 glyphs, hasNames= 512 , POST size= 2692
Checking cmap  0 ( 1 , 0 , 0 ) format  0
Checking cmap  1 ( 3 , 0 , 0 ) format  4
found Symbol enc for Wingdings Regular
using special enc for Wingdings Regular
load post 0 2692
Process 7568 stopped
* thread #1: tid = 0xf3d73, 0x000000010000a1c4 Scribus`QBasicAtomicInteger<int>::load() const + 4, queue = 'com.apple.main-thread', stop reason = EXC_BAD_ACCESS (code=EXC_I386_GPFLT)
    frame #0: 0x000000010000a1c4 Scribus`QBasicAtomicInteger<int>::load() const + 4
Scribus`QBasicAtomicInteger<int>::load:
->  0x10000a1c4 <+4>: movl   (%rdi), %eax
    0x10000a1c6 <+6>: popq   %rbp
    0x10000a1c7 <+7>: retq

Scribus`ScDLManager::qt_static_metacall:
    0x10000a1c8 <+0>: pushq  %rbp
(lldb) bt
* thread #1: tid = 0xf3d73, 0x000000010000a1c4 Scribus`QBasicAtomicInteger<int>::load() const + 4, queue = 'com.apple.main-thread', stop reason = EXC_BAD_ACCESS (code=EXC_I386_GPFLT)
  * frame #0: 0x000000010000a1c4 Scribus`QBasicAtomicInteger<int>::load() const + 4
    frame #1: 0x000000010000da5e Scribus`QtPrivate::RefCount::ref() + 14
    frame #2: 0x000000010015b93c Scribus`Mark::getString() + 18
    frame #3: 0x0000000100171a0e Scribus`PageItem::ExpandToken(unsigned int) + 496
    frame #4: 0x00000001001cae1e Scribus`PageItem_TextFrame::layout() + 4424
    frame #5: 0x00000001001d0272 Scribus`PageItem_TextFrame::layout() + 26012
    frame #6: 0x00000001001c9d93 Scribus`PageItem_TextFrame::layout() + 189
    frame #7: 0x00000001003a5268 Scribus`ScribusMainWindow::loadDoc(QString) + 7368
    frame #8: 0x00000001003adf83 Scribus`ScribusMainWindow::slotFileOpen() + 615
    frame #9: 0x0000000100013683 Scribus`ScribusMainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) + 3111
    frame #10: 0x00000001030d85bd QtCore`QMetaObject::activate(QObject*, int, int, void**) + 749
    frame #11: 0x0000000101bf496f QtWidgets`QAction::activate(QAction::ActionEvent) + 303
    frame #12: 0x00000001030d85bd QtCore`QMetaObject::activate(QObject*, int, int, void**) + 749
    frame #13: 0x00000001030d16dc QtCore`QObject::event(QEvent*) + 156
    frame #14: 0x0000000101bfdb76 QtWidgets`QApplicationPrivate::notify_helper(QObject*, QEvent*) + 294
    frame #15: 0x0000000101c004c0 QtWidgets`QApplication::notify(QObject*, QEvent*) + 5648
    frame #16: 0x00000001030a53f4 QtCore`QCoreApplication::notifyInternal2(QObject*, QEvent*) + 164
    frame #17: 0x00000001030a6014 QtCore`QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) + 596
    frame #18: 0x0000000103e21bae libqcocoa.dylib`QCocoaEventDispatcherPrivate::processPostedEvents() + 190
    frame #19: 0x0000000103e22481 libqcocoa.dylib`QCocoaEventDispatcherPrivate::postedEventsSourceCallback(void*) + 33
    frame #20: 0x00007fff95652a01 CoreFoundation`__CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
    frame #21: 0x00007fff95644b8d CoreFoundation`__CFRunLoopDoSources0 + 269
    frame #22: 0x00007fff956441bf CoreFoundation`__CFRunLoopRun + 927
    frame #23: 0x00007fff95643bd8 CoreFoundation`CFRunLoopRunSpecific + 296
    frame #24: 0x00007fff95fdb56f HIToolbox`RunCurrentEventLoopInMode + 235
    frame #25: 0x00007fff95fdb1ee HIToolbox`ReceiveNextEventCommon + 179
    frame #26: 0x00007fff95fdb12b HIToolbox`_BlockUntilNextEventMatchingListInModeWithFilter + 71
    frame #27: 0x00007fff917458ab AppKit`_DPSNextEvent + 978
    frame #28: 0x00007fff91744e58 AppKit`-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 346
    frame #29: 0x00007fff9173aaf3 AppKit`-[NSApplication run] + 594
    frame #30: 0x0000000103e2137f libqcocoa.dylib`QCocoaEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 2191
    frame #31: 0x00000001030a17a1 QtCore`QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 401
    frame #32: 0x00000001030a5a65 QtCore`QCoreApplication::exec() + 341
    frame #33: 0x00000001007dedc5 Scribus`mainApp(int, char**) + 90
    frame #34: 0x00007fff8c3a55c9 libdyld.dylib`start + 1
    frame #35: 0x00007fff8c3a55c9 libdyld.dylib`start + 1
bt.txt (4,835 bytes)

Kunda

2016-04-18 17:54

manager   ~0040281

Last edited: 2016-04-18 17:56

View 3 revisions

OSX 10.10.5 1.5.2svn r21207
Weird, I can successfully open this in lldb without it crashing.

Without lldb it crashes Signal 11 again. Here is the output:

Scribus150Format::updateNames2Ptr() : wrong mark [ "PPP140" ] data - item [ 213501392 ] not exists - DELETING MARK
Erase mark [ "PPP140" ] failed - was it defined?
pathForIcon: Unable to load icon /usr/local/Cellar/scribus/HEAD/Scribus.app/Contents/share/scribus/icons/1_5_1/testfill.png: File not found
setBestEncoding for  LiberationSans-Regular  with  675 glyphs, hasNames= 512 , POST size= 5182
Checking cmap  0 ( 0 , 3 , 0 ) format  4
found Unicode enc for Liberation Sans Regular as map 0 with 662 glyphs
Checking cmap  1 ( 1 , 0 , 0 ) format  6
Checking cmap  2 ( 3 , 1 , 0 ) format  4
found Unicode enc for Liberation Sans Regular as map 2 with 1324 glyphs
using Unicode enc for Liberation Sans Regular
load post 0 5182
setBestEncoding for  Wingdings-Regular  with  226 glyphs, hasNames= 512 , POST size= 2692
Checking cmap  0 ( 1 , 0 , 0 ) format  0
Checking cmap  1 ( 3 , 0 , 0 ) format  4
found Symbol enc for Wingdings Regular
using special enc for Wingdings Regular
load post 0 2692
Scribus Crash
-------------
Scribus crashes due to Signal # 11
Scribus(23145,0x10fc8e000) malloc: *** error for object 0x7f9dfde3a3a0: incorrect checksum for freed object - object was probably modified after being freed.
*** set a breakpoint in malloc_error_break to debug


Kunda

2016-04-18 18:16

manager   ~0040282

Franz, i'm punting to you if you have a moment to look at this.

cbradney

2016-04-18 18:48

administrator   ~0040283

when you have this kind of replication status, it often means there is initialised memory in the debugger (ie all reset to 0 or all randomised) vs when not in the debugger.... Maybe the memory allocation work in one case and not in the other for the same reason.

fschmid

2016-04-18 19:36

administrator   ~0040284

Have fixed the crash, but somehow saving item marks seems to be buggy.

Kunda

2016-04-18 21:07

manager   ~0040291

is there an open bug for the buggy phenomena of saving item marks ?

Kunda

2016-04-19 04:20

manager   ~0040297

Can't reproduce crash but still see the output
Scribus150Format::updateNames2Ptr() : wrong mark [ "PPP140" ] data - item [ 213501392 ] not exists - DELETING MARK

Kunda

2016-04-28 00:37

manager   ~0040556

splitting in to new ticket based on Franz's comment 0013602:0040284

Kunda

2016-04-28 00:42

manager   ~0040557

buggy mark issue has been split in to 0013987
Closing this ticket

Issue History

Date Modified Username Field Change
2015-12-14 18:04 JLuc New Issue
2015-12-14 18:04 JLuc File Added: p138 alt empty.sla
2015-12-14 18:04 JLuc File Added: bt signal 6
2015-12-14 18:06 JLuc Description Updated View Revisions
2015-12-14 18:06 JLuc Additional Information Updated View Revisions
2015-12-14 18:06 JLuc File Deleted: bt signal 6
2015-12-14 18:08 JLuc Description Updated View Revisions
2015-12-14 18:10 JLuc Description Updated View Revisions
2015-12-14 18:16 JLuc Description Updated View Revisions
2015-12-14 18:27 JLuc Additional Information Updated View Revisions
2015-12-14 18:29 JLuc Additional Information Updated View Revisions
2015-12-14 18:29 JLuc Additional Information Updated View Revisions
2015-12-14 18:30 JLuc Summary Crash on opening SLA => Crash on opening SLA wih reference to item mark
2015-12-15 02:12 Kunda Note Added: 0037921
2015-12-15 02:13 Kunda Status new => confirmed
2015-12-15 02:13 Kunda Note Edited: 0037921 View Revisions
2015-12-15 02:13 Kunda Note Edited: 0037921 View Revisions
2015-12-15 03:49 Kunda Summary Crash on opening SLA wih reference to item mark => Crash on opening SLA with reference to item mark
2015-12-15 03:49 Kunda Severity minor => crash
2016-03-20 18:41 Kunda Note Added: 0039294
2016-03-20 18:41 Kunda File Added: bt.txt
2016-04-18 17:54 Kunda Note Added: 0040281
2016-04-18 17:56 Kunda Note Edited: 0040281 View Revisions
2016-04-18 17:56 Kunda Note Edited: 0040281 View Revisions
2016-04-18 18:15 Kunda Assigned To => fschmid
2016-04-18 18:15 Kunda Status confirmed => assigned
2016-04-18 18:16 Kunda Note Added: 0040282
2016-04-18 18:16 Kunda Target Version => 1.6 milestone
2016-04-18 18:48 cbradney Note Added: 0040283
2016-04-18 19:36 fschmid Note Added: 0040284
2016-04-18 19:36 fschmid Product Version => 1.5.2.svn
2016-04-18 19:36 fschmid Target Version 1.6 milestone => 1.5.2
2016-04-18 19:36 fschmid Status assigned => resolved
2016-04-18 19:36 fschmid Fixed in Version => 1.5.2.svn
2016-04-18 19:36 fschmid Resolution open => fixed
2016-04-18 21:07 Kunda Note Added: 0040291
2016-04-19 04:20 Kunda Note Added: 0040297
2016-04-28 00:37 Kunda Note Added: 0040556
2016-04-28 00:39 Kunda Issue cloned: 0013987
2016-04-28 00:39 Kunda Relationship added related to 0013987
2016-04-28 00:42 Kunda Note Added: 0040557
2016-04-28 00:42 Kunda Status resolved => closed