View Issue Details

IDProjectCategoryView StatusLast Update
0013978ScribusUser Interfacepublic2019-12-01 19:44
ReporterPeterBenedek Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
Platformx86 and x64OSLinux Mint OS Version17.3 (64bit)
Product Version1.5.2.svn 
Target Version1.5.5Fixed in Version1.5.3.svn 
Summary0013978: Regression: Docked palettes position is not saved between sessions (0011544)
DescriptionAntecedent: 0011544

- Open three docked panel (Windows -- Properties, Laers, Align and Distribute)
- Open Windows -- "Arrange Pages" panel
- Dock "Arrange Pages" panel
- Close "Arrange Pages" panel
- Close Scribus
- Open Scribus (New empty document)
- Edit -- Master pages

"Arrange Pages" panel cause confusion
Tagsindigodock
PatchNo

Relationships

related to 0011544 closedfschmid Docked palettes position / size is not saved between sessions. 
related to 0013808 closedfschmid Regression: Ghost Palettes 
related to 0009719 confirmed Palettes/Windows position not saved after restart (or even in the same session) 
related to 0009707 closed Problems while using 2 monitors; Scribus with non-default Monitor 
related to 0010623 closedcbradney OSX Dual Screen bug: Starting Scribus results in the Properties Window being displayed with a position of -1280 
has duplicate 0014446 closed New Text Properties panel distract the Dock Panel 

Activities

PeterBenedek

2016-04-23 21:07

developer  

ArrangePages.png (19,759 bytes)
ArrangePages.png (19,759 bytes)

Kunda

2016-04-24 00:01

manager   ~0040416

Perhaps related to 0013808 ?

Kunda

2016-04-25 12:09

manager   ~0040467

punting to Franz since seems related to 0011544

Kunda

2016-05-04 05:31

manager   ~0040756

0009719
0009707
0010623
are all related to this ticket.

fschmid

2016-05-06 07:24

administrator   ~0040814

Made some improvements, but these require you to build with Qt-5.6.x

Kunda

2016-05-07 13:17

manager   ~0040868

Franz, does r21295 have any affect on 0009719 / 0009707 / 0010623

Kunda

2016-05-09 03:29

manager   ~0040892

Peter, please retest with latest trunk. Thanks!

PeterBenedek

2016-05-09 07:44

developer   ~0040894

Last edited: 2016-05-09 07:47

View 2 revisions

Tested: r21298

Umph...!

Two problem:

1)
- Must be open 3 tab
- Close Scribus
- Open Scribus

Comment: Scribus forgot window last setting. If was exiting full screen, the window on startup too high, and not fullscreen!


2)
- Open Scribus
- Must be open 3 tab
- Add new tab (e.g. Action History, Outline, etc.)
- If new tab so far was not included tab list: Scribus forgot window last setting. Scribus window too high, and not fullscreen!

cbradney

2017-03-14 21:14

administrator   ~0043597

Please test now. Seems ok here on Ubuntu 16/17/Windows/OSX

PeterBenedek

2017-03-15 09:04

developer   ~0043606

Unfortunately does not work.

Look: https://youtu.be/IJBKYfjy7K4

PeterBenedek

2019-12-01 19:21

developer   ~0047181

Last edited: 2019-12-01 19:22

View 2 revisions

I did the tests again. I can't reproduce the original question, but in one case the scribus still does not work properly.

-- Unpin all windows in Scribus window
-- Close all Windows in Scribus (Properties, Content Properties, Action History etc.)
-- Open Properties, Content Properties, Outline
-- Pin the Properties and Content Properties
-- Close Content properties
Now...
-- Pin Outline above the Properties window
-- Click: Windows menu -- Contet Properties

Result: Disappear the "full screen" scribus window controller and the scribus window will be larger than the vertical size of the screen.



output.gif (648,691 bytes)
output.gif (648,691 bytes)

PeterBenedek

2019-12-01 19:42

developer   ~0047183

Last edited: 2019-12-01 19:44

View 2 revisions

Perhaps can solve the problem if the Scribus does not allow in docker the resizable window to be placed above the fixed window.

Issue History

Date Modified Username Field Change
2016-04-23 21:04 PeterBenedek New Issue
2016-04-23 21:07 PeterBenedek Description Updated View Revisions
2016-04-23 21:07 PeterBenedek File Added: ArrangePages.png
2016-04-24 00:00 Kunda Summary (0011544) Docked palettes position is not saved between sessions. => (0011544) Docked palettes position is not saved between sessions.
2016-04-24 00:00 Kunda Description Updated View Revisions
2016-04-24 00:01 Kunda Note Added: 0040416
2016-04-25 12:07 Kunda Relationship added related to 0011544
2016-04-25 12:07 Kunda Relationship added related to 0013808
2016-04-25 12:09 Kunda Note Added: 0040467
2016-04-25 12:09 Kunda Assigned To => fschmid
2016-04-25 12:09 Kunda Status new => assigned
2016-04-25 12:09 Kunda Summary (0011544) Docked palettes position is not saved between sessions. => Regression: Docked palettes position is not saved between sessions (0011544)
2016-04-27 22:31 Kunda Target Version => 1.5.2
2016-05-04 05:29 Kunda Relationship added related to 0009719
2016-05-04 05:29 Kunda Relationship added related to 0009707
2016-05-04 05:29 Kunda Relationship added related to 0010623
2016-05-04 05:31 Kunda Note Added: 0040756
2016-05-06 07:24 fschmid Note Added: 0040814
2016-05-07 13:17 Kunda Note Added: 0040868
2016-05-09 03:29 Kunda Note Added: 0040892
2016-05-09 07:44 PeterBenedek Note Added: 0040894
2016-05-09 07:47 PeterBenedek Note Edited: 0040894 View Revisions
2016-05-16 13:41 cbradney Target Version 1.5.2 => 1.5.4.svn
2016-12-02 20:51 Kunda Tag Attached: indigodock
2016-12-10 14:10 jghali Relationship added has duplicate 0014446
2017-03-14 21:14 cbradney Note Added: 0043597
2017-03-14 21:22 cbradney Assigned To fschmid => cbradney
2017-03-14 21:22 cbradney Status assigned => resolved
2017-03-14 21:22 cbradney Resolution open => fixed
2017-03-14 21:22 cbradney Fixed in Version => 1.5.3.svn
2017-03-15 09:04 PeterBenedek Note Added: 0043606
2017-03-15 09:12 PeterBenedek Status resolved => feedback
2017-03-15 09:12 PeterBenedek Resolution fixed => reopened
2018-04-30 12:26 jghali Target Version 1.5.4.svn => 1.5.5
2019-12-01 19:21 PeterBenedek File Added: output.gif
2019-12-01 19:21 PeterBenedek Note Added: 0047181
2019-12-01 19:21 PeterBenedek Status feedback => assigned
2019-12-01 19:22 PeterBenedek Note Edited: 0047181 View Revisions
2019-12-01 19:42 PeterBenedek Note Added: 0047183
2019-12-01 19:44 PeterBenedek Note Edited: 0047183 View Revisions