View Issue Details

IDProjectCategoryView StatusLast Update
0014009ScribusUsabilitypublic2016-05-10 12:04
Reporterjhmtv Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSXOS10.11OS Version10.11.4
Product Version1.5.1 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0014009: Objects in rotated groups are loosing it's position on ungrouping
DescriptionWhen ungrouping complex groups, with rotated elements and even a rotated group. Objects are loosing their current locations.

It seems not to loose only the rotation value from the groups. Object positions seems to be random. It would be nice if ungrouping is possible also from complex groups reflecting rotation properties back to the unwrapped objects (may be as an option), to keep the objects in position.

Undoing this ungrouping is also not possible, objects are not restored to there former position.
Steps To ReproduceLoad document and ungroup the right group. Try also to undo.
Additional InformationThis happens i.E. if you group objects to copy them i.E. to each corner of the document and if you rotate each of them to another 90 degree angle.

For me it would be okay if it is possible to ungroup without loosing the position. Grouping again could be done with a angle of 0, but it will make it easier for the above described scenario, if you want to edit each of the corners in detail after positioning.
Tagsrotate
PatchNo

Relationships

related to 0013509 confirmed undo does not restore group correctly (only as individual unsequential ungrouped parts) 
related to 0014026 assignedfschmid Objects in rotated and moved groups are leaving artifacts once ungrouped 
related to 0014043 closedfschmid Ungrouping with flipped objects, objects are not positioned correctly 
child of 0003812 acknowledged Metabug: Grouped objects 
child of 0013075 acknowledged Metabug: missing display refresh 

Activities

jhmtv

2016-05-01 17:57

reporter  

grouprotated.sla (18,503 bytes)

Kunda

2016-05-02 20:45

updater   ~0040730

Laser, please test. Thanks!

Laser

2016-05-02 22:08

reporter   ~0040739

Last edited: 2016-05-02 22:26

View 3 revisions

A first test says, that with this special document I can reproduce.
But if I rotate the ungrouped elements, group them and rotate group, I cannot reproduce anymore...

This has something to do with copy and paste.
After that this random positioning happens - but only if new group is rotated.

Next test says: can reproduce with just one group.

Kunda

2016-05-02 22:29

updater  

upgroup-bug.gif (792,386 bytes)
upgroup-bug.gif (792,386 bytes)

Kunda

2016-05-02 22:31

updater   ~0040740

I think this ticket is caused by the following issue: (see gif attached)
1) create 2 textboxes (or whatever objects you want)
2) group them together
3) rotate them 90 degrees
4) move them to another location on the SLA needs to be distant from current locations
5) ungroup
Result: Ungroup causes objects to decouple incorrectly

Kunda

2016-05-02 22:41

updater   ~0040741

Reproduced on Arch 1.5.2svn HEAD
OSX 10.10.5 1.5.2svn r21269

Kunda

2016-05-05 16:13

updater   ~0040796

Franz committed fix in r21281
Fixed issue.
Remaining issue are artifacts. I will open a new issue for them

Kunda

2016-05-05 16:40

updater   ~0040798

jhmtv, would you confirm please? thanks

Kunda

2016-05-05 16:51

updater   ~0040799

Split off the remaining issue to 0014026

Kunda

2016-05-06 01:32

updater   ~0040812

Closing

jhmtv

2016-05-09 21:01

reporter   ~0040924

Last edited: 2016-05-09 21:02

View 2 revisions

Much better, but still problems with at least ungrouping flipped bezier lines.
I can provide a simple example.

jhmtv

2016-05-09 21:02

reporter  

testgrouprotate2.sla (17,289 bytes)

jghali

2016-05-09 21:11

administrator   ~0040925

jhmtv, this is a different issue, so please open another one.

Kunda

2016-05-10 12:03

updater   ~0040927

jhmtv opened 0014043 in regards to 0014009:0040924
Closing this ticket now

Issue History

Date Modified Username Field Change
2016-05-01 17:57 jhmtv New Issue
2016-05-01 17:57 jhmtv File Added: grouprotated.sla
2016-05-01 19:54 Kunda Tag Attached: rotate
2016-05-02 02:02 Kunda Relationship added related to 0004491
2016-05-02 02:02 Kunda Relationship deleted related to 0004491
2016-05-02 02:03 Kunda Relationship added child of 0003812
2016-05-02 14:14 Kunda Relationship added related to 0013509
2016-05-02 20:45 Kunda Note Added: 0040730
2016-05-02 22:08 Laser Note Added: 0040739
2016-05-02 22:18 Laser Note Edited: 0040739 View Revisions
2016-05-02 22:26 Laser Note Edited: 0040739 View Revisions
2016-05-02 22:29 Kunda File Added: upgroup-bug.gif
2016-05-02 22:31 Kunda Note Added: 0040740
2016-05-02 22:41 Kunda Note Added: 0040741
2016-05-02 22:41 Kunda Status new => confirmed
2016-05-02 22:41 Kunda Target Version => 1.5.3
2016-05-05 09:12 fschmid Target Version 1.5.3 => 1.5.2
2016-05-05 09:13 fschmid Status confirmed => resolved
2016-05-05 09:13 fschmid Fixed in Version => 1.5.2.svn
2016-05-05 09:13 fschmid Resolution open => fixed
2016-05-05 09:13 fschmid Assigned To => fschmid
2016-05-05 16:13 Kunda Note Added: 0040796
2016-05-05 16:19 Kunda Issue cloned: 0014026
2016-05-05 16:19 Kunda Relationship added related to 0014026
2016-05-05 16:40 Kunda Note Added: 0040798
2016-05-05 16:47 Kunda Tag Attached: fixed
2016-05-05 16:51 Kunda Note Added: 0040799
2016-05-06 01:32 Kunda Note Added: 0040812
2016-05-06 01:32 Kunda Status resolved => closed
2016-05-09 21:01 jhmtv Note Added: 0040924
2016-05-09 21:01 jhmtv Status closed => feedback
2016-05-09 21:01 jhmtv Resolution fixed => reopened
2016-05-09 21:02 jhmtv Note Edited: 0040924 View Revisions
2016-05-09 21:02 jhmtv File Added: testgrouprotate2.sla
2016-05-09 21:11 jghali Note Added: 0040925
2016-05-09 21:11 jghali Status feedback => resolved
2016-05-09 21:11 jghali Resolution reopened => fixed
2016-05-10 11:57 Kunda Relationship added related to 0014043
2016-05-10 12:03 Kunda Relationship added child of 0013075
2016-05-10 12:03 Kunda Note Added: 0040927
2016-05-10 12:03 Kunda Status resolved => closed
2016-05-10 12:04 Kunda Tag Detached: fixed