View Issue Details

IDProjectCategoryView StatusLast Update
0014095ScribusLanguage Toolspublic2016-05-25 07:05
ReporterKunda Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformMacOSXOSYosemiteOS Version10.10.5
Product Version1.5.3.svn 
Target VersionFixed in Version 
Summary0014095: Hyphenation doesn't work as expected (needs more descriptive title)
DescriptionThis was cloned from 0007684 since that bug wasn't reproducible anymore but there was a separate issue. We're trying to understand what the issue is and would appreciate any help in this regard).

The original comments were left over so that when the problem is understood they can be cleaned up.
Steps To ReproduceSee screencast: https://www.dropbox.com/s/yhi6nll883mmaav/example.avi
Additional Information1.5.3svn r21350
Tags#please_test, hyphenation
PatchNo

Relationships

duplicate of 0007684 closedKunda Hyphenation setting in "Document Setup" -> "Hyphenator" jumps back to "English" after having started the hyphenator 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

2016-03-31 08:08

 

Dokumentum-1.sla (25,462 bytes)

jghali

2016-05-24 21:43

administrator   ~0041388

In 1.3.3.x hyphenation language is defined at the frame level and can be set using properties palette. In 1.3.4+ the hyphenation language is determined by the character style language. In both case changing the hyphenation language in document prefs won't miraculously change already defined frame language settings or character style language settings.

basvanschaik

2016-05-24 21:43

reporter   ~0041389

I know, but after setting all options to "Dutch" it still seems to apply English hyphenation patterns. At least it looks like English hyphenation, but I can be wrong.

IMO, this can be caused by two problems:
 1) Scribus applies the wrong patterns
 2) Dutch hyphenation in Scribus is just not perfect.

I wouldn't know how to find out what is wrong...

jghali

2016-05-24 21:43

administrator   ~0041390

I mean changing language in app/doc preferences is not enough as those settings do not affect language settings already defined. In 1.3.3.x you have to change language setting of each frame from text tab in properties palette. In 1.3.5svn you have to change the style languages from style manager. In both case dutch hyphenation is then clearly different from english hyphenation.

basvanschaik

2016-05-24 21:43

reporter   ~0041391

I meant to say that I have changed the style options in the style manager. Browsing the source code in hyphenator.cpp (and adding some debugging statements) made clear that the following statement:
  it->itemText.charStyle(firstC).language()

Does not return a language, but just some empty string. Now
  NewDict(it->itemText.charStyle(firstC).language());

fails to load the wanted dictionairy, but doesn't notice the user of that failure!

I'm debugging some more...

basvanschaik

2016-05-24 21:43

reporter   ~0041392

Just hardcoding the string "Dutch" in hyphenator.cpp does seem to work better (at least my debugging statements show a successful load), but the results are still a bit disappointing...

I'm still wondering if Scribus is actually /using/ the loaded hyph_nl dictionary.

Debugging some more...

jghali

2016-05-24 21:43

administrator   ~0041393

It looks like 1.3.3.x documents loaded in 1.3.5svn do not have language infos set in character styles. Somewhat normal as 1.3.3.x did not have character styles but would be nice if we found a way to handle hyphenation more gracefully in such docs.

basvanschaik

2016-05-24 21:43

reporter   ~0041394

That's probably true, but I did set the correct values for character styles in my 1.3.5 document.

Kunda

2016-05-24 21:43

manager   ~0041395

jghali, i can't reproduce the the main issue of this bug. But it looks like there are other issues discovered through this bug. Please advise how to proceed?

Kunda

2016-05-24 21:43

manager   ~0041396

Peter, this as well :)
(last one for today, I promise)

PeterBenedek

2016-05-24 21:43

developer   ~0041397

Hi Kunda!
I will gladly help! :-)

I do not know, I understand the problem?

Test: https://www.dropbox.com/s/yhi6nll883mmaav/example.avi?dl=0 (recommended download, dropbox blurred viewer)
Setting me will not change after reopen, but seems hyphenation sometimes incorrect.

Kunda

2016-05-24 21:43

manager   ~0041398

I think the name of this ticket needs to be revised. Seems has to do more with language infos set in the character style then with the language in the hyphenator menu changing.

Kunda

2016-05-24 21:43

manager   ~0041399

In other words, the title of this ticket which is what this report is mainly about is not reproducible.

The hyphenation problem is a different bug all together which this ticket is most likely a duplicate of
BTW, I like your screencast! Lets see if we can attach it to a more relevant hyphenation bug.

jghali

2016-05-24 22:41

administrator   ~0041403

Last edited: 2016-05-24 23:32

View 2 revisions

No need to open an issue for something we already know : since 1.3.4+ the hyphenation language setting is only used to define the default character style language when creating doc. Afterwards you MUST use styles as hyphenation use language extracted from styles. I already have mentionned that in https://bugs.scribus.net/view.php?id=7684#c20832

The attached screencast only demonstrates this: once doc is created the hyphenation language setting is useless. You MUST use style language properties.

In CTL, this hyphenation setting in prefs is dead anyway.

You have a version transition issue when moving docs between versions (because of changes in language strings). But we have already 0014806 which deal with that.

Kunda

2016-05-24 23:35

manager   ~0041404

jghali, 0014806 doesn't exist

jghali

2016-05-25 07:05

administrator   ~0041412

Sorry that was 0014086

Issue History

Date Modified Username Field Change
2016-05-24 21:43 Kunda New Issue
2016-05-24 21:43 Kunda Issue generated from: 0007684
2016-05-24 21:43 Kunda Relationship added related to 0007684
2016-05-24 21:45 Kunda Tag Attached: #please_test
2016-05-24 21:45 Kunda Tag Attached: hyphenation
2016-05-24 21:46 Kunda Relationship added child of 0003828
2016-05-24 21:47 Kunda Steps to Reproduce Updated View Revisions
2016-05-24 21:47 Kunda Additional Information Updated View Revisions
2016-05-24 21:48 Kunda Status new => confirmed
2016-05-24 22:41 jghali Note Added: 0041403
2016-05-24 22:41 jghali Relationship replaced duplicate of 0007684
2016-05-24 22:41 jghali Status confirmed => resolved
2016-05-24 22:41 jghali Resolution open => duplicate
2016-05-24 22:41 jghali Assigned To => jghali
2016-05-24 22:41 jghali Status resolved => closed
2016-05-24 23:32 Kunda Note Edited: 0041403 View Revisions
2016-05-24 23:35 Kunda Note Added: 0041404
2016-05-25 07:05 jghali Note Added: 0041412