View Issue Details

IDProjectCategoryView StatusLast Update
0014108ScribusStory Editor / Text Framespublic2016-12-08 21:39
ReporterKunda Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSXOSYosemiteOS Version10.10.5
Product Version1.5.3.svn 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0014108: 'text-to-path' frame doesnt encapsulate text correctly
DescriptionWhy doesn't the the frame border around text-frame objects conform to or at the least encapsulate the whole object?

see gif
Additional Informationuploaded gif and SLA example
Tags#tobeclosed, text to path
PatchNo

Relationships

related to 0014107 confirmed When using 'text to path' and scrolling, parts of the text disappears 
related to 0003667 confirmed Item > Attach text to path, spacing not uniform in U curves 

Activities

Kunda

2016-05-27 20:47

manager  

Kunda

2016-05-27 20:47

manager  

sparta.sla (14,406 bytes)

Kunda

2016-12-05 11:43

manager   ~0042667

Can't reproduce this in 1.5.3svn r21584
Need to test on OSX since bug was originally filed on that platform, @cbradeny do you mind ?

Kunda

2016-12-06 19:33

manager   ~0042736

@utnik can you test on OSX ? If you need the latest nightly it's at https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.3.svn/Scribus15xNightly-20161205.dmg/download

utnik

2016-12-06 21:01

updater   ~0042743

looks ok with 1.5.3svn r21463, in r21564 everything is distorted and the frame doesn't surround the text. (see screenshot)

1.5.3svn21564.png (88,640 bytes)
1.5.3svn21564.png (88,640 bytes)

Kunda

2016-12-06 21:11

manager   ~0042746

@utnik do you test on that nightly link ?

utnik

2016-12-06 21:29

updater   ~0042747

this build doesn't run on my os 10.11.6 – see below.

Process: Scribus [94326]
Path: /Applications/grafikBildLayout/Scribus15xNightly.app/Contents/MacOS/Scribus
Identifier: net.scribus
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Scribus [94326]
User ID: 503

Date/Time: 2016-12-06 22:24:53.388 +0100
OS Version: Mac OS X 10.11.6 (15G1108)
Report Version: 11
Anonymous UUID: 4ED9673C-02AF-E810-B343-CEAEE6698D83

Sleep/Wake UUID: 83D806D8-9C18-42F3-B249-CAFD7F82FDD1

Time Awake Since Boot: 160000 seconds
Time Since Wake: 9300 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/QtXml.framework/Versions/5/QtXml
  Referenced from: /Applications/grafikBildLayout/Scribus15xNightly.app/Contents/MacOS/Scribus
  Reason: image not found

Binary Images:
    0x7fff616e2000 - 0x7fff61719a47 dyld (360.22) <DC81CC9D-651A-3A45-8809-928282052BD3> /usr/lib/dyld

Model: MacBookPro11,3, BootROM MBP112.0138.B17, 4 processors, Intel Core i7, 2.3 GHz, 16 GB, SMC 2.19f12
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Graphics: NVIDIA GeForce GT 750M, NVIDIA GeForce GT 750M, PCIe, 2048 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x134), Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
Bluetooth: Version 4.4.6f1 17910, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0512F, 500.28 GB
USB Device: USB 3.0 Bus
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 17.1

Kunda

2016-12-06 21:46

manager   ~0042749

@utnik turns out that nightly was broken, here's one that isn't https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.3.svn/Scribus15xNightly-20161206-r21599.dmg/download
Sorry :)

utnik

2016-12-07 04:45

updater   ~0042758

both 20161206 nightly builds don't run either – with the same error message.

cbradney

2016-12-07 18:57

administrator   ~0042777

20161207-r21603 should be fine, it opens on my test system ok. Switched back to my Qt5.7 install for the build and its ok.

Issue History

Date Modified Username Field Change
2016-05-27 20:47 Kunda New Issue
2016-05-27 20:47 Kunda File Added: text-to-path-frame-doesnt-encapsulate-text-correctly.gif
2016-05-27 20:47 Kunda File Added: sparta.sla
2016-05-27 20:48 Kunda Tag Attached: text to path
2016-05-27 20:48 Kunda Relationship added related to 0014107
2016-05-27 20:49 Kunda Relationship added related to 0003667
2016-12-05 11:43 Kunda Note Added: 0042667
2016-12-05 11:44 Kunda Tag Attached: #tobeclosed
2016-12-06 19:33 Kunda Note Added: 0042736
2016-12-06 20:23 cbradney Assigned To => Fahad
2016-12-06 20:23 cbradney Status new => resolved
2016-12-06 20:23 cbradney Resolution open => fixed
2016-12-06 20:23 cbradney Fixed in Version => 1.5.3.svn
2016-12-06 21:01 utnik File Added: 1.5.3svn21564.png
2016-12-06 21:01 utnik Note Added: 0042743
2016-12-06 21:11 Kunda Note Added: 0042746
2016-12-06 21:29 utnik Note Added: 0042747
2016-12-06 21:46 Kunda Note Added: 0042749
2016-12-07 04:45 utnik Note Added: 0042758
2016-12-07 11:47 Kunda Assigned To Fahad => cbradney
2016-12-07 11:47 Kunda Status resolved => assigned
2016-12-07 18:57 cbradney Note Added: 0042777
2016-12-07 19:43 Kunda Status assigned => resolved
2016-12-08 21:29 cbradney Status resolved => closed
2016-12-08 21:39 cbradney Target Version => 1.5.3