View Issue Details

IDProjectCategoryView StatusLast Update
0014140ScribusUsabilitypublic2020-05-08 13:19
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx64OSLinux Mint - Ubuntu 16.04OS Version17.3 (64bit)
Product Version1.5.3.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0014140: Cutting/Pasting then deleting footnote frame results in crash
DescriptionTested Ubuntu 16.04; r21370; 1.5.3svn

Unweld Foot/Endnote cut and paste operations crashes.
Steps To Reproduce- Make new document
- Insert TextBox
- Write some character in TextBox
- Insert -- Marks -- Foot/Endnote
- Unweld items
- Click the Foot/Endnote frame and CTRL+X -- CTRL+V -- Delete button

Result:
Scribus Crash signal 11
Additional Information(gdb) bt
#0 0x0000555555a38108 in NotesStyle::isAutoRemoveEmptyNotesFrames() const ()
0000001 0x0000555555a38255 in PageItem_NoteFrame::isAutoNoteFrame() const ()
0000002 0x0000555556024056 in ScribusDoc::itemSelection_DeleteItem(Selection*, bool) ()
0000003 0x0000555555b23b98 in CanvasMode::commonkeyPressEvent_NormalNodeEdit(QKeyEvent*) ()
0000004 0x0000555555b8f623 in CanvasMode_Normal::keyPressEvent(QKeyEvent*) ()
0000005 0x0000555556089673 in ScribusView::eventFilter(QObject*, QEvent*) ()
0000006 0x00007ffff3ad3412 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000007 0x00007ffff452003c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000008 0x00007ffff452709b in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000009 0x00007ffff3ad362b in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000010 0x00007ffff457fb23 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000011 0x00007ffff452005c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000012 0x00007ffff4525516 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000013 0x00007ffff3ad362b in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000014 0x00007ffff3f6c19e in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000015 0x00007ffff3f711c5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000016 0x00007ffff3f54f38 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000017 0x00007fffe634c070 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
0000018 0x00007fffee00e127 in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000019 0x00007fffee00e380 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000020 0x00007fffee00e42c in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000021 0x00007ffff3b29a7f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000022 0x00007ffff3ad0dea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000023 0x00007ffff3ad8e8c in QCoreApplication::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000024 0x000055555659d2a6 in mainApp(int, char**) ()
TagsNo tags attached.
PatchNo

Relationships

related to 0015388 closedjghali Crash when deleting footnote 
related to 0015681 closedjghali Crash when deleting text with footnotes 
child of 0012496 acknowledged Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

Activities

PeterBenedek

2016-06-08 14:26

developer  

0014140.gif (703,211 bytes)
0014140.gif (703,211 bytes)

PeterBenedek

2016-06-08 14:29

developer  

0014140_2.gif (521,175 bytes)
0014140_2.gif (521,175 bytes)

PeterBenedek

2016-06-08 14:35

developer   ~0041631

0014140_2.gif example shows, after CTRL + X, CTRL + V and restart Foot/Endnote: Scribus crashes.

.
.
.
- Click the Foot/Endnote frame and CTRL+X -- CTRL+V
- Resume: Insert -- Marks -- Foot/Endnote

Result: Scribus Crashes

FirasH

2016-06-13 16:56

developer   ~0041655

Confirmed with 1.5.3.svn (21375).

jghali

2020-04-28 01:05

administrator   ~0047578

I did the minimum to prevent the crash. However do not expect more. Copy/pasting endnote/footnote frames presents let's say... interesting challenges...

PeterBenedek

2020-05-03 12:23

developer   ~0047589

Thanks Jean.
I'm reluctant to close this ticket, because the 0014140.gif crash is still happening. Can it stay open?

jghali

2020-05-07 00:20

administrator   ~0047598

Last edited: 2020-05-07 00:20

View 2 revisions

I did an additional commit which prevent the crash shown 0014140.gif in r23677. However same than the previous one : do not expect more. Copy/Pasting footnote frames will currently break them and at the moment I have no clear way to prevent that.

Issue History

Date Modified Username Field Change
2016-06-08 14:25 PeterBenedek New Issue
2016-06-08 14:26 PeterBenedek File Added: 0014140.gif
2016-06-08 14:29 PeterBenedek File Added: 0014140_2.gif
2016-06-08 14:35 PeterBenedek Note Added: 0041631
2016-06-10 07:15 JLuc Summary Unweld Foot/Endnote frame Cut + Paste Here + Delete button result Crash => [crash] Unweld Foot/Endnote frame Cut + Paste Here + Delete button result Crash
2016-06-11 11:01 jghali Summary [crash] Unweld Foot/Endnote frame Cut + Paste Here + Delete button result Crash => Unweld Foot/Endnote frame Cut + Paste Here + Delete button result Crash
2016-06-13 16:56 FirasH Note Added: 0041655
2016-06-13 16:56 FirasH Status new => confirmed
2016-06-13 16:57 FirasH Relationship added child of 0012496
2018-07-30 06:10 PeterBenedek Relationship added related to 0015388
2019-05-11 14:36 PeterBenedek Relationship added has duplicate 0015681
2019-05-11 14:46 PeterBenedek Relationship deleted has duplicate 0015681
2019-05-11 14:46 PeterBenedek Relationship added related to 0015681
2020-04-28 00:59 jghali Summary Unweld Foot/Endnote frame Cut + Paste Here + Delete button result Crash => Cutting/Pasting then deleting footnote frame results in crash
2020-04-28 01:05 jghali Assigned To => jghali
2020-04-28 01:05 jghali Status confirmed => resolved
2020-04-28 01:05 jghali Resolution open => fixed
2020-04-28 01:05 jghali Fixed in Version => 1.5.6.svn
2020-04-28 01:05 jghali Note Added: 0047578
2020-05-03 12:23 PeterBenedek Note Added: 0047589
2020-05-07 00:20 jghali Note Added: 0047598
2020-05-07 00:20 jghali Note Edited: 0047598 View Revisions
2020-05-08 13:19 PeterBenedek Status resolved => closed