View Issue Details

IDProjectCategoryView StatusLast Update
0014434ScribusFontspublic2019-07-30 21:27
Reportermarkus_m Assigned Tojghali  
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSDebianOS VersionStretch
Product Version1.4.6 
Target VersionFixed in Version1.5.5.svn 
Summary0014434: Converting true type fonts to outlines produces wrong shapes
DescriptionWhen I convert true type fonts (with quadratic curve type) to outlines the shapes differ from the embedded font.
Steps To Reproducesee attached files
Additional InformationWhen I convert the fonts to outlines with Inkscape or Freehand MX the shapes
are not differing from the embedded font. But to me it looks like they are changing the quadratic curves into cubic ones.
TagsNo tags attached.
PatchNo

Activities

markus_m

2016-12-08 21:56

reporter  

SCRIBUS_ttf_outlines.tar.gz (314,279 bytes)

ale

2016-12-09 14:51

manager   ~0042818

please check the irc logs for 8.12.2016 for some more details...

FirasH

2016-12-10 11:23

developer   ~0042835

Confirmed with 1.4.6.
Outlined font does not match the embedded font as visible in markus_m pdf.

Targetting 1.4.7 to not lose track of the issue.

jghali

2019-07-17 23:21

administrator   ~0046412

I committed a fix to 1.5.5.svn. I'll wait and see what happen after 1.5.5 release before maybe backporting to 1.4.9.svn.

PeterBenedek

2019-07-18 06:31

developer   ~0046413

Tested in: LinuxMint 19.1; r23082 (1.5.5svn)

I used Export -- Save as PDF then, I opened the PDF with GIMP.
Here a picture from GIMP.

Jean, this fault seems to be related the "Export -- Save as PDF -- Fonts -- Embedding mode: Outline All Fonts" function too.
This patch, does improves this?

SCRIBUS_ttf_outlines.jpg (17,543 bytes)
SCRIBUS_ttf_outlines.jpg (17,543 bytes)

PeterBenedek

2019-07-18 06:43

developer   ~0046414

Last edited: 2019-07-18 06:45

View 2 revisions

Meanwhile came the update (r23084)...
Reply to myself: Yes, this solved it.

Issue History

Date Modified Username Field Change
2016-12-08 21:56 markus_m New Issue
2016-12-08 21:56 markus_m File Added: SCRIBUS_ttf_outlines.tar.gz
2016-12-09 14:51 ale Note Added: 0042818
2016-12-10 11:23 FirasH Status new => confirmed
2016-12-10 11:23 FirasH Note Added: 0042835
2016-12-10 11:24 FirasH Target Version => 1.4.7
2019-07-17 23:11 jghali Target Version 1.4.7 =>
2019-07-17 23:13 jghali Summary converting true type fonts to outlines produces wrong shapes => Converting true type fonts to outlines produces wrong shapes
2019-07-17 23:20 jghali Assigned To => jghali
2019-07-17 23:20 jghali Status confirmed => resolved
2019-07-17 23:20 jghali Resolution open => fixed
2019-07-17 23:20 jghali Fixed in Version => 1.5.5.svn
2019-07-17 23:21 jghali Note Added: 0046412
2019-07-18 06:31 PeterBenedek File Added: SCRIBUS_ttf_outlines.jpg
2019-07-18 06:31 PeterBenedek Note Added: 0046413
2019-07-18 06:43 PeterBenedek Note Added: 0046414
2019-07-18 06:45 PeterBenedek Note Edited: 0046414 View Revisions
2019-07-30 21:27 cbradney Status resolved => closed