View Issue Details

IDProjectCategoryView StatusLast Update
0014555ScribusUser Interfacepublic2017-03-02 07:37
Reporterchristoph_s Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionreopened 
Platformx86 64OSLinuxOS VersionopenSUSE 42.1
Product Version1.5.3.svn 
Target VersionFixed in Version 
Summary0014555: Better "Guides" tooltip in 1.5.x
DescriptionIn 1.4.x users had the option to select whether guides are being displayed in the foreground or in the background via either Document Setup or the Prefs. This option is no longer available in 1.5.x and should be restored.
TagsNo tags attached.
PatchNo

Activities

utnik

2017-01-14 08:40

updater   ~0043340

in scribus 1.5.x there are even more options for this. you can define how content objects, guides, grid, baseline grid and margins are stacked on top of each other.

if this works on all platforms (on macOS it does–) the issue could be closed.

jghali

2017-01-14 11:14

administrator   ~0043341

Last edited: 2017-01-14 11:17

View 3 revisions

This options has been removed on purpose as it is indeed now possible to configure how objects, guides, grid, baseline grid and margins are stacked on top of each other. See Guides > Placement.

christoph_s

2017-01-15 07:19

administrator   ~0043344

Right. I was being misled by the insufficient tooltip. It should be replaced by something like "You can determine the hierarchy of visibility of design aids relative to actual content, as well as each other by using the arrow buttons."

ale

2017-02-27 09:30

manager   ~0043498

Last edited: 2017-02-27 17:38

View 3 revisions

imo, if the dialog is not self-describing enough, it should be improved.

tooltips are not a bad idea, but most people do not read them...
and long tooltips tend to be unreadable...

cbradney

2017-02-27 20:17

administrator   ~0043503

I'm not sure how to make it happen, but I'd suggest removing the up/down arrows and making the items in the list box draggable (tried a few options and cannot make it work). Enabling this in all listboxes would save some GUI space in many locations and align functionality across the application. Maybe @jghali can work that part out?

ale

2017-02-28 07:44

manager   ~0043509

well, i'm not sure that a change is needed.
but *if* it's not friendly enough, we should try to make it friendlier, not explain why it's unfriendly.

so the first steps is to check if a change is needed.
up to now i have not heard of many complaints but it's only in the dev branch and only few people have tested it yet.

probably, we should find out all places where resources can be reordered and use the same UI.
(layers, what else? currently, they seem to be using the same UI...)

christoph_s

2017-02-28 08:09

administrator   ~0043510

I don't think it's not user-friendly, quite the opposite: it's great -- once you know how to use it. What needs changing is that totally confusing tooltip.

jghali

2017-02-28 13:52

administrator   ~0043514

>> I don't think it's not user-friendly, quite the opposite: it's great -- once you know how to use it.

Honestly, Christoph, before starting coding on Scribus, I didn't even know a thing such as tooltips existed. So I join ale on that point: most people probably don't read them.

>> I'd suggest removing the up/down arrows and making the items in the list box draggable

Ok for making the items in the list box draggable, not for removing up/down arrows. It won't be evident at first sight that items in the list are draggable (unless you add a tooltip that probably most people won't read).

christoph_s

2017-03-01 06:42

administrator   ~0043516

Well, Jean, I did, even though I didn't always care. My point is that I was fooled by the *misleading* tooltip, because I relied on it. So we can do both, dragging the items with the mouse (and keep the arrows; we use them in other places, so it'd not be a violation of established UI principles) and provide a better tooltip along the lines I outlined above.

cbradney

2017-03-01 17:28

administrator   ~0043520

The arrows are ugly and break flow in the GUI - they should go.

christoph_s

2017-03-02 07:37

administrator   ~0043533

And how many other arrows do you think have to go as well? There must be dozens of them ;)

Seriously, this feature is really good, including the arrows. It could be improved, but the tooltip needs to be modified, because it's misleading.

Issue History

Date Modified Username Field Change
2017-01-14 07:07 christoph_s New Issue
2017-01-14 07:07 christoph_s Status new => assigned
2017-01-14 07:07 christoph_s Assigned To => cbradney
2017-01-14 07:09 christoph_s Category Canvas => User Interface
2017-01-14 08:40 utnik Note Added: 0043340
2017-01-14 11:14 jghali Note Added: 0043341
2017-01-14 11:14 jghali Note Edited: 0043341 View Revisions
2017-01-14 11:17 jghali Note Edited: 0043341 View Revisions
2017-01-14 11:18 jghali Status assigned => resolved
2017-01-14 11:18 jghali Resolution open => no change required
2017-01-15 07:19 christoph_s Note Added: 0043344
2017-01-15 07:20 christoph_s Assigned To cbradney =>
2017-01-15 07:20 christoph_s Status resolved => new
2017-01-15 07:20 christoph_s Resolution no change required => reopened
2017-02-26 08:01 christoph_s Summary Forgotten Guides option in 1.5.x => Better "Guides" tooltip in 1.5.x
2017-02-27 09:30 ale Note Added: 0043498
2017-02-27 17:38 ale Note Edited: 0043498 View Revisions
2017-02-27 17:38 ale Note Edited: 0043498 View Revisions
2017-02-27 20:17 cbradney Note Added: 0043503
2017-02-28 07:44 ale Note Added: 0043509
2017-02-28 08:09 christoph_s Note Added: 0043510
2017-02-28 13:52 jghali Note Added: 0043514
2017-03-01 06:42 christoph_s Note Added: 0043516
2017-03-01 17:28 cbradney Note Added: 0043520
2017-03-02 07:37 christoph_s Note Added: 0043533