View Issue Details

IDProjectCategoryView StatusLast Update
0014813ScribusTypographypublic2019-11-05 09:31
Reportersouthwindows Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
PlatformOSWindowsOS Version7 and 10CE
Product Version1.5.3.svn 
Target VersionFixed in Version 
Summary0014813: Inconsistent behavior with Plane 1 characters and OT
DescriptionWith 1.5.3 svn, Stylistic Sets with Plane 1 characters work correctly on a machine with Win7 Home Premium. On Win10 Creator's Edition, the characters remain displayed in the default shape even though the stylistic sets are visible in the Font Features tab and I am able to place a checkmark to select them. In other words, Scribus recognizes that the features exist in the font but somehow the correct glyphs are not shown.

On both versions of Windows, the glyph composition/decomposition feature does not work with Plane 1 characters. In the screenshot, the two instances of U+1031F should be replaced by a single alternate glyph (I put a red circle where the missing glyph should be). The mark to base positioning feature works with Plane 1 characters on Win10 but not Win7. (The combining underdots should always be centered.) The Mac version behaves correctly in all ways.

The font I am using is designed to support the Old Italic block of Unicode. It's my own font, but all the features work correctly in XeTeX and in LibreOffice 5.3.2, so I am confident that the font is correctly built. I can supply the font and/or test files if that will be helpful.
Tagstypography, unicode
PatchNo

Activities

southwindows

2017-05-22 22:00

reporter  

Scribus Win7.png (121,308 bytes)
Scribus Win7.png (121,308 bytes)

jghali

2017-05-22 23:39

administrator   ~0043928

Test file and font will be indeed required to have a close look at this issue. Please compress them and upload them here or at a place of your convenience.

southwindows

2017-05-31 16:33

reporter   ~0043975

Since posting this bug report, I've done more testing and gotten some help from folks on the Scribus forum, one of whom pointed me to the checkfonts150.xml. I thought that different results I got on Win7, Win10, and OS X were due to an issue in Scribus' handling of OT features. It now appears that some very strange things are going on with Scribus and fonts on Windows; multiple versions of my font are listed in checkfonts150 as installed and Scribus was using early versions. Once I sorted this out, the OT features started behaving properly on all platforms.

I probably should close or delete this bug and file a different one. But I'm new at this so I want to make sure I do things right. Thanks!

jghali

2019-11-05 09:30

administrator   ~0046969

Closing. Having several versions of a font installed can indeed lead to font conflicts.

Issue History

Date Modified Username Field Change
2017-05-22 22:00 southwindows New Issue
2017-05-22 22:00 southwindows File Added: Scribus Win7.png
2017-05-22 22:00 southwindows File Added: Scribus Old italic Win 10 CE.jpg
2017-05-22 22:00 southwindows Tag Attached: typography
2017-05-22 22:00 southwindows Tag Attached: unicode
2017-05-22 23:39 jghali Note Added: 0043928
2017-05-31 16:33 southwindows Note Added: 0043975
2019-11-05 09:30 jghali Assigned To => jghali
2019-11-05 09:30 jghali Status new => resolved
2019-11-05 09:30 jghali Resolution open => no change required
2019-11-05 09:30 jghali Note Added: 0046969
2019-11-05 09:31 jghali Status resolved => closed