View Issue Details

IDProjectCategoryView StatusLast Update
0014872ScribusStory Editor / Text Framespublic2017-06-27 05:17
Reportereudoxos Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntu OS Version17.04
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0014872: Crash when linking frames which are already linked
DescriptionI stumbled upon crashes when linking text frames in bigger documents, below is a minimal crasher IĀ could isolate and reproduce (not sure if that was the cause of other crashes). There is a failed assertion:

    /build/scribus-trunk-LLBIRy/scribus-trunk-1.5.3svn~r22063~20170612~ppa69~ubuntu17.04.1/scribus/pageitem.cpp:1284: void PageItem::link(PageItem*, bool): Assertion `!nextInChain()' failed.
Steps To Reproduce Create 2 couples of linked frames. Then create a 5th frame, select that one and one from each couple, and link them. (screenshot in the attached image)
TagsNo tags attached.
PatchNo

Activities

eudoxos

2017-06-20 06:31

reporter  

crash.png (4,591 bytes)
crash.png (4,591 bytes)

PeterBenedek

2017-06-21 07:28

developer   ~0044067

Tested Linux Mint 18.1; r22074

I cannot reproduce. Works well.

Issue History

Date Modified Username Field Change
2017-06-20 06:31 eudoxos New Issue
2017-06-20 06:31 eudoxos File Added: crash.png
2017-06-20 16:24 jghali Assigned To => jghali
2017-06-20 16:24 jghali Status new => resolved
2017-06-20 16:24 jghali Resolution open => fixed
2017-06-20 16:24 jghali Fixed in Version => 1.5.4.svn
2017-06-21 07:28 PeterBenedek Note Added: 0044067
2017-06-27 05:17 PeterBenedek Status resolved => closed