View Issue Details

IDProjectCategoryView StatusLast Update
0015004ScribusUser Interfacepublic2017-10-12 00:36
Reporterchristoph_s Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86 64OSWindows OS Version10
Product Version1.5.4.svn 
Target Version1.5.4Fixed in Version1.5.4.svn 
Summary0015004: Changing a Font Feature in the Text PP results in tab switch
DescriptionAs in the summary
Steps To Reproduce1) Create two new documents and insert a text frame into each via shift-click;

2) Insert a sample text into the text frame of doc one;

3) Type in some custom text into the text frame in the second document;

4) Apply an OpenType font feature to selected text in the 2nd doc via the Text Properties dialogue, e.g., disable common ligatures.


--> Scribus switches to the first document tab.
TagsNo tags attached.
PatchNo

Activities

jghali

2017-10-01 09:27

administrator   ~0044461

Unable to reproduce

christoph_s

2017-10-02 05:12

administrator   ~0044463

You need the Tab view enabled to reproduce this, as well as a font that supports OpenType features. I could also reproduce it on Linux.

christoph_s

2017-10-02 05:13

administrator   ~0044464

Linux shell output:

using default enc for Courier Regular
storytext::charstyle: access at end of text %i 8
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted
setBestEncoding for MinionPro-Regular with 1682 glyphs, hasNames= 512 , POST size= 32
Checking cmap 0 ( 0 , 3 , 0 ) format 4
found Unicode enc for Minion Pro Regular as map 0 with 1658 glyphs
Checking cmap 1 ( 1 , 0 , 0 ) format 6
Checking cmap 2 ( 3 , 1 , 0 ) format 4
found Unicode enc for Minion Pro Regular as map 2 with 3316 glyphs
Checking cmap 3 ( 7 , 0 , 0 ) format 0
using Unicode enc for Minion Pro Regular
pathForIcon: Unable to load icon /opt/scribus15/share/scribus/icons/1_5_1/tab.png: File not found
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61642, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61663, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61678, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61695, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61715, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61730, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61741, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61756, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61767, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61782, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61793, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 61808, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 65224, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 65245, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 65262, resource id: 33554533, major code: 130 (Unknown), minor code: 3
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted
QPixmap::scaled: Pixmap is a null pixmap
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaled: Pixmap is a null pixmap
QPainter::end: Painter not active, aborted

jghali

2017-10-02 06:57

administrator   ~0044466

>> You need the Tab view enabled to reproduce this, as well as a font that supports OpenType features.

I already did the tests with tab view enabled and OpenType fonts, but couldn't reproduce.

ale

2017-10-02 12:11

manager   ~0044467

there are other cases that make scribus switch to a "hidden" document.

there must be a ticket burried somewhere in this tracker... but i could not find it...

christoph_s

2017-10-07 18:31

administrator   ~0044500

Add another step: Select text in the 2nd frame, e.g. an ff to disable the ligature.

jghali

2017-10-07 18:54

administrator   ~0044501

I tried again and i'm still unable to reproduce.

christoph_s

2017-10-08 06:23

administrator   ~0044506

Last edited: 2017-10-08 06:34

View 2 revisions

After some more testing, this seems to be related to the docking of palettes.

On Windows 10 the issue only occurs when the Text Properties Palette has been docked to the left side of the Scribus window. On Linux (openSUSE 42.1) it also happens when it has been docked to the right side. If the TPP is free-flowing, Scribus works as expected on both platforms.

jghali

2017-10-08 16:22

administrator   ~0044513

Tested once again with TP docked to the left side. Still unable to reproduce.

christoph_s

2017-10-10 19:19

administrator   ~0044524

Video: http://www.yourfilelink.com/get.php?fid=1420694

jghali

2017-10-11 22:27

administrator   ~0044528

The root cause of the issue comes apparently from the way Qt is handling widget focus changes when hiding widget. I modified quite a bit the PP font features code to strongly mitigate this issue. But this is only a mitigation.

christoph_s

2017-10-12 00:36

administrator   ~0044529

Tested, fixed. Thanks a lot!!!

Issue History

Date Modified Username Field Change
2017-10-01 05:35 christoph_s New Issue
2017-10-01 09:27 jghali Note Added: 0044461
2017-10-02 05:12 christoph_s Note Added: 0044463
2017-10-02 05:13 christoph_s Note Added: 0044464
2017-10-02 06:57 jghali Note Added: 0044466
2017-10-02 12:11 ale Note Added: 0044467
2017-10-07 18:31 christoph_s Note Added: 0044500
2017-10-07 18:54 jghali Note Added: 0044501
2017-10-08 06:23 christoph_s Note Added: 0044506
2017-10-08 06:34 christoph_s Note Edited: 0044506 View Revisions
2017-10-08 16:22 jghali Note Added: 0044513
2017-10-10 19:19 christoph_s Note Added: 0044524
2017-10-11 22:27 jghali Assigned To => jghali
2017-10-11 22:27 jghali Status new => resolved
2017-10-11 22:27 jghali Resolution open => fixed
2017-10-11 22:27 jghali Fixed in Version => 1.5.4.svn
2017-10-11 22:27 jghali Note Added: 0044528
2017-10-12 00:36 christoph_s Status resolved => closed
2017-10-12 00:36 christoph_s Note Added: 0044529