View Issue Details

IDProjectCategoryView StatusLast Update
0015014ScribusTypographypublic2017-10-09 08:28
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformx64OSLinux MintOS Version18 (64bit)
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015014: "Non breaking space" does not work well
DescriptionTested r22187

Comment: A few days ago this worked well.

-- Open the Doc-1.sla
-- Look it: "blablabla – test" the "– t" between is "Non breaking space" (incorrect_break.jpg).

The Scribus does not detect this. But Scribus doesn't work well with another characters. Example: ")", "." ,"/" etc.) (another_character_1.jpg)

I examined in the Scribus 1.5.3. Result: Works well (correct_break.jpg)!
TagsNo tags attached.
PatchNo

Activities

PeterBenedek

2017-10-08 10:35

developer  

Doc-1.sla (14,833 bytes)
correct_break.jpg (149,151 bytes)
correct_break.jpg (149,151 bytes)
incorrect_break.jpg (111,773 bytes)
incorrect_break.jpg (111,773 bytes)
another_character_1.jpg (146,344 bytes)
another_character_1.jpg (146,344 bytes)
another_character__2.jpg (89,192 bytes)
another_character__2.jpg (89,192 bytes)

PeterBenedek

2017-10-08 11:41

developer   ~0044510

Last edited: 2017-10-08 12:02

View 3 revisions

The last well-functioning version: r22163
The r22167 already contains the bug.

"But Scribus doesn't work well with another characters. Example: ")", "." ,"/" etc.) (another_character_1.jpg)"
These characters are still causing a broken line break, in r22163 too.

Perhaps related: 0014999 ? I don't know...

jghali

2017-10-08 16:09

administrator   ~0044511

What is shown in "another_character_1.jpg" is a correct line break: you can't break before a closing parenthesis.

PeterBenedek

2017-10-08 16:41

developer   ~0044514

I understand.
Thanks Jean.

PeterBenedek

2017-10-09 08:27

developer   ~0044519

Tested r22189

I can't reproduce. Works well.

Issue History

Date Modified Username Field Change
2017-10-08 10:35 PeterBenedek New Issue
2017-10-08 10:35 PeterBenedek File Added: Doc-1.sla
2017-10-08 10:35 PeterBenedek File Added: correct_break.jpg
2017-10-08 10:35 PeterBenedek File Added: incorrect_break.jpg
2017-10-08 10:35 PeterBenedek File Added: another_character_1.jpg
2017-10-08 10:35 PeterBenedek File Added: another_character__2.jpg
2017-10-08 10:38 PeterBenedek Description Updated View Revisions
2017-10-08 10:39 PeterBenedek Description Updated View Revisions
2017-10-08 11:41 PeterBenedek Note Added: 0044510
2017-10-08 11:51 PeterBenedek Note Edited: 0044510 View Revisions
2017-10-08 12:02 PeterBenedek Note Edited: 0044510 View Revisions
2017-10-08 15:58 jghali Summary "Non breaking space" it does not work well => "Non breaking space" does not work well
2017-10-08 15:59 jghali Assigned To => jghali
2017-10-08 15:59 jghali Status new => resolved
2017-10-08 15:59 jghali Resolution open => fixed
2017-10-08 15:59 jghali Fixed in Version => 1.5.4.svn
2017-10-08 16:09 jghali Note Added: 0044511
2017-10-08 16:41 PeterBenedek Note Added: 0044514
2017-10-09 08:27 PeterBenedek Note Added: 0044519
2017-10-09 08:28 PeterBenedek Status resolved => closed