View Issue Details

IDProjectCategoryView StatusLast Update
0015057ScribusUndo/Redopublic2017-11-30 04:13
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx64OSLinux MintOS Version18 (64bit)
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015057: Scribus crash when undoing after applying "unlink text frame and cut text"
DescriptionTested Linux Mint 18; r22227

-- Open the Dokumentum-1.sla
-- Click on RED TextFrame
-- Apply the Item - Text Frame Links - Unlink text frames and cut text
-- Double click on RED TextFrame
-- Click UNDO (or CTRL + Z)

Scribus crash 0000011
Additional Information(gdb) run
Starting program: /usr/bin/scribus-trunk
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe4503700 (LWP 29852)]
[New Thread 0x7fffdb101700 (LWP 29853)]
pathForIcon: Unable to load icon /usr/share/scribus-trunk/icons/1_5_1/zeichen.png: File not found
[New Thread 0x7fffcbf4c700 (LWP 29859)]
[New Thread 0x7fffcb74b700 (LWP 29860)]
[New Thread 0x7fffcab0a700 (LWP 29861)]
[New Thread 0x7fffca309700 (LWP 29862)]
[New Thread 0x7fffc9493700 (LWP 29863)]
[Thread 0x7fffca309700 (LWP 29862) exited]
[Thread 0x7fffc9493700 (LWP 29863) exited]
setBestEncoding for Roboto-Regular with 1035 glyphs, hasNames= 512 , POST size= 9142
Checking cmap 0 ( 0 , 3 , 0 ) format 4
found Unicode enc for Roboto Regular as map 0 with 876 glyphs
Checking cmap 1 ( 1 , 0 , 0 ) format 6
Checking cmap 2 ( 3 , 1 , 0 ) format 4
found Unicode enc for Roboto Regular as map 2 with 1752 glyphs
using Unicode enc for Roboto Regular
QPixmap::scaled: Pixmap is a null pixmap
pathForIcon: Unable to load icon /usr/share/scribus-trunk/icons/1_5_1/tab.png: File not found
storytext::charstyle: access at end of text %i 344

Thread 1 "scribus-trunk" received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
Tagsundo
PatchNo

Activities

PeterBenedek

2017-11-29 12:01

developer  

Dokumentum-1.sla (16,083 bytes)

PeterBenedek

2017-11-30 04:12

developer   ~0044680

Tested Linux Mint 18; r22227

I can't reproduce, works fine.
Thanks.

Closed

Issue History

Date Modified Username Field Change
2017-11-29 12:00 PeterBenedek New Issue
2017-11-29 12:01 PeterBenedek File Added: Dokumentum-1.sla
2017-11-29 12:09 PeterBenedek Tag Attached: undo
2017-11-29 12:12 PeterBenedek Summary Scribus crash when apply the "unlink text frame and cut text" and use undo this. => Scribus crash when apply the "unlink text frame and cut text" and use CTRL+Z (undo).
2017-11-29 19:09 JLuc Category Usability => Undo/Redo
2017-11-29 21:01 jghali Summary Scribus crash when apply the "unlink text frame and cut text" and use CTRL+Z (undo). => Scribus crash when applying "unlink text frame and cut text" and using undo
2017-11-29 21:04 jghali Summary Scribus crash when applying "unlink text frame and cut text" and using undo => Scribus crash when undoing after applying "unlink text frame and cut text"
2017-11-29 21:10 jghali Assigned To => jghali
2017-11-29 21:10 jghali Status new => resolved
2017-11-29 21:10 jghali Resolution open => fixed
2017-11-29 21:10 jghali Fixed in Version => 1.5.4.svn
2017-11-30 04:12 PeterBenedek Note Added: 0044680
2017-11-30 04:13 PeterBenedek Status resolved => closed