View Issue Details

IDProjectCategoryView StatusLast Update
0015059ScribusMaster Pagespublic2017-12-20 20:58
ReporterLuna Nightshade Assigned Tojghali  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindowsOS Version10
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015059: Issue with importing master pages that have the same name
DescriptionI have an old project that is split into several files. I had to make a few adjustments to the master pages for a refreshment in the first document (moving a text frame and adding text).
And since I am lazy, I went and imported the page into the next document part. The import was successful, but the result unexpected:
* Scribus created a new master page "copy of [name]" that is totally empty
* The Master Page with the same name has the old and the changed elements on it

I think it would be nice to have a behavior that is similar to the one of importing styles: Ask whether or not a master page with the same name is replaced or renamed.
Steps To ReproduceSee description
Tagsimport
PatchNo

Activities

jghali

2017-12-03 13:04

administrator   ~0044708

>> I think it would be nice to have a behavior that is similar to the one of importing styles: Ask whether or not a master page with the same name is replaced or renamed.

I fixed the master page import issue. Feel free to open a feature request for this.

PeterBenedek

2017-12-04 18:24

developer   ~0044713

Tested Linux Mint 18; r22233

I can't reproduce it. Import works well: Scribus rename the imported master pages.

Issue History

Date Modified Username Field Change
2017-12-01 08:57 Luna Nightshade New Issue
2017-12-01 08:57 Luna Nightshade Tag Attached: import
2017-12-03 13:04 jghali Assigned To => jghali
2017-12-03 13:04 jghali Status new => resolved
2017-12-03 13:04 jghali Resolution open => fixed
2017-12-03 13:04 jghali Fixed in Version => 1.5.4.svn
2017-12-03 13:04 jghali Note Added: 0044708
2017-12-04 18:24 PeterBenedek Note Added: 0044713
2017-12-20 20:58 cbradney Status resolved => closed