View Issue Details

IDProjectCategoryView StatusLast Update
0001506ScribusPlug-inspublic2008-02-08 19:57
Reporteruser318Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinux i686 X11OSSUSE-9.1OS Version
Product Version1.3.0cvs 
Target VersionFixed in Version1.2.1 
Summary0001506: SVG imported -- rotation spinbox not only rotates, but also displaces the SVG
Description"Rotation" of SVG does not only rotate, but also "displace" the object.

Actually, it doesnt only move "north-east", as I initially reported. If you do 360 steps to rotate a full circle, the object moves on and completeds movement on a full circle, also rotating 360 degree. Very much like the movement of the moon during a month....

Maybe you can fix it by leaving the code alone, and just re-naming the "Rotation" label into "Moon-like movement"? ;-)
Steps To ReproduceTo reproduce, do this:

* open a new file
* import SVG (I attach the one I used)
* right-click & open "Show Properties..."
* click on spinbox "Rotation", repeat
* watch the SVG image not only rotate, but also be displaced with each step
Additional InformationBuilt with current "qt-copy" from current KDE-HEAD CVS...
TagsNo tags attached.
Patch

Relationships

child of 0002931 acknowledged Metabug: SVG 

Activities

2005-01-08 00:55

 

Chip.svg (70,474 bytes)

user318

2005-01-08 01:27

  ~0003400

Additional note:

the described behaviour can also be observed by editing the spinbox value. F.e. if you put in 180, the object rotates by half and jumps to the adjectory point of its "moon-like" virtual orbit. BTW, the orbit seems to be the same diameter as the SVG I provided (which is also of circle shape).

fschmid

2005-01-08 08:40

administrator   ~0003401

Use the 5 Radiobuttons beneath the Rotation Spinbox to determine the center of the rotation. If you choose the center one, rotation works as expected

user318

2005-01-09 17:53

  ~0003417

*blush*

user318

2005-01-09 17:54

  ~0003418

Hmmm... how can I close it again now?

Issue History

Date Modified Username Field Change
2005-01-08 00:55 user318 New Issue
2005-01-08 00:55 user318 File Added: Chip.svg
2005-01-08 01:12 cbradney Status new => assigned
2005-01-08 01:12 cbradney Assigned To => fschmid
2005-01-08 01:13 cbradney Severity minor => block
2005-01-08 01:27 user318 Note Added: 0003400
2005-01-08 08:40 fschmid Note Added: 0003401
2005-01-08 08:40 fschmid Status assigned => resolved
2005-01-08 08:40 fschmid Fixed in Version => 1.2.1cvs
2005-01-08 08:40 fschmid Resolution open => no change required
2005-01-08 11:43 cbradney Severity block => minor
2005-01-08 11:44 cbradney Status resolved => closed
2005-01-08 11:44 cbradney Fixed in Version 1.2.1cvs =>
2005-01-09 17:53 user318 Status closed => feedback
2005-01-09 17:53 user318 Resolution no change required => reopened
2005-01-09 17:53 user318 Note Added: 0003417
2005-01-09 17:54 user318 Note Added: 0003418
2005-01-09 20:35 fschmid Status feedback => closed
2005-01-09 20:35 fschmid Fixed in Version => 1.2.1
2006-05-17 19:26 christoph_s Relationship added child of 0002931
2008-02-08 19:57 christoph_s Status closed => resolved
2008-02-08 19:57 christoph_s Resolution reopened => no change required
2008-02-08 19:57 christoph_s Status resolved => closed