View Issue Details

IDProjectCategoryView StatusLast Update
0015066ScribusGraphics / Image Framespublic2017-12-11 13:01
ReporterKingHarry Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.4.6 
Target VersionFixed in Version 
Summary0015066: Scribus stopps / crashes after linking more than 200 images to image frame
DescriptionHi together,
currently I'm creating an photo book (DIN A4, double pages) by the following procedure:
1. creating 100 new pages
2. inserting new image frames, connecting jpeg-images by drag&drop from local drive
    as an alternative: creating new image frame, copying frame 10 time , connecting images to each frame

After about 200 - 240 images scribus stopped showing the images. The new linked image frames looked as if the path was changed (red crossed, file name, no picture) or just blank (white frame). Also the "working" image frames were not more editable --> scribus file was damaged!

Probably - with deleting - could it be that I reached a limit (internal counter) of 255 images ?






Steps To ReproduceRepair procedure:
It wasn't possible just to restart. So I deleted the last 2-3 failing image frames, saved, re-opened it and did "Collect to output". In the new created file it was possible to edit the "working" image frames again (luckily, not the whole work was lost), but after adding new frames, the same error occured again.
The whole output-file (scribus + 200 jpeg-images) had a about 500MB.
Additional InformationDifferent IT configurations: I tried the procedure above with the following configurations:
1. Win 7 home (4GB RAM) 64bit + local stored files (image folder on desktop) + Scribus 1.4.6
2. Win 10 enterprise (8GB RAM) 64bit + local stored files (image folder on desktop) + Scribus 1.4.6 portable
3. both systems with files externally (NAS) image folders

Work-Around:
Now, I decided to create some chapters (each limited with 20-30 pages), export the and create a complete file with another program
Tagscrash, error, frame, image, image-frames, page management, windows10, windows7
PatchNo

Relationships

duplicate of 0004520 assignedjghali Crash while placing multiple large JPEG images 

Activities

jghali

2017-12-11 12:58

administrator   ~0044731

Duplicate of 0004520. As you have already noticed, when working with lots of images it is necessary to split document into several sub-documents.

jghali

2017-12-11 13:00

administrator   ~0044732

>> Probably - with deleting - could it be that I reached a limit (internal counter) of 255 images ?

No, the limit is imposed by available memory on your computer. When working with lots of images, 4Gb or 8Gb is not much.

Issue History

Date Modified Username Field Change
2017-12-11 12:07 KingHarry New Issue
2017-12-11 12:07 KingHarry Tag Attached: crash
2017-12-11 12:07 KingHarry Tag Attached: error
2017-12-11 12:07 KingHarry Tag Attached: frame
2017-12-11 12:07 KingHarry Tag Attached: image
2017-12-11 12:07 KingHarry Tag Attached: image-frames
2017-12-11 12:07 KingHarry Tag Attached: page management
2017-12-11 12:07 KingHarry Tag Attached: windows10
2017-12-11 12:07 KingHarry Tag Attached: windows7
2017-12-11 12:58 jghali Assigned To => jghali
2017-12-11 12:58 jghali Status new => resolved
2017-12-11 12:58 jghali Resolution open => duplicate
2017-12-11 12:58 jghali Note Added: 0044731
2017-12-11 12:58 jghali Relationship added duplicate of 0004520
2017-12-11 13:00 jghali Note Added: 0044732
2017-12-11 13:01 jghali Priority urgent => normal
2017-12-11 13:01 jghali Status resolved => closed