View Issue Details

IDProjectCategoryView StatusLast Update
0015081ScribusGeneralpublic2017-12-27 12:48
Reporterserg0 Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version1.5.3 
Target VersionFixed in Version 
Summary0015081: Undo function works buggy
DescriptionI created several text blocks, resized it. Then In text block I clicked twice and pasted from clipboard a text which was early copyied from Libreoffice. After pasting a text I made Undo. This function does not affect on pasted a text block but affect on any other iterations which I've made early,
Several times Scribus crashed.
Steps To Reproduce1. Make a new document (1 page).
2. Make several text blocks.
3. Resize them left or rigtht or bottom.
4. copy text from M$ office, Libreoffice...
5. Paste a text into text block (text must be bigger then block's size to pake possible linking it into other ),
6. link text into other next block.
7. Make Undo several times.
8. Undo function affect on size of blocks but pasted text does not appear.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0015067 closedjghali Undoing text paste over causes old and new text merge 
child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

serg0

2017-12-27 06:42

reporter   ~0044782

This bug appears in Sbribus ver 1.5.3.

jghali

2017-12-27 12:48

administrator   ~0044787

This issue has already been fixed in 1.5.4.svn with 0015067

Issue History

Date Modified Username Field Change
2017-12-27 06:21 serg0 New Issue
2017-12-27 06:42 serg0 Note Added: 0044782
2017-12-27 12:05 JLuc Relationship added related to 0015080
2017-12-27 12:06 JLuc Relationship added child of 0012500
2017-12-27 12:35 JLuc Product Version => 1.5.3
2017-12-27 12:48 jghali Assigned To => jghali
2017-12-27 12:48 jghali Status new => resolved
2017-12-27 12:48 jghali Resolution open => duplicate
2017-12-27 12:48 jghali Note Added: 0044787
2017-12-27 12:48 jghali Relationship added duplicate of 0015067
2017-12-27 12:48 jghali Relationship deleted related to 0015080
2017-12-27 12:48 jghali Status resolved => closed