View Issue Details

IDProjectCategoryView StatusLast Update
0015118ScribusBuild Systempublic2019-06-04 20:56
Reportersefran Assigned Tojghali  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformDebian, ArchlinuxOSLinuxOS Version4.14
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015118: Misleading indentation warning
DescriptionWhen compile scribus 1.5.4, i found warning :

[ 0%] Building CXX object scribus/third_party/zip/CMakeFiles/scribus_zip_lib.dir/zip.cpp.o
/run/media/franc/991f047a-ee36-4f43-870f-27be50b88af1/franc/Téléchargements/scribus_trunk/scribus15-compile/scribus/third_party/zip/zip.cpp: Dans la fonction membre « Zip::ErrorCode ZipPrivate::createArchive(QIODevice*) »:
/run/media/franc/991f047a-ee36-4f43-870f-27be50b88af1/franc/Téléchargements/scribus_trunk/scribus15-compile/scribus/third_party/zip/zip.cpp:304:5: warning: cette instruction « if » ne protège pas… [-Wmisleading-indentation]
     if (device != file)
     ^~
/run/media/franc/991f047a-ee36-4f43-870f-27be50b88af1/franc/Téléchargements/scribus_trunk/scribus15-compile/scribus/third_party/zip/zip.cpp:307:2: note: …cette instruction, mais l'indentation de cette dernière est trompeuse car elle fait croire qu'elle est gardée par le « if »
  if (!device->isOpen()) {
  ^~
/run/media/franc/991f047a-ee36-4f43-870f-27be50b88af1/franc/Téléchargements/scribus_trunk/scribus15-compile/scribus/third_party/zip/zip.cpp: Dans la fonction membre « Zip::ErrorCode Zip::createArchive(const QString&, bool) »:
/run/media/franc/991f047a-ee36-4f43-870f-27be50b88af1/franc/Téléchargements/scribus_trunk/scribus15-compile/scribus/third_party/zip/zip.cpp:1387:5: warning: cette instruction « if » ne protège pas… [-Wmisleading-indentation]
     if (filename.isEmpty())
     ^~
/run/media/franc/991f047a-ee36-4f43-870f-27be50b88af1/franc/Téléchargements/scribus_trunk/scribus15-compile/scribus/third_party/zip/zip.cpp:1390:2: note: …cette instruction, mais l'indentation de cette dernière est trompeuse car elle fait croire qu'elle est gardée par le « if »
  d->file = new QFile(filename);
  ^
Steps To Reproducemake clean
make
Tagslinux
PatchNo

Activities

jurajF

2018-01-29 22:31

reporter   ~0044890

I have noticed those warning too, but i choose to ignore them because they are included third party sources code.

Issue History

Date Modified Username Field Change
2018-01-29 07:59 sefran New Issue
2018-01-29 07:59 sefran Tag Attached: linux
2018-01-29 22:31 jurajF Note Added: 0044890
2018-01-30 16:44 jghali Summary Compilation warning => Misleading indentation warning
2018-01-30 16:45 jghali Assigned To => jghali
2018-01-30 16:45 jghali Status new => resolved
2018-01-30 16:45 jghali Resolution open => fixed
2018-01-30 16:45 jghali Fixed in Version => 1.5.4.svn
2019-06-04 20:56 cbradney Status resolved => closed