View Issue Details

IDProjectCategoryView StatusLast Update
0015172ScribusGraphics / Image Framespublic2019-06-04 20:56
Reporterjberg Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.3 
Target VersionFixed in Version1.5.4.svn 
Summary0015172: double-click + keyboard adjusting image frames doesn't set "free scaling"
DescriptionYesterday, I made a whole bunch of pages with images, and the workflow was "double-click, and then use arrows, shift-arrows & alt-arrows to adjust the image in the frame.

Imagine my surprise when I reopened the document today and all the images were fit to the boxes again.

Turns out that using the mouse/keyboard in this way doesn't set the image frame to "Free Scaling" despite having just done free scaling.
Steps To Reproduceadd an image frame
add an image to it
double-click it
use keyboard to scale/move image in frame
save
close
open
scaling/moving is gone
TagsNo tags attached.
PatchNo

Activities

PeterBenedek

2018-02-26 14:47

developer   ~0044993

Tested Linux Mint 18.3; r22413 (1.5.4svn)

I can't reproduce. Document save saves the changes.

jberg

2018-02-26 14:56

reporter   ~0044994

So maybe it's fixed then - I can definitely reproduce on 1.5.3 with a blank default document, adding an image frame (it gets default scaling "To Frame Size") and then saving/closing/reopening the document loses the adjustments made to the image.

I'll try to see if I can get svn up & running to check there.

jberg

2018-02-26 15:20

reporter   ~0044996

I can reproduce this on 1.5.4-svn (r22410 I think, I used github), can I change the version on the bug somehow?

jberg

2018-02-26 15:28

reporter   ~0044998

I can't seem to edit anything above (subject, steps to reproduce, etc.) but let me attach a screencast.

vokoscreen-2018-02-26_16-26-33.mkv (836,753 bytes)

jberg

2018-02-26 15:29

reporter   ~0044999

Oh ... the scaling there was done with alt+right-arrow

PeterBenedek

2018-02-26 15:46

developer   ~0045000

Ok, I mean.
I can reproduce this.

So: The scribus doesn't disable hotkeys in "to frame size" mode.

jberg

2018-02-26 15:57

reporter   ~0045001

Yeah, ok, you could see it that way around too. From a workflow perspective, personally, I'd prefer it to just change to "free scaling" mode automatically so I don't have to scroll around there in the properties to enable free scaling, but disabling the hotkeys would avoid the "data loss".

FWIW, everything including exporting a PDF worked fine, so at least I have a document to redo my changes from :-)

jghali

2018-02-26 20:02

administrator   ~0045005

Fixed too. The scaling mode is now changed to "free scaling" if needed.

jberg

2018-02-26 20:56

reporter   ~0045006

Very nice, thanks!

Will using an svn snapshot have an adverse effect on my document, like not being able to open it with a release later?

jghali

2018-02-26 22:47

administrator   ~0045007

With current snapshots there are several risks:
- a file saved with current 1.5.4.svn snapshots will not open anymore in 1.5.3 due to a change in the way colors are stored in sla file
- a file saved with a specific snapshot may not open with a previous snapshot or previous release
- a file saved with a specific snapshot may render differently in a later snapshot
- text layout can change from one snapshot to another, this is also true anyway for any 1.5.x release as 1.5.x is a development branch

However it is generally expected that a file saved with a snapshot will open with later snapshots.

PeterBenedek

2018-03-01 18:26

developer   ~0045016

Tested r22419

I can't reproduce, works fine.
Thanks.

Issue History

Date Modified Username Field Change
2018-02-26 12:26 jberg New Issue
2018-02-26 14:47 PeterBenedek Note Added: 0044993
2018-02-26 14:53 PeterBenedek Severity major => minor
2018-02-26 14:56 jberg Note Added: 0044994
2018-02-26 15:20 jberg Note Added: 0044996
2018-02-26 15:21 PeterBenedek Steps to Reproduce Updated View Revisions
2018-02-26 15:23 PeterBenedek Steps to Reproduce Updated View Revisions
2018-02-26 15:28 jberg File Added: vokoscreen-2018-02-26_16-26-33.mkv
2018-02-26 15:28 jberg Note Added: 0044998
2018-02-26 15:29 jberg Note Added: 0044999
2018-02-26 15:46 PeterBenedek Note Added: 0045000
2018-02-26 15:57 jberg Note Added: 0045001
2018-02-26 20:02 jghali Assigned To => jghali
2018-02-26 20:02 jghali Status new => resolved
2018-02-26 20:02 jghali Resolution open => fixed
2018-02-26 20:02 jghali Fixed in Version => 1.5.4.svn
2018-02-26 20:02 jghali Note Added: 0045005
2018-02-26 20:56 jberg Note Added: 0045006
2018-02-26 22:47 jghali Note Added: 0045007
2018-03-01 18:26 PeterBenedek Note Added: 0045016
2019-06-04 20:56 cbradney Status resolved => closed