View Issue Details

IDProjectCategoryView StatusLast Update
0015254ScribusStylespublic2018-04-20 17:45
ReporterFirasH Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015254: Scribus crashes when scrolling Character Style Family drop menu
DescriptionScribus crashes scrolling Character Style Family drop menu.
Steps To Reproduce0) Open the attached document
1) Go to: Edit > Styles... > Default Paragraph Style > Character Style
2) Select Family drop menu
3) Scroll the drop menu

Scribus crashes due to Signal 11
Additional InformationScribus 1.5.4.svn (22444) on macOS
Scribus 1.5.4.svn 180331 snapshot on Windows
TagsNo tags attached.
PatchNo

Activities

FirasH

2018-04-07 10:49

developer  

0025-Aprile2018.sla (14,726 bytes)

utnik

2018-04-07 11:59

updater   ~0045151

unable to reproduce (scribus 1.5.4_r22444, macOS 10.13.4) – no crash.
could it be something related to the used font ('caviar dreams bold')? – the font was replaced in my test run…

jghali

2018-04-07 14:24

administrator   ~0045152

The crash occurred when reaching the "Use Parent Font" item at then end of the list. This is now fixed.

FirasH

2018-04-20 17:45

developer   ~0045172

Thanks!
Fixed in 1.5.4.svn (22467).

Issue History

Date Modified Username Field Change
2018-04-07 10:49 FirasH New Issue
2018-04-07 10:49 FirasH File Added: 0025-Aprile2018.sla
2018-04-07 11:59 utnik Note Added: 0045151
2018-04-07 14:24 jghali Summary Scribus crashes scrolling Character Style Family drop menu => Scribus crashes when scrolling Character Style Family drop menu
2018-04-07 14:24 jghali Assigned To => jghali
2018-04-07 14:24 jghali Status new => resolved
2018-04-07 14:24 jghali Resolution open => fixed
2018-04-07 14:24 jghali Fixed in Version => 1.5.4.svn
2018-04-07 14:24 jghali Note Added: 0045152
2018-04-20 17:45 FirasH Status resolved => closed
2018-04-20 17:45 FirasH Note Added: 0045172