View Issue Details

IDProjectCategoryView StatusLast Update
0015281ScribusInternalpublic2019-06-04 20:56
Reporterdcb Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.4.7 
Target VersionFixed in Version1.5.5.svn 
Summary0015281: Warning: Expression is always false because 'else if' condition matches previous condition
Descriptionscribus-1.4.7/scribus/propertiespalette.cpp:2455]: (style) Expression is always false because 'else if' condition matches previous condition at line 2447.

               if (bp == 0)
                        m_ScMW->view->RCenter = FPoint(gx, gy);
                else if (bp == 1)
                        m_ScMW->view->RCenter = FPoint(gx + gw, gy);
                else if (bp == 2)
                        m_ScMW->view->RCenter = FPoint(gx + gw / 2.0, gy + gh / 2.0);
                else if (bp == 3)
                        m_ScMW->view->RCenter = FPoint(gx, gy + gh);
                else if (bp == 0)
                        m_ScMW->view->RCenter = FPoint(gx + gw, gy + gh);
TagsNo tags attached.
PatchNo

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-04-28 16:39 dcb New Issue
2018-04-29 00:37 jghali Summary scribus-1.4.7/scribus/propertiespalette.cpp:2455: more "can't reach" if chain => Warning: Expression is always false because 'else if' condition matches previous condition
2018-04-29 00:38 jghali Assigned To => jghali
2018-04-29 00:38 jghali Status new => resolved
2018-04-29 00:38 jghali Resolution open => fixed
2018-04-29 00:38 jghali Fixed in Version => 1.5.5.svn
2018-04-29 02:41 jghali Category Properties Palette => Internal
2019-06-04 20:56 cbradney Status resolved => closed