View Issue Details

IDProjectCategoryView StatusLast Update
0015303ScribusStory Editor / Text Framespublic2018-05-22 14:42
Reportertcharlss Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version17.10
Product Version1.5.3 
Target VersionFixed in Version1.5.4.svn 
Summary0015303: Crash when editing text frame
DescriptionHi,

I'm working on a small publishing company's catalog.
The document was created way back in 2010 in Scribus 1.5-trunk, we update it each year with new informations.

This year after updating to Scribus 1.5.3, I have a lot of difficulties trying to edit it : it crashes every time I attempt to edit a text frame.

Here is the error message from the console :

ASSERT failure in QList<T>::operator[]: "index out of range", file /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h, line 549
scribus-ng: /build/scribus-ng-DAj0hs/scribus-ng-1.5.3/scribus/scribuscore.cpp :89 : void abort_on_error(QtMsgType, const QMessageLogContext&, const QString&): l'assertion « false » a échoué.
Plantage de Scribus
-------------
Plantage de Scribus suite au signal 0000006

Maybe I can provide you an excerpt of the document if you need.
Additional Information1.5.3-0ubuntu17.10~ppa0
lp-ppa-scribus-artful-main
TagsNo tags attached.
PatchNo

Activities

jghali

2018-05-06 14:23

administrator   ~0045208

1.5.4 is out since a few days and is mostly a bugfix releases over 1.5.3. You should upgrade. However, yes, a sample document would be helpful for testing.

tcharlss

2018-05-22 14:21

reporter   ~0045262

Hi,

Since 1.5.4 I dont' have this bug anymore.

Thanks

jghali

2018-05-22 14:42

administrator   ~0045263

Thanks for the information, resolving then.

Issue History

Date Modified Username Field Change
2018-05-06 12:18 tcharlss New Issue
2018-05-06 14:23 jghali Note Added: 0045208
2018-05-22 14:21 tcharlss Note Added: 0045262
2018-05-22 14:42 jghali Assigned To => jghali
2018-05-22 14:42 jghali Status new => resolved
2018-05-22 14:42 jghali Resolution open => fixed
2018-05-22 14:42 jghali Fixed in Version => 1.5.4.svn
2018-05-22 14:42 jghali Note Added: 0045263
2018-05-22 14:42 jghali Status resolved => closed