View Issue Details

IDProjectCategoryView StatusLast Update
0015318ScribusPDFpublic2019-06-04 20:56
Reporteraiena Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015318: Page number glyphs partially render as boxes/blank during PDF export in certain circumstances
DescriptionScribus program info
==================
Using: Scribus 1.5.5svn
Built from source from the Scribus Git mirror.
Git branch "master"
Git commit "8bf3eb2a8021a101ecc150cc8ee0304f1e32e54b" (More nullptr and other conversions)

(Note: this version (1.5.5svn) is not available in above "Product Version" drop down)


Problem Description:
=================

I had created a master page where I used insert page number for a text frame. I applied a character style to it which uses OTF features of a font for old style numbers.

The glyphs of these old style numbers render perfectly in scribus while typesetting and in document preview. On PDF export some page number glyphs render in the final PDF as boxes some render like in preview.

However If I make a textbox in the same document and put all the numbers and apply the same character style used for the page numbers suddenly the output PDF seems to render all those glyphs which were showed as boxes correctly.

Fonts required:
1) Linux Libertine O (Available here "https://sourceforge.net/projects/linuxlibertine/files/linuxlibertine/5.3.0/LinLibertineOTF_5.3.0_2012_07_02.tgz/download")
2) Latin Modern Roman Demi 10 (Available here "http://www.gust.org.pl/projects/e-foundry/latin-modern/download/lm2.004otf.zip")
3) Flanker Griffo (Available here "http://www.1001fonts.com/flanker-griffo-font.html")
Steps To Reproduce1) Extract the zip archive
2) Open A.sla then choose Export and export with PDF 1.3 try with both options. Export with embedded fonts and export as outlines.

Expected result: The pdf should look like how it looks within scribus.
Real result: Some page number glyphs render some don't and show up as boxes with enbedded fonts and blank with outlines.

This is demonstrated in the "/PDF Export/A-pdf1.3-embedded-fonts.pdf" & "/PDF Export/A-pdf1.3-outlined-glyphs.pdf"
One of the numbers renders i.e. 4 in this case renders fine the rest render as boxes. In an earlier version of this file glyphs 4 and 5 did not render but glyphs 6 and 7 did. In both cases it was consistent with reopening Scribus and opening that same file and exporting to fresh new PDF files from the same document.

3) Open B.sla then choose Export and export with PDF 1.3 try with both options. Export with embedded fonts and export as outlines.

Expected result: The pdf should look like how it looks within Scribus.
Real result:The pdf looks like how it looks within Scribus.

This is demonstrated in the "/PDF Export/B-pdf1.3-embedded-fonts.pdf" & "/PDF Export/B-pdf1.3-outlined-glyphs.pdf"
So here the issue suddenly disappears. Only change between A and B is putting a text frame in the document body with all the numbers. The character style applied is the same to the page numbers and the text frame number.
Additional InformationAll paths for files are relative to the submitted archive's extracted folder.
TagsNo tags attached.
PatchNo

Activities

aiena

2018-05-13 06:16

reporter  

bug report files.zip (639,285 bytes)

Issue History

Date Modified Username Field Change
2018-05-13 06:16 aiena New Issue
2018-05-13 06:16 aiena File Added: bug report files.zip
2018-05-13 11:14 jghali Product Version 1.5.4.svn => 1.5.5.svn
2018-05-13 11:14 jghali Summary Page number glyphs partially render as boxes/blank only during PDF export in certain circumstances. (Scribus 1.5.5svn) => Page number glyphs partially render as boxes/blank only during PDF export in certain circumstances
2018-05-13 12:32 jghali Summary Page number glyphs partially render as boxes/blank only during PDF export in certain circumstances => Page number glyphs partially render as boxes/blank during PDF export in certain circumstances
2018-05-13 12:34 jghali Assigned To => jghali
2018-05-13 12:34 jghali Status new => resolved
2018-05-13 12:34 jghali Resolution open => fixed
2018-05-13 12:34 jghali Fixed in Version => 1.5.5.svn
2019-06-04 20:56 cbradney Status resolved => closed