View Issue Details

IDProjectCategoryView StatusLast Update
0015333ScribusColor Managementpublic2018-05-23 21:30
Reportertcharlss Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
PlatformLinuxOSUbuntuOS Version17.10
Product Version1.5.4 
Target VersionFixed in Version 
Summary0015333: Color separation : print preview doesn't display spot colors
DescriptionI'm working on a document which uses a Pantone spot color (5 colors in total : CMYK + spot color).
When I check the color separations in the print preview, I can see CMYK colors just fine, but not the spot color.

I've joined a sample and a few screenshots.
The spot color is the brownish one.

ton_direct_color_config.png : spot color configuration
ton_direct_edit.png : preview of the document
ton_direct_preview_cmjn : color separation for CMYK colors
ton_direct_preview_pantone : color separation for the spot color

I've worked on this document for a few years now, and the color separation worked juste fine previously (that is 3 years ago on Scribus 1.5-trunk).
I also recall I could see the spot color in the print preview.

Now I don't know if this is just a preview bug, or a more serious bug affecting the color separation for spot colors.
Should I be worried that the color separation will fail when we'll send the document for printing ?

Regards
Tagsprint preview, spot color
PatchNo

Activities

tcharlss

2018-05-22 22:39

reporter  

ton_direct.sla (116,782 bytes)
ton_direct_edit.png (34,522 bytes)
ton_direct_edit.png (34,522 bytes)

PeterBenedek

2018-05-23 07:38

developer   ~0045264

Tested Linux Mint 18.3 (Ubuntu 16.04)

I not see a problem. Works well.

test_direct_color.jpg (29,186 bytes)
test_direct_color.jpg (29,186 bytes)

tcharlss

2018-05-23 07:45

reporter   ~0045265

Strange...

Here are the complete infos about my version just in case (from the "about Scribus" menu) :

>Version de Scribus 1.5.4
>28 Avril 2018
>Identifiant de compilation : C--T-F-C1.14.10-64bit
>Utilisation de Ghostscript version 9.21

PeterBenedek

2018-05-23 07:50

developer   ~0045266

Hi tcharlss

I noticed that a setting is not good, please you modify:
File menu -- Document setup (or preferences... too) -- Colour management -- RGB images and RGB solid colour rows include wrong settings.

Let it be: sRGB profile and not the Monitor profile !!!

jghali

2018-05-23 21:16

administrator   ~0045268

Avoid using special characters inside spot color names. Limit yourself to alphanumeric characters, spaces and underscores.

tcharlss

2018-05-23 21:30

reporter   ~0045269

Thank you very much, I changed the color name and that solved the problem.

I think there should be a warning of some sort if spot color names must follow a specific convention, which doesn't seem to be the case for regular colors.

Also @PeterBenedek thanks for the advice.

Issue History

Date Modified Username Field Change
2018-05-22 22:39 tcharlss New Issue
2018-05-22 22:39 tcharlss File Added: ton_direct.sla
2018-05-22 22:39 tcharlss File Added: ton_direct_color_config.png
2018-05-22 22:39 tcharlss File Added: ton_direct_edit.png
2018-05-22 22:39 tcharlss File Added: ton_direct_preview_cmjn.png
2018-05-22 22:39 tcharlss File Added: ton_direct_preview_pantone.png
2018-05-22 22:39 tcharlss Tag Attached: print preview
2018-05-22 22:39 tcharlss Tag Attached: spot color
2018-05-23 07:38 PeterBenedek File Added: test_direct_color.jpg
2018-05-23 07:38 PeterBenedek Note Added: 0045264
2018-05-23 07:45 tcharlss Note Added: 0045265
2018-05-23 07:50 PeterBenedek File Added: colour_management_settings.jpg
2018-05-23 07:50 PeterBenedek Note Added: 0045266
2018-05-23 21:16 jghali Note Added: 0045268
2018-05-23 21:30 tcharlss Note Added: 0045269