View Issue Details

IDProjectCategoryView StatusLast Update
0015352ScribusMaster Pagespublic2019-06-04 20:56
Reportereniva100 Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86-64OSWindowsOS Version7
Product Version1.5.4 
Target VersionFixed in Version1.5.5.svn 
Summary0015352: Scribus looses color setting of variable text marks
DescriptionWhen color is applied to a Variable Text Mark on a master page the document will show the text with the correct color. However after the document is saved and closed the color returns to black upon opening again the document file.
Steps To ReproduceCreate a new document

Add a color, name it Test color

Go to Edit Master pages

Add a text frame in the Normal master page and insert a new variable text mark in the text frame

Type any text in the Text to insert field and click on the OK button

Do a Select All in the text frame, this will select the text of the mark

Open the text properties window and change the color of the text to the newly created Test color

Close the Text properties window, your text should now be the color of Test color

Click on End edit to return to your document, you should see a text frame with the appropriate text and the color you applied

Close and save the document

Now open the document you just saved

The color is gone
TagsNo tags attached.
PatchNo

Activities

eniva100

2018-06-06 12:25

reporter   ~0045309

Tried it on 1.5.5.svn 24 April 2018 and got the same result

jghali

2018-06-06 20:03

administrator   ~0045310

The problem is not limited to master pages, the issue also occurs when the variable mark is placed on a standard page.

Issue History

Date Modified Username Field Change
2018-06-06 12:17 eniva100 New Issue
2018-06-06 12:25 eniva100 Note Added: 0045309
2018-06-06 20:02 jghali Summary Scribus loses color setting of variable text marks placed on a master page => Scribus loses color setting of variable text marks
2018-06-06 20:03 jghali Note Added: 0045310
2018-06-06 20:03 jghali Summary Scribus loses color setting of variable text marks => Scribus looses color setting of variable text marks
2018-06-06 20:17 jghali Assigned To => jghali
2018-06-06 20:17 jghali Status new => resolved
2018-06-06 20:17 jghali Resolution open => fixed
2018-06-06 20:17 jghali Fixed in Version => 1.5.5.svn
2019-06-04 20:56 cbradney Status resolved => closed