View Issue Details

IDProjectCategoryView StatusLast Update
0015392ScribusImport / Exportpublic2019-06-04 20:56
Reporterdcpurton Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinuxOS VersionDebian testing
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015392: RGB colours changed when exported to PDF and SVG
DescriptionWhen exporting RGB colours to a PDF for Screen/Web or an SVG, they are slightly adjusted. This seems to occur regardless of colour management settings.
Steps To Reproduce1. Start with a new document.
2. Create an RGB colour in Colours and Fills…, e.g., R 228 G 0 B 43
3. Create a rectangle and apply the new colour as its fill.
4. Export to PDF (1.3; Screen/Web; do not compressed text and vector graphics)
5. Open resulting PDF and confirm that the colour is: 0.89412 0.00000 0.17647 rg, which corresponds to R 228 G 0 B 45.

The PDF should contain 0.89412 0.00000 0.16863 rg
Additional InformationTested with Scribus 1.5.5svn r22594.
TagsNo tags attached.
PatchNo

Activities

dcpurton

2018-08-04 01:55

reporter   ~0045362

The same behaviour also occurs when exporting to images with colour management disabled.

jghali

2018-08-05 16:34

administrator   ~0045363

The issue is caused by some rounding errors in QColor getHsv() and setHsv(). Now fixed.

Issue History

Date Modified Username Field Change
2018-08-04 01:45 dcpurton New Issue
2018-08-04 01:55 dcpurton Note Added: 0045362
2018-08-05 16:34 jghali Assigned To => jghali
2018-08-05 16:34 jghali Status new => resolved
2018-08-05 16:34 jghali Resolution open => fixed
2018-08-05 16:34 jghali Fixed in Version => 1.5.5.svn
2018-08-05 16:34 jghali Note Added: 0045363
2019-06-04 20:56 cbradney Status resolved => closed