View Issue Details

IDProjectCategoryView StatusLast Update
0015417ScribusImport / Exportpublic2019-10-08 09:58
Reporterchristoph_s Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version1.5.5.svn 
Target VersionFixed in Version 
Summary0015417: SVG file cannot be correctly imported
DescriptionScribus has problems importing the file https://de.wikipedia.org/wiki/Kreis_Nordfriesland#/media/File:DEU_Kreis_Nordfriesland_COA.svg. It doesn't show the coat of arms but a single coloured square.
TagsNo tags attached.
PatchNo

Activities

jghali

2018-09-05 19:58

administrator   ~0045430

Unable to reproduce.

15417_svg_import.png (273,028 bytes)
15417_svg_import.png (273,028 bytes)

christoph_s

2018-09-05 23:47

administrator   ~0045431

That's what I get on Windows 10.

NF-SVG-import.png (28,893 bytes)
NF-SVG-import.png (28,893 bytes)

ale

2018-09-06 12:50

manager   ~0045433

works here too...

christoph_s

2018-09-06 18:55

administrator   ~0045435

That's really odd. I tried with 1.4.7, 1.5.4 and 1.5.5svn. Always the same result. Other SVGs can be imported without any problems.

PeterBenedek

2018-09-06 19:07

developer   ~0045437

I tested in LinuxMint too. Nothig problem. Works well.

jghali

2018-09-06 19:09

administrator   ~0045438

Tested again in a Windows 10 VM. Works too.

15417_svg_import_win10.png (167,451 bytes)
15417_svg_import_win10.png (167,451 bytes)

christoph_s

2018-09-06 22:05

administrator   ~0045439

Further testing: I ungrouped the file and checked with the Properties Palette. There have been no colours imported; all items are in CMYK Black.

ale

2018-09-07 07:33

manager   ~0045440

take off your sun glasses?

christoph_s

2018-09-07 23:38

administrator   ~0045446

I don't even have sun glasses ;)

christoph_s

2018-09-10 22:11

administrator   ~0045454

Tried again on yet another Windows 10 machine and *all* installed Scribus versions show the result as described by me.

Nelsson

2019-10-08 09:58

reporter   ~0046753

Tested this on Linux Manjaro, it imports without errors. However similar error occurs when reading a svg with <style> tags, perhaps that gives some way to figure out how this error happens (failing at the same point maybe?). Has anyone else tested this on Windows 10 (not VM)? Something dependency-related maybe?

Issue History

Date Modified Username Field Change
2018-09-05 19:18 christoph_s New Issue
2018-09-05 19:58 jghali File Added: 15417_svg_import.png
2018-09-05 19:58 jghali Note Added: 0045430
2018-09-05 23:47 christoph_s File Added: NF-SVG-import.png
2018-09-05 23:47 christoph_s Note Added: 0045431
2018-09-06 12:50 ale Note Added: 0045433
2018-09-06 18:55 christoph_s Note Added: 0045435
2018-09-06 19:07 PeterBenedek Note Added: 0045437
2018-09-06 19:09 jghali File Added: 15417_svg_import_win10.png
2018-09-06 19:09 jghali Note Added: 0045438
2018-09-06 22:05 christoph_s Note Added: 0045439
2018-09-07 07:33 ale Note Added: 0045440
2018-09-07 23:38 christoph_s Note Added: 0045446
2018-09-10 22:11 christoph_s Note Added: 0045454
2019-10-08 09:58 Nelsson Note Added: 0046753