View Issue Details

IDProjectCategoryView StatusLast Update
0015426ScribusUsabilitypublic2018-09-29 20:05
Reporteredraioma Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSLinuxOS Version
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015426: Pasting path into file dialog and hitting return stopped working
DescriptionUp to a few weeks ago I could jump to any place in the filesystem by simply pasting the whole path into the Name-Filed in the file dialog.

I use this quite frequently when impoting images from various locations on my system, so it is a big annoyance, and a lot of additional clicking is needed since this feature stopped working.

Now, when I paste a path into the filename filed it simnply does nothing.

TagsNo tags attached.
PatchNo

Activities

jghali

2018-09-16 13:30

administrator   ~0045457

I don't remember that dropping an URL into the filename edit line was ever supported. What is supported is dropping an URL into the file list and this is expected to move file dialog to URL directory. According to my tests, this still works.

DnD may also put the URL filename into the file dialog edit line, however the behavior here depends directly on Qt, the GUI toolkit we use, and for this to happen, the file dialog edit line must not have focus, ie practically the cursor must not be shown inside.

ale

2018-09-17 07:30

manager   ~0045461

jean, if i understand the issue correctly, that's a known bug that has been introduced for fixing an issue that only happens on specific linux systems (opensuse?).

i have a (refused) patch that i apply to my version of scribus to activate again the normal / old behavior.

```
--- a/scribus/ui/scfilewidget.cpp
+++ b/scribus/ui/scfilewidget.cpp
@@@ -66,16 -66,12 +66,15 @@@ QString ScFileWidget::selectedFile(
      return l.at(0);
  }
  
 -/* Hack to make the previews in our file dialogs useable again
 - needed e.g on OpenSuse patched Qt versions */
 -// remove the hack to get the dialog to work correctly on all other systems (ale)
 +/* Hack to make the previews in our file dialogs useable again,
 + needed e.g on OpenSuse KDE. Otherwise file would open on first
 + click, leaving user no time to see preview. Drawback: in other
 + Linux desktop environment, this may force user to click OK for
 + opening/saving file. */
++ // hack removed to get the dialog to work correctly on all other systems (ale)
  void ScFileWidget::accept()
  {
- #ifndef Q_OS_LINUX
      QFileDialog::accept();
- #endif
  }
  
  void ScFileWidget::locationDropped(QString fileUrl)
```

of course, i would love it, if this (in my eyes) absurd hack was removed... but i guess it's hopeless...

edraioma

2018-09-17 07:33

reporter   ~0045462

First: thank you for the hint about dropping an URL into the file list.
I diden't know, this worked. That's because I mainly work with the keyboard, using shortcuts whenever possible.
It's much faster that way.

What I used before it stopped working was the following series of shortcuts (having selected the image I want to insert and copied it's path to the clipboard):
Ctrl-i - Ctrl-v - Return
and that was it!

Now Ctrl-i - Ctrl-v still inserts the path into the Filename-Field, but hitting Return simply does nothing!

jghali

2018-09-17 08:13

administrator   ~0045465

>> jean, if i understand the issue correctly, that's a known bug that has been introduced for fixing an issue that only happens on specific linux systems (opensuse?)

No, this hack has been introduced to fix an issue that will affect basically any KDE user.

ale

2018-09-18 09:58

manager   ~0045468

yep, jean, the hack fixed an issue for basically any KDE user and introduced an issue for all linux users who are used to type the url in the file dialogs and do not klick...
i don't think i have other c++/Qt application around to test it, but i don't know of any other software that behaves like scribus (without the above patch).
personally, i'm fine with applying the patch, but i fear that once 1.5 becomes stable, we will have more people complaining...

ale

2018-09-19 06:50

manager   ~0045469

i've tried with krita: typing "/tmp/ in the filen name field, shows the files in /tmp...
krita does work correctly for me and i have to suppose that it's not broken with KDE... since it's (on of the) the flaship KDE application(s)...

edraioma

2018-09-19 09:15

reporter   ~0045470

I can second ale: krita works as expected on my system too.

jghali

2018-09-19 11:27

administrator   ~0045471

Last edited: 2018-09-19 11:30

View 2 revisions

>> krita does work correctly for me and i have to suppose that it's not broken with KDE...

1) Krita use native KDE file dialog by default on KDE. We can't.
2) Krita does not provide a file preview on Ubuntu (for eg.) in it's File > Open Dialog and hence can use unmodified Qt file dialog. We can't.

So basically Krita file dialog does not have the same constraints, does not provide the same functionality, and hence you cannot compare the situations.

jghali

2018-09-19 21:34

administrator   ~0045472

I found a more "elegant" way to implement our hack. Now pasting a path into the filename edit line and hitting return should work again on Linux.

PeterBenedek

2018-09-21 05:58

developer   ~0045473

Last edited: 2018-09-21 06:04

View 3 revisions

Tested r22702; LinuxMint 19 (Ubuntu 18.04)

Works well (it hasn't worked so far, now it is working).
Many thanks!

ale

2018-09-22 15:51

manager   ~0045478

yes, i did a quick test and scribus seems not now to be working correctly!

thanks jean!

PeterBenedek

2018-09-26 15:21

developer   ~0045483

"...seems not now to be working correctly!"

Is this a mistake, ale?

ale

2018-09-27 06:12

manager   ~0045484

yep, a typo : - (

it seems to be working correctly!

PeterBenedek

2018-09-28 17:04

developer   ~0045487

Closing?

jghali

2018-09-29 20:05

administrator   ~0045488

Closed.

Issue History

Date Modified Username Field Change
2018-09-16 10:09 edraioma New Issue
2018-09-16 13:30 jghali Note Added: 0045457
2018-09-17 07:30 ale Note Added: 0045461
2018-09-17 07:33 edraioma Note Added: 0045462
2018-09-17 08:13 jghali Note Added: 0045465
2018-09-18 09:58 ale Note Added: 0045468
2018-09-19 06:50 ale Note Added: 0045469
2018-09-19 09:15 edraioma Note Added: 0045470
2018-09-19 11:27 jghali Note Added: 0045471
2018-09-19 11:30 jghali Note Edited: 0045471 View Revisions
2018-09-19 21:11 jghali Summary Paste path into file Dialog stopped working => Pasting path into file dialog and hitting return stopped working
2018-09-19 21:34 jghali Assigned To => jghali
2018-09-19 21:34 jghali Status new => resolved
2018-09-19 21:34 jghali Resolution open => fixed
2018-09-19 21:34 jghali Fixed in Version => 1.5.5.svn
2018-09-19 21:34 jghali Note Added: 0045472
2018-09-21 05:58 PeterBenedek Note Added: 0045473
2018-09-21 06:00 PeterBenedek Note Edited: 0045473 View Revisions
2018-09-21 06:04 PeterBenedek Note Edited: 0045473 View Revisions
2018-09-22 15:51 ale Note Added: 0045478
2018-09-26 15:21 PeterBenedek Note Added: 0045483
2018-09-27 06:12 ale Note Added: 0045484
2018-09-28 17:04 PeterBenedek Note Added: 0045487
2018-09-29 20:05 jghali Status resolved => closed
2018-09-29 20:05 jghali Note Added: 0045488