View Issue Details

IDProjectCategoryView StatusLast Update
0015498ScribusImport / Exportpublic2019-06-04 20:55
ReporterJoanie814 Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4 
Target VersionFixed in Version1.5.5.svn 
Summary0015498: Document crashes Scribus upon export to pdf
DescriptionI have used previous Scribus versions for years and I am familiar with the software. Tested documents in 1.5.4 and they worked fine so I completed my new project in the latest version. Ran collect for output and opened the .sla file to export to .pdf for professional printing. I set set 0.25 crops and choose to print crops and bleeds. The program immediately crashes. A small .pdf file is created but will not open, the fie is too small to be complete. I've tried to export to image and eps with same results. I really need to get this printed and mailed out as soon as possible. I've uploaded my .sla file, but the collect for output folder is too large to upload here. Can you save it?
Steps To ReproduceOpen .sla file and Export to pdf
TagsNo tags attached.
PatchNo

Activities

Joanie814

2018-12-05 04:47

reporter  

Bell_Medical_Catalog_102018.sla (1,609,773 bytes)

Luna Nightshade

2018-12-05 09:32

reporter   ~0045681

I do not have the font Cooper Black, but the document fails to export to PDF in 1.5.5svn as well.

jghali

2018-12-05 11:36

administrator   ~0045682

Last edited: 2018-12-05 11:56

View 2 revisions

On PDF export, the crash occurs in the fonts subsetting code, I'll need a bit of time to see exactly what happens. As a workaround, you can change the font embedding mode to "Outline All Fonts". In this case the fonts will be vectorized.

jghali

2018-12-06 22:13

administrator   ~0045697

I committed a fix for PDF export, I'll upload by tomorrow night some snapshots for WIndows. I cannot reproduce a crash when exporting to images or EPS. I suspect those other crashes might be caused by the important number of images in the document and consequent high memory consumption. When working with long documents or documents containing a high number of images, it is always recommended to split document into smaller ones.

jghali

2018-12-07 20:27

administrator   ~0045703

Last edited: 2018-12-07 20:28

View 2 revisions

I have uploaded new snapshots, numbered 181207, with the fix for Windows:
https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.5.svn/

PeterBenedek

2018-12-08 07:54

developer   ~0045704

Tested Linux Mint 19.0; r22781

I can't reproduce.
Works perfectly.

Issue History

Date Modified Username Field Change
2018-12-05 04:47 Joanie814 New Issue
2018-12-05 04:47 Joanie814 File Added: Bell_Medical_Catalog_102018.sla
2018-12-05 09:32 Luna Nightshade Note Added: 0045681
2018-12-05 11:36 jghali Note Added: 0045682
2018-12-05 11:56 jghali Note Edited: 0045682 View Revisions
2018-12-06 22:13 jghali Note Added: 0045697
2018-12-07 20:05 jghali Summary 79 page document crashes Scribus upon export to pdf, eps or image => Document crashes Scribus upon export to pdf
2018-12-07 20:05 jghali Assigned To => jghali
2018-12-07 20:05 jghali Status new => resolved
2018-12-07 20:05 jghali Resolution open => fixed
2018-12-07 20:20 jghali Priority urgent => normal
2018-12-07 20:20 jghali Fixed in Version => 1.5.5.svn
2018-12-07 20:27 jghali Note Added: 0045703
2018-12-07 20:28 jghali Note Edited: 0045703 View Revisions
2018-12-08 07:54 PeterBenedek Note Added: 0045704
2019-06-04 20:55 cbradney Status resolved => closed