View Issue Details

IDProjectCategoryView StatusLast Update
0015537ScribusBuild Systempublic2019-06-04 20:55
Reportererictapen Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64-linuxOSNixOSOS Versionnixos-unstable
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015537: changes in poppler 0.73.0 cause build failure
DescriptionUnpatched Scribus fails to build against poppler 0.73.0 under NixOS with the following error message:


[ 89%] Generating ui_pdfimportoptions.h
[ 89%] Generating moc_importpdf.cpp
[ 89%] Generating moc_importpdfplugin.cpp
[ 89%] Generating moc_pdfimportoptions.cpp
Scanning dependencies of target importpdf
[ 89%] Building CXX object scribus/plugins/import/pdf/CMakeFiles/importpdf.dir/importpdf.cpp.o
In file included from /build/Scribus-r22730/scribus/plugins/import/pdf/importpdf.cpp:18:0:
/build/Scribus-r22730/scribus/plugins/import/pdf/slaoutput.h:31:10: fatal error: poppler/goo/gtypes.h: No such file or directory
 #include <poppler/goo/gtypes.h>
          ^~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [scribus/plugins/import/pdf/CMakeFiles/importpdf.dir/build.make:78: scribus/plugins/import/pdf/CMakeFiles/importpdf.dir/importpdf.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1763: scribus/plugins/import/pdf/CMakeFiles/importpdf.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 89%] Linking CXX shared module libimportpages.so
[ 89%] Linking CXX shared module libimportpct.so
[ 89%] Built target importpages
[ 89%] Built target importpct
[ 89%] Linking CXX shared module libimportodg.so
[ 89%] Built target importodg
make: *** [Makefile:152: all] Error 2


It seems to me that the cause is [0], as it deletes poppler/goo/gtypes.h. For Nixpkgs, I patched Scribus and it results in a working build, so I guess that patch [1] would be desirable at upstream as well.

[0] https://gitlab.freedesktop.org/poppler/poppler/commit/ef3ef702bc3dc845731e43215400448c5324efd4
[1] https://github.com/erictapen/nixpkgs/blob/scribusUnstable-poppler-fix/pkgs/applications/office/scribus/poppler-0.73.0.patch
Steps To Reproduce1. Have Nix installed and download a current Nixpkgs checkout (in my case e8c996295762c91f9b208974a53568e3a38e588a).

2. Run

  nix build nixpkgs.scribusUnstable -I nixpkgs=/path/to/your/nixpkgs

3. Experience the build error.
TagsNo tags attached.
PatchYes

Activities

erictapen

2019-01-15 12:45

reporter  

poppler-0.73.0.patch (464 bytes)
diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
--- a/scribus/plugins/import/pdf/slaoutput.h
+++ b/scribus/plugins/import/pdf/slaoutput.h
@@ -28,7 +28,7 @@ for which a new license (GPL+exception) is in place.
 #include "selection.h"
 #include "vgradient.h"
 
-#include <poppler/goo/gtypes.h>
+#include <poppler/goo/gfile.h>
 #include <poppler/Object.h>
 #include <poppler/OutputDev.h>
 #include <poppler/Gfx.h>
poppler-0.73.0.patch (464 bytes)

jghali

2019-01-15 13:17

administrator   ~0045790

Isn't it sufficient to remove gtypes.h include? It does not seem we are using any definition from gfile.h...

erictapen

2019-01-15 13:23

reporter   ~0045791

Oh, that sounds like a much easier solution. It would be even backwards compatible.

jghali

2019-01-15 13:32

administrator   ~0045792

Last edited: 2019-01-15 13:34

View 2 revisions

If it works for you without gfile.h, I'll just remove gtypes.h include. I have already done some adjustments for poppler 0.73.0 in importpdfconfig.h. Please test, I have only poppler 0.71.0 here.

jghali

2019-01-16 00:32

administrator   ~0045793

I wonder where I had my head, no removing gfile.h can't work for older poppler versions. I used a different method which includes it only for poppler versions < 0.73.0. Please test.

jghali

2019-01-16 00:33

administrator   ~0045794

Precision: fix has been committed as svn r22806.

erictapen

2019-01-16 13:56

reporter   ~0045796

Sorry for not calling back. I can confirm that Scribus builds fine with poppler-0.73.0 and Scribus r22806. I also opened the app and exported a PDF for testing. Thanks!

https://github.com/NixOS/nixpkgs/pull/54055

jghali

2019-01-16 14:14

administrator   ~0045797

Thanks for the feedback! I'm resolving this issue then.

Issue History

Date Modified Username Field Change
2019-01-15 12:45 erictapen New Issue
2019-01-15 12:45 erictapen File Added: poppler-0.73.0.patch
2019-01-15 13:17 jghali Note Added: 0045790
2019-01-15 13:23 erictapen Note Added: 0045791
2019-01-15 13:32 jghali Note Added: 0045792
2019-01-15 13:34 jghali Note Edited: 0045792 View Revisions
2019-01-16 00:32 jghali Note Added: 0045793
2019-01-16 00:33 jghali Note Added: 0045794
2019-01-16 13:56 erictapen Note Added: 0045796
2019-01-16 14:14 jghali Assigned To => jghali
2019-01-16 14:14 jghali Status new => resolved
2019-01-16 14:14 jghali Resolution open => fixed
2019-01-16 14:14 jghali Fixed in Version => 1.5.5.svn
2019-01-16 14:14 jghali Note Added: 0045797
2019-06-04 20:55 cbradney Status resolved => closed