View Issue Details

IDProjectCategoryView StatusLast Update
0015543ScribusTemplatespublic2019-06-04 20:55
ReporterRoland Illig Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4 
Target VersionFixed in Version1.5.5.svn 
Summary0015543: Prices on Menükarte template disappear
DescriptionTo get a first impression of Scribus, I searched for an example document. I found one by opening "Menükarte_1" from the templates.

When I doubleclicked into one of the text areas, I saw a left-aligned tabstop at 150 mm. "They cannot be serious about this", was my first thought. And indeed, as soon as I change the price from 4.90 to 14.90, the whole price disappears and the text area's border becomes red.

This means that the template is bad because it does not even work for its intended use case, being a menu card for a restaurant. It could only be used for cafés where all prices are below 10.00 in whatever currency is used in that country.

This template violates the general rule that the templates should demonstrate best practices.
TagsNo tags attached.
PatchNo

Activities

jghali

2019-01-19 21:44

administrator   ~0045823

>> being a menu card for a restaurant

Sorry, it is nowhere specified it is a template for a restaurant menu...

Roland Illig

2019-01-19 22:00

reporter   ~0045824

>>>> being a menu card for a restaurant

>> Sorry, it is nowhere specified it is a template for a restaurant menu...

Of course it is, the template name says it all. It is called "Menükarte", which directly translates to menu. Even more, in German the word Menü specifically refers to a series of dishes.

The Wikipedia article https://de.wikipedia.org/wiki/Menükarte redirects to Speisekarte, and that is linked to https://en.wikipedia.org/wiki/Menu.

jghali

2019-01-19 22:02

administrator   ~0045825

>> This means that the template is bad because it does not even work for its intended use case

By definition a template is not a final document. A template is by definition made to be modified. In this case, the tapstop is one of the parameter subject to modification. It cannot be always right in the template as depending on the kind of menu, the kind of restaurant and the currency, the prices can vary greatly...

jghali

2019-01-19 22:10

administrator   ~0045826

>> Even more, in German the word Menü specifically refers to a series of dishes.

This is German centric as the original name of the template is in English and is "Menu template". So it could be a bar menu... If you can provide a better translation then, feel free.

Roland Illig

2019-01-19 22:20

reporter   ~0045827

This bug report is not about the name of the template but about its features.

Scribus provides decimal tabstops as a feature, and this menu is exactly what these should be used for. Therefore this template should use them.

jghali

2019-01-19 22:52

administrator   ~0045828

>> Scribus provides decimal tabstops as a feature

This is not exact.

Roland Illig

2019-01-19 23:41

reporter   ~0045830

>>>> Scribus provides decimal tabstops as a feature

>> This is not exact.

Ok, let's make that "comma tabstop" and "period tabstop". Since the numbers in the template are currently in English, the "period tabstop" should be used.

Even better would be to really have a "decimal tabstop" that would behave either like a comma or a period tabstop, depending on the language selected for the paragraph. But that's an entirely different topic.

jghali

2019-01-20 00:05

administrator   ~0045832

Last edited: 2019-01-20 00:08

View 2 revisions

>> Ok, let's make that "comma tabstop" and "period tabstop". Since the numbers in the template are currently in English, the "period tabstop" should be used.

This is not exact either. Scribus provide absolutely no feature which allows to align automatically numbers decimal separator, whether the decimal separator is a comma or a period. What Scribus can do is fill the blank spaces defined by the tab by using a specific character.

Roland Illig

2019-01-20 01:43

reporter   ~0045835

>> This is not exact either. Scribus provide absolutely no feature which allows to align automatically numbers decimal separator, whether the decimal separator is a comma or a period. What Scribus can do is fill the blank spaces defined by the tab by using a specific character.

If that were true, I wonder why there are 5 types of tabulator instead of only 3. That sounds very much like (left, center, right, period, comma).

https://github.com/scribusproject/scribus/blob/master/scribus/ui/tabruler.cpp#L135

It's confusing that the tabulator type is a simple int instead of an enum. It's also confusing that comma and period are painted the same. But since the ruler lines are painted in strong colors, the visual difference between a period tabulator and a comma tabulator would not be visible anyway.

jghali

2019-02-02 13:35

administrator   ~0045880

>> If that were true, I wonder why there are 5 types of tabulator instead of only 3. That sounds very much like (left, center, right, period, comma).

Ooops indeed... I remembered we had once such a feature request. I didn't remember and didn't think it had been implemented. So I have replaced tabulators in that template by period tabulators.

Issue History

Date Modified Username Field Change
2019-01-19 21:04 Roland Illig New Issue
2019-01-19 21:38 jghali Summary Prices on Menükarte disappear => Prices on Menükarte template disappear
2019-01-19 21:44 jghali Note Added: 0045823
2019-01-19 22:00 Roland Illig Note Added: 0045824
2019-01-19 22:02 jghali Note Added: 0045825
2019-01-19 22:10 jghali Note Added: 0045826
2019-01-19 22:20 Roland Illig Note Added: 0045827
2019-01-19 22:52 jghali Note Added: 0045828
2019-01-19 23:41 Roland Illig Note Added: 0045830
2019-01-20 00:05 jghali Note Added: 0045832
2019-01-20 00:08 jghali Note Edited: 0045832 View Revisions
2019-01-20 01:43 Roland Illig File Added: 2019-01-20 02_42_08-Window.png
2019-01-20 01:43 Roland Illig Note Added: 0045835
2019-02-02 13:35 jghali Note Added: 0045880
2019-02-02 13:36 jghali Assigned To => jghali
2019-02-02 13:36 jghali Status new => resolved
2019-02-02 13:36 jghali Resolution open => fixed
2019-02-02 13:36 jghali Fixed in Version => 1.5.5.svn
2019-06-04 20:55 cbradney Status resolved => closed