View Issue Details

IDProjectCategoryView StatusLast Update
0015596ScribusInternalpublic2019-06-04 20:55
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015596: remove the global variable ScMW
Descriptionremove the "ScribusMainWindow SCRIBUS_API *ScMW" global variable defined in the main_*.cpp files.

it seems to be unused and it's IMO frightening enough to have a global ScCore that is "indirectly" defined...

(please also remove the out commented code that is using it and fix the copyright notices that call the application ScMW instead of Scribus : - ) .. you can grep for " ScMW" to find them...)
TagsNo tags attached.
PatchNo

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-03-11 08:42 ale New Issue
2019-03-11 12:34 jghali Category - => Internal
2019-03-11 12:43 jghali Assigned To => jghali
2019-03-11 12:43 jghali Status new => resolved
2019-03-11 12:43 jghali Resolution open => fixed
2019-03-11 12:43 jghali Fixed in Version => 1.5.5.svn
2019-06-04 20:55 cbradney Status resolved => closed