View Issue Details

IDProjectCategoryView StatusLast Update
0015614ScribusShape Drawingpublic2019-06-04 20:55
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015614: path tools > subtract does not work correctly
Description- the preview is correct
- the execution is poor
- undo does not work
TagsNo tags attached.
PatchNo

Activities

ale

2019-03-24 10:16

manager  

path-tools-substract.gif (196,062 bytes)
path-tools-substract.gif (196,062 bytes)

jghali

2019-03-24 13:14

administrator   ~0046037

Please provide sample document. I did a test and cannot reproduce an issue.

ale

2019-03-24 18:37

manager   ~0046038

et voilĂ .

the two rectangles on top are the result of the substraction of left and middle.

below a duplicate of the three original shapes...

path-substract.sla (16,863 bytes)

ale

2019-04-01 08:02

manager   ~0046057

the undo seems to work now, but the substraction still does not work...

btw, in the attached .sla file, one has to first convert the left text frame into a polygon.
sorry for the mismatch.

ale

2019-04-01 08:08

manager  

path-tools-substract-02.gif (415,144 bytes)
path-tools-substract-02.gif (415,144 bytes)

jghali

2019-04-01 08:30

administrator   ~0046058

Last edited: 2019-04-01 08:35

View 2 revisions

It does work, the problem is that your text frame has no fill or stroke color. Once converted to a polygon, that does not change. And in the dialog you have choosen to use colors of left frame... which means in this case no colors.

ale

2019-04-01 15:46

manager   ~0046059

ok, yes, now i understand what happens...

scribus is showing the bounding box of the item, not its shape...

converting it to a text frame does then show the right shape (as it then shows both the frame border and the bounding box).

it's a bit "surprising" but it's not wrong.

Issue History

Date Modified Username Field Change
2019-03-24 10:16 ale New Issue
2019-03-24 10:16 ale File Added: path-tools-substract.gif
2019-03-24 13:14 jghali Note Added: 0046037
2019-03-24 18:37 ale File Added: path-substract.sla
2019-03-24 18:37 ale Note Added: 0046038
2019-03-30 02:38 jghali Summary path tools > susbstract does not work correctly => path tools > subtract does not work correctly
2019-03-30 02:43 jghali Assigned To => jghali
2019-03-30 02:43 jghali Status new => resolved
2019-03-30 02:43 jghali Resolution open => fixed
2019-03-30 02:43 jghali Fixed in Version => 1.5.5.svn
2019-03-30 13:12 jghali Category - => Shape Drawing
2019-04-01 08:02 ale Status resolved => feedback
2019-04-01 08:02 ale Resolution fixed => reopened
2019-04-01 08:02 ale Note Added: 0046057
2019-04-01 08:08 ale File Added: path-tools-substract-02.gif
2019-04-01 08:30 jghali Note Added: 0046058
2019-04-01 08:31 jghali Status feedback => resolved
2019-04-01 08:31 jghali Resolution reopened => fixed
2019-04-01 08:35 jghali Note Edited: 0046058 View Revisions
2019-04-01 15:46 ale Note Added: 0046059
2019-06-04 20:55 cbradney Status resolved => closed