View Issue Details

IDProjectCategoryView StatusLast Update
0015656ScribusGeneralpublic2020-04-14 12:18
Reportermilo Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformmacOSXOS Version10.11.6
Product Version 
Target VersionFixed in Version1.5.6.svn 
Summary0015656: comma and decimals
Description1. Ensure that metrics use commas instead of fullstops. At least for cm and mm.
2. Restrict the decimal numbers to two digits after the comma for *all* units. (At least I wouldn't know of anyone using anything beyond two decimal naumers)
See screenshot
TagsNo tags attached.
PatchNo

Activities

milo

2019-04-20 15:37

reporter  

comma and decimals.png (47,018 bytes)
comma and decimals.png (47,018 bytes)

Robby A

2019-04-20 18:30

reporter   ~0046137

Please do not replace dots in decimals with commas. This would cause unbearable confusion when use of stops for decimals is nearly universal and commas are used only to demarcate the triple digits in thousands to make them easily readable.

milo

2019-04-20 19:38

reporter   ~0046138

... universal ... Sorry, but that's simply NOT true. Especially not for units as *cm* and *mm*. Inches may be another story (that's also why I asked for cm and mm only). Comma is the preferred sign i.e. by ISO.

Additionally, I'd even argue that fontsizes in *pt* don't need fractioning ... but maybe for the sake of calculation between units, it may be necessary from a programmers point of view !?

utnik

2019-04-21 06:48

updater   ~0046143

i'm in the 'metric region' and full stops are common as decimal separators here.
for ISO take a look at this: https://www.iso.org/schema/isosts/v1.1/doc/n-cdf0.html – no need to change anything!

Luna Nightshade

2019-04-21 21:35

reporter   ~0046144

The use of "point" or "comma" as a decimal delimiter should simply be done according to the used language. I am from Germany and we use the comma for decimals. Whereas those familiar with programming know that every programming language uses the point.

But please do not change it for the units!

jghali

2019-04-21 22:36

administrator   ~0046145

>> 1. Ensure that metrics use commas instead of fullstops. At least for cm and mm.

That would not be correct to do that systematically. That would be also incorrect to do that depending on unit. The decimal separator is country dependent.

>> Please do not replace dots in decimals with commas. This would cause unbearable confusion when use of stops for decimals is nearly universal

Use of stops for decimals is anything except universal. Just look here: https://en.wikipedia.org/wiki/Decimal_separator. There are in fact more countries using comma as decimal separator than countries using fullstops.

>> i'm in the 'metric region' and full stops are common as decimal separators here. for ISO take a look at this: https://www.iso.org/schema/isosts/v1.1/doc/n-cdf0.html – no need to change anything!

We could use current system locale to format numbers. That should not change anything for you. But that would allow us to use the correct decimal separator in countries using the comma as decimal separator.

milo

2019-04-22 00:23

reporter   ~0046146

@RobbyA
Talking about "… unbearable confusion …", have you noticed the diverse usage of commas and periods throughout the application?
- In the bottom status bar, periods for all units
- In the "Preferences > General Document Setup", comma is used for width and height in all units, *except* for Picas
- In Text Properties, Guides Manager … all using comma

@utnik
Yes, as ISO explicitly specifies "... either “.” or “,” ..."
But neither is there such a thing as one "metric region", nor is ISO the only norm on earth. Just check DIN norm. Not to speak of the different language orthographies within one and the same "metric region", etc. ...

@jghali
>>… separator is country dependent …
IMO, not quite. If I where specifying *inches* in a croatian/german text, I wouldn't use a comma as a separator, but a period. And I would expect to see a comma in an english text, specifying an amount in Euro. Consequently in the app I wouldn't be surprised by a period separator, where inches are specified. But maybe that's just me being strange ;-)

@someone who is administrator
Please change this issue to a "FEATURE REQUEST" as follows:

1. When selecting the "Language" in Scribus' preferences, Scribus should use the user's system language settings for number separators. (If possible, inches could be left out to use only period. I don't think there is any country/language using inches and commas together)

2. If there is no specific need, please restrict decimal numbers to two digits after the comma/period. All due respect, but I don't understand the need for the ability of setting *micrometers* (0,001 mm or aprox. 0,000039 inch), nor for informing the user about such values – no matter what the unit may be. We are talking about desktop publishing after all …

ale

2019-04-23 15:30

manager   ~0046147

hi milo, one note from my side:

UI language and units preferences often do not match.

- there are lot of people who are using an english / us UI, but want their localized units;
- there are "languages" that do not have a specific UI localization... (my "mother language" does not... but it often has an own localization for units...)

taking the system defaults can also be a problem (in my case it probably will be... but i'm a bit of an exception there...)
scribus should probably allow the user to select a specific units "set" and, indeed, default to the UI language.

milo

2019-04-23 16:30

reporter   ~0046150

>> allow the user to select a specific units "set" and, indeed, default to the UI language.
yes, that would be very user friendly, i agree. (i'm no programmer, but i presume that's more work for implementing – adding some fields in the UI, etc.)
maybe it can be done in 2 steps:
1. implement user's default system language & restrict to two decimals – as proposed by me
2. add user specific settings in scribus' preferences – as proposed by you

utnik

2020-04-14 08:50

updater   ~0047514

i'm not sure if a restriction to two decimals is a good thing. if you use inches as your standard unit, 1/8" (0.125") is a often used fraction.

cbradney

2020-04-14 08:51

administrator   ~0047515

That's why I didn't add that, and won't

cbradney

2020-04-14 08:53

administrator   ~0047516

Code changed in r23608 to allow selection of numeric separators and align across UI

utnik

2020-04-14 10:32

updater   ~0047519

ok. great, thanks!

ale

2020-04-14 11:03

manager   ~0047521

Last edited: 2020-04-14 11:09

View 3 revisions

hi craig,

how does one select a locale?

as an example, what do i need to do if i want fr_LU ? (or it_CH / fr_CH... for things that matter more to me : -)

ps.: i'm trying to find the relevant code in the diff, found traces of it, but i still didn't find in the the UI...

p.p.s: ok, i might not have been updating the code correctly... i'm building again...

cbradney

2020-04-14 11:06

administrator   ~0047522

Its very basic.. preferences->user interface, then Number Format is either System (whatever Qt has detected as your system local, or the format based on the language selected.

ale

2020-04-14 12:18

manager   ~0047523

ok, yes, i finally got the right code to compile.

it looks like a good solution.

Issue History

Date Modified Username Field Change
2019-04-20 15:37 milo New Issue
2019-04-20 15:37 milo File Added: comma and decimals.png
2019-04-20 18:30 Robby A Note Added: 0046137
2019-04-20 19:38 milo Note Added: 0046138
2019-04-21 06:48 utnik Note Added: 0046143
2019-04-21 21:35 Luna Nightshade Note Added: 0046144
2019-04-21 22:36 jghali Note Added: 0046145
2019-04-22 00:23 milo Note Added: 0046146
2019-04-23 15:30 ale Note Added: 0046147
2019-04-23 16:30 milo Note Added: 0046150
2020-04-14 08:34 cbradney Assigned To => cbradney
2020-04-14 08:34 cbradney Status new => resolved
2020-04-14 08:34 cbradney Resolution open => fixed
2020-04-14 08:34 cbradney Fixed in Version => 1.5.6.svn
2020-04-14 08:50 utnik Note Added: 0047514
2020-04-14 08:51 cbradney Note Added: 0047515
2020-04-14 08:53 cbradney Note Added: 0047516
2020-04-14 10:32 utnik Note Added: 0047519
2020-04-14 11:03 ale Note Added: 0047521
2020-04-14 11:06 ale Note Edited: 0047521 View Revisions
2020-04-14 11:06 cbradney Note Added: 0047522
2020-04-14 11:09 ale Note Edited: 0047521 View Revisions
2020-04-14 12:18 ale Note Added: 0047523