View Issue Details

IDProjectCategoryView StatusLast Update
0015670ScribusPDFpublic2019-07-30 21:27
Reportersonejostudios Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4 
Target VersionFixed in Version1.5.5.svn 
Summary0015670: PDF Link annotations not updated when inserting/removing pages
DescriptionProblem:

While making a PDF with link annotations to pages, the page number links are absolute. That means, after inserting a new page in the beginning, all links are wrong (they are still going to the right page number, but the content of the pages changed, so the link doesn't go to the right page content).

Feature request:

Update page number links while inserting a new page in the project.

Is there a kind of page ID? The best would be to add links to page IDs, and then convert this to page number while exporting to PDF.
Steps To Reproduce1. Create a project with 2 pages with some content.
2. On page 1, create an annotation link to page 2.
3. Export to PDF, test the link.
4. Insert a page with another content between page 1 and 2.
5. Export to PDF, test the link: because the link was not updated, it is still going to page 2, now with the wrong content. Instead, it should go to page 3 to the right content.
Tagsinsert, link annotation, pages, PDF
PatchNo

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-05-03 15:12 sonejostudios New Issue
2019-05-03 15:12 sonejostudios Tag Attached: PDF
2019-05-03 15:12 sonejostudios Tag Attached: insert
2019-05-03 15:12 sonejostudios Tag Attached: link annotation
2019-05-03 15:12 sonejostudios Tag Attached: pages
2019-06-08 15:59 jghali Summary PDF Links annotations update => PDF Links annotations not updated when inserting/removing pages
2019-06-08 15:59 jghali Summary PDF Links annotations not updated when inserting/removing pages => PDF Link annotations not updated when inserting/removing pages
2019-06-08 16:03 jghali Assigned To => jghali
2019-06-08 16:03 jghali Status new => resolved
2019-06-08 16:03 jghali Resolution open => fixed
2019-06-08 16:03 jghali Fixed in Version => 1.5.5.svn
2019-07-30 21:27 cbradney Status resolved => closed