View Issue Details

IDProjectCategoryView StatusLast Update
0015705ScribusUsabilitypublic2019-06-07 05:20
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSLinux MintOS Version19 (64bit)
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015705: Text color combos show wrong value
DescriptionTested in r22999

-- Open new document
-- Check your color settings in: Edit - Colours and Fills... - Solid Colours - Scribus Basic
-- Add new TextFrame to document
-- Write some characters in TextFrame
-- Select some characters
-- Choose Text Properties - Colour&Effects - Red
-- Show the Dropdown menu: "Registration" (and not Red)

If you click the next item in the list (Rich Black) then the Dropdown menu show "Warm Black"... ...and so on.
If you click the "Yellow" then the Dropdown menu is empty.
TagsNo tags attached.
PatchNo

Activities

PeterBenedek

2019-06-04 19:38

developer  

output.gif (417,331 bytes)
output.gif (417,331 bytes)

PeterBenedek

2019-06-04 19:43

developer   ~0046270

Last edited: 2019-06-04 19:48

View 2 revisions

Same happen in the "Color of Selected Text" and "Color of Selected stroke" menu too.

jghali

2019-06-04 20:02

administrator   ~0046271

Cannot reproduce on Windows.

PeterBenedek

2019-06-05 08:51

developer   ~0046278

Please try it...

-- Open new document
-- Insert a TextFrame
-- Double click on TextFrame (TextFrame is editable)
Now...
-- Choose the "Red" item either DropDown menu
Result: "Registration" (This is the next item in the menu)

I not tried on Windows.

jghali

2019-06-06 12:20

administrator   ~0046283

Thanks, with these new steps I've been able to reproduce the issue

jghali

2019-06-06 12:22

administrator   ~0046284

Pushed the fix in r23002

PeterBenedek

2019-06-07 05:20

developer   ~0046286

Tested in r 23002

Works well!

Thanks!

Issue History

Date Modified Username Field Change
2019-06-04 19:38 PeterBenedek New Issue
2019-06-04 19:38 PeterBenedek File Added: output.gif
2019-06-04 19:43 PeterBenedek Note Added: 0046270
2019-06-04 19:48 PeterBenedek Note Edited: 0046270 View Revisions
2019-06-04 20:02 jghali Note Added: 0046271
2019-06-05 08:51 PeterBenedek Note Added: 0046278
2019-06-06 12:20 jghali Note Added: 0046283
2019-06-06 12:20 jghali Summary Background colour of selected text appear wrong title => Text color combos show wrong value
2019-06-06 12:22 jghali Assigned To => jghali
2019-06-06 12:22 jghali Status new => resolved
2019-06-06 12:22 jghali Resolution open => fixed
2019-06-06 12:22 jghali Fixed in Version => 1.5.5.svn
2019-06-06 12:22 jghali Note Added: 0046284
2019-06-07 05:20 PeterBenedek Note Added: 0046286
2019-06-07 05:20 PeterBenedek Status resolved => closed