View Issue Details

IDProjectCategoryView StatusLast Update
0001571ScribusUser Interfacepublic2005-06-24 18:42
Reporternermander Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.2cvs 
Fixed in Version1.3.0cvs 
Summary0001571: Setting of View -> Snap to guide and Snap to grid doesn't save
DescriptionThe settings of the options Snap to guides and Snap to grid in the view menu does not seem to be saved between sessions. Other settings in the View menu does save.
TagsNo tags attached.
Patch

Activities

rdebel

2005-01-29 14:04

reporter   ~0003553

Also the snap-distance doesn't save

plinnell

2005-04-08 07:11

viewer   ~0004151

I am bumping this to a 1.3 feature request, where the document preferences and application preferences are separated.

The current behaviour is correct in my opinion. Here is why:

Make a document with objects and without snap to guides.

Give it to a colleague who has snap to guides enabled.

Some objects are within the snap to radius.

Result: The doc is changed unintentionally - a very bad thing IMO.

nermander

2005-04-08 07:22

reporter   ~0004155

If the Snap to... affects ALL objects I can understand the point, but in that case I think that is a bug. Snap to should not affect all objects, but only objects moved or resized.

My work flow is:

Create guides to help alignment
Create objects that snap to those guides

but as it is now I end up with frames of different sizes and in wrong locations because I forget to turn on the Snap to guides each time I start Scribus...

But maybe I'm just to spoiled with how I learned to use the different Snap-features of AutoCAD?

cbradney

2005-06-06 18:41

administrator   ~0004923

This is a bug, and annoying at that.

ringerc

2005-06-07 02:58

reporter   ~0004929

Assuming I understand what's going on correctly (I haven't checked the code to confirm) this can be fixed once the PageItem/ScribusView rewrite is complete. Part of that will involve a rewrite of mouse drag handling. We can start keeping track of "drag position" separate to "frame position", so we can actually snap the position of the frame properly.

plinnell

2005-06-13 19:12

viewer   ~0005014

Is this fixable in 1.2.2 ?

fschmid

2005-06-13 21:34

administrator   ~0005016

It is fixed in 1.2.2cvs too.

Issue History

Date Modified Username Field Change
2005-01-22 07:21 nermander New Issue
2005-01-29 14:04 rdebel Note Added: 0003553
2005-04-08 07:11 plinnell Note Added: 0004151
2005-04-08 07:11 plinnell Severity minor => feature
2005-04-08 07:11 plinnell Product Version 1.2.1 => 1.3.0cvs
2005-04-08 07:22 nermander Note Added: 0004155
2005-06-06 18:41 cbradney Note Added: 0004923
2005-06-06 18:41 cbradney Severity feature => minor
2005-06-06 18:41 cbradney Product Version 1.3.0cvs => 1.2.2cvs
2005-06-07 02:58 ringerc Note Added: 0004929
2005-06-07 02:58 ringerc Status new => acknowledged
2005-06-09 19:23 fschmid Status acknowledged => resolved
2005-06-09 19:23 fschmid Fixed in Version => 1.3.0cvs
2005-06-09 19:23 fschmid Resolution open => fixed
2005-06-09 19:23 fschmid Assigned To => fschmid
2005-06-13 19:12 plinnell Note Added: 0005014
2005-06-13 21:34 fschmid Note Added: 0005016
2005-06-24 18:42 cbradney Status resolved => closed