View Issue Details

IDProjectCategoryView StatusLast Update
0015775ScribusBuild Systempublic2019-12-08 21:24
Reporterale Assigned Toale  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015775: set the default name tag for the AppImage to "nightly"
Descriptioncurrently, the appimage tools add the git hash (if any) to the appimage name.

this makes it impossible to link the latest appimage, created from the latest commit to gitlab.

the attached patch replaces the "random" git hash by "nightly"
Tagspatch
PatchYes

Activities

ale

2019-08-18 18:10

manager  

appimage-version-master.diff (616 bytes)
diff --git a/AppImage-package/bundle.sh b/AppImage-package/bundle.sh
index 4378e5a1f6dafe618f0e4ea895ec1541c12b87c0..fe25508001289f9f1c0b343c1dffed40dc1a6861 100644
--- a/AppImage-package/bundle.sh
+++ b/AppImage-package/bundle.sh
@@ -121,6 +121,8 @@ EOF
 # Generate AppImage
 ########################################################################
 
+export VERSION=nightly
+
 # Finalize AppDir but do not turn into AppImage just yet
 wget -c -nv "https://github.com/probonopd/linuxdeployqt/releases/download/continuous/linuxdeployqt-continuous-x86_64.AppImage"
 chmod a+x linuxdeployqt-continuous-x86_64.AppImage

jghali

2019-08-19 14:21

administrator   ~0046487

>> set the default name tag for the appimage to "master"

master or nightly?

ale

2019-08-22 06:52

manager   ~0046512

it's not really nightly, but it's not master either (since the original is in svn which does have trunk and not master).

just pick one of both.
in the patch i "correctly" wrote "nightly" and when i noticed that the title said "master" i thought that it was not the effort to change the title. it would have been : - )

jghali

2019-08-23 05:34

administrator   ~0046518

>> this makes it impossible to link the latest appimage, created from the latest commit to gitlab

In fact you can. By doing a google search, I stumbled on https://gitlab.com/gitlab-org/gitlab-ce/issues/39099.

According to this link, you can download the latest artifacts archive, which contains the AppImage, by using this link:
https://gitlab.com/scribus/scribus/-/jobs/artifacts/master/download?job=appimage:linux

ale

2019-08-23 06:16

manager   ~0046520

yep, but i don't want the user to download the archive, i want her to download the appimage itself...

jghali

2019-08-23 06:49

administrator   ~0046521

Ok, instead of exporting VERSION explicitly, I defined VERSION directly on linuxdeployqt line. This VERSION environment variable takes the value of a SCRIBUS_VERSION variable defined at top of script.

ale

2019-08-23 10:43

manager   ~0046522

perfect, it works.

now https://gitlab.com/scribus/scribus/-/jobs/artifacts/master/raw/Scribus-nightly-x86_64.AppImage?job=appimage%3Alinux downloads the latest appimage built on gitlab.

we just have to make sure that we never leave the code alone, without a commit (and push to github / gitlab) for a full week... but that can be a goal by itself : - )

Issue History

Date Modified Username Field Change
2019-08-18 18:10 ale New Issue
2019-08-18 18:10 ale File Added: appimage-version-master.diff
2019-08-18 18:10 ale Tag Attached: patch
2019-08-19 13:56 jghali Category - => Build System
2019-08-19 14:21 jghali Note Added: 0046487
2019-08-22 06:52 ale Note Added: 0046512
2019-08-22 06:52 ale Summary [PATCH] set the default name tag for the appimage to "master" => [PATCH] set the default name tag for the appimage to "nightly"
2019-08-23 05:34 jghali Note Added: 0046518
2019-08-23 06:16 ale Note Added: 0046520
2019-08-23 06:38 jghali Summary [PATCH] set the default name tag for the appimage to "nightly" => set the default name tag for the appimage to "nightly"
2019-08-23 06:40 jghali Summary set the default name tag for the appimage to "nightly" => set the default name tag for the AppImage to "nightly"
2019-08-23 06:49 jghali Note Added: 0046521
2019-08-23 06:51 jghali Assigned To => ale
2019-08-23 06:51 jghali Status new => resolved
2019-08-23 06:51 jghali Resolution open => fixed
2019-08-23 06:51 jghali Fixed in Version => 1.5.6.svn
2019-08-23 10:43 ale Note Added: 0046522
2019-12-08 21:24 cbradney Status resolved => closed