View Issue Details

IDProjectCategoryView StatusLast Update
0015818ScribusPDFpublic2019-12-08 21:24
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015818: gradient transparency on a group make the group disappear in the pdf
Descriptionthe gradiant transparency gets shown correctly in scribus, but the group disappears in the pdf.
TagsNo tags attached.
PatchNo

Activities

jghali

2019-09-11 12:58

administrator   ~0046662

What PDF reader? I did a simple test and Adobe Reader is showing the group correctly. Anyway please attach sample document.

ale

2019-09-11 14:36

manager   ~0046663

i tested it with evince.

so, yes, it might be a reader thing...

gradient.pdf (3,010 bytes)
gradient.sla (15,187 bytes)

PeterBenedek

2019-09-11 15:15

developer   ~0046664

Last edited: 2019-09-11 15:22

View 2 revisions

Not the reader's fault...

Inkscape is crashed if I imported the pdf file.



gradient_in_firefox.jpg (5,759 bytes)
gradient_in_firefox.jpg (5,759 bytes)
gradient_in_foxit.jpg (5,934 bytes)
gradient_in_foxit.jpg (5,934 bytes)
gradient_in_gimp.jpg (5,977 bytes)
gradient_in_gimp.jpg (5,977 bytes)
gradient_in_scribus.jpg (29,918 bytes)
gradient_in_scribus.jpg (29,918 bytes)

ale

2019-09-11 15:20

manager   ~0046665

well, not even scribus can import it correctly : - )

but "per definition", if adobe reader shows it correctly and all other viewers do not, it's the fault of the rest of the world : - )

jghali

2019-09-12 02:25

administrator   ~0046666

Well, the bug was depending in fact on the object position and gradient/pattern type used for transparency. By performing a few more tests, I uncovered a few more issues, they are now fixed.

ale

2019-09-12 07:22

manager   ~0046668

thanks jean!

PeterBenedek

2019-09-13 04:55

developer   ~0046669

Tested in Linux Mint 19.x; r23198

I can't reproduce anymore. Works well.
Thanks

Issue History

Date Modified Username Field Change
2019-09-10 10:04 ale New Issue
2019-09-11 12:47 jghali Category - => PDF
2019-09-11 12:58 jghali Note Added: 0046662
2019-09-11 14:36 ale File Added: gradient.pdf
2019-09-11 14:36 ale File Added: gradient.sla
2019-09-11 14:36 ale Note Added: 0046663
2019-09-11 15:15 PeterBenedek File Added: gradient_in_firefox.jpg
2019-09-11 15:15 PeterBenedek File Added: gradient_in_foxit.jpg
2019-09-11 15:15 PeterBenedek File Added: gradient_in_gimp.jpg
2019-09-11 15:15 PeterBenedek File Added: gradient_in_scribus.jpg
2019-09-11 15:15 PeterBenedek Note Added: 0046664
2019-09-11 15:20 ale Note Added: 0046665
2019-09-11 15:22 PeterBenedek Note Edited: 0046664 View Revisions
2019-09-12 02:25 jghali Assigned To => jghali
2019-09-12 02:25 jghali Status new => resolved
2019-09-12 02:25 jghali Resolution open => fixed
2019-09-12 02:25 jghali Fixed in Version => 1.5.6.svn
2019-09-12 02:25 jghali Note Added: 0046666
2019-09-12 07:22 ale Note Added: 0046668
2019-09-13 04:55 PeterBenedek Note Added: 0046669
2019-12-08 21:24 cbradney Status resolved => closed