View Issue Details

IDProjectCategoryView StatusLast Update
0015836ScribusUndo/Redopublic2019-12-08 21:24
ReporterFirasH Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015836: Undoing on Attach Text to Path returns a bigger selected Text Frame
DescriptionUndo on Attach Text to Path returns a bigger selected Text Frame
Steps To ReproduceYou can skip to step 3, use the attached file 15836.sla
0) Create a new document
1) Add a Bezier Curve
2) Add a Text Frame with some Text (e.g. one paragraph of Sample Text)

3) Select the Bezier Curve and the Text Frame and Item > Path Tools > Attach Text to Path
4) Undo step 3

The Text Frame is correctly restored, but the selection rectangle (in red color) is bigger that the Text Frame.
Reselecting the Text Frame results in the correct selection rectangle.
Additional InformationLast verified with 1.5.6.svn (2019-10-03), but also present in previous versions.
TagsNo tags attached.
PatchNo

Relationships

child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

FirasH

2019-10-04 09:09

developer  

15836.sla (15,082 bytes)

jghali

2019-10-09 04:58

administrator   ~0046757

Weird issue... I tried to track it but for now have been unable to find the cause. In 1.5.4, it was even worse.

jghali

2019-10-10 06:16

administrator   ~0046758

I found the cause at last. That bigger selection was in fact not coming from an incorrect computation of text frame size, but by some undo function which were adding the deleted PathText item back to the selection. This is now fixed.

Issue History

Date Modified Username Field Change
2019-10-04 09:08 FirasH New Issue
2019-10-04 09:09 FirasH File Added: 15836.sla
2019-10-04 09:09 FirasH Relationship added child of 0012500
2019-10-09 04:58 jghali Note Added: 0046757
2019-10-10 06:07 jghali Summary Undo on Attach Text to Path returns a bigger selected Text Frame => Undoing on Attach Text to Path returns a bigger selected Text Frame
2019-10-10 06:16 jghali Assigned To => jghali
2019-10-10 06:16 jghali Status new => resolved
2019-10-10 06:16 jghali Resolution open => fixed
2019-10-10 06:16 jghali Fixed in Version => 1.5.6.svn
2019-10-10 06:16 jghali Note Added: 0046758
2019-12-08 21:24 cbradney Status resolved => closed