View Issue Details

IDProjectCategoryView StatusLast Update
0016020ScribusOS-MacOSXpublic2021-04-15 20:37
Reporterramuntcho Assigned Tocbradney  
PriorityhighSeverityblockReproducibilityalways
Status closedResolutionduplicate 
PlatformmacosOSmacOS Version10.15
Product Version1.5.5 
Fixed in Version1.5.7.svn 
Summary0016020: If you switch to french language, preferences are no more available
DescriptionIn the Preferences of Scribus, you can switch to French. If you do, the window for modifying the preferences is no more available.
Steps To ReproduceOpen Scribus
Create a new document
In menu Scribus, choose Preferences
Change in the window to have the interface in French (or spanish)
Qui Scribus
Launch Scribus
Go to the menu Scribus and choose the line Preferences... nothing happens, the Preferences window doesn't appear anymore
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0016044 new Scribus was not able to load its preferences 

Activities

ramuntcho

2019-12-19 11:25

reporter  

French.png (210,581 bytes)   
French.png (210,581 bytes)   

ale

2019-12-19 20:24

manager   ~0047299

... until december 22nd, after switching to french, you need to check if the menu entry is marked as suppressed, before starting scribus...

:-)

... in the meantime you can try and see if cmd-, opens the preferences...

if you want your preferences back, you can also remove the preferences file. if you want to go this way, i can look for the instructions for mac... i don't know them by heart...

ramuntcho

2019-12-26 17:36

reporter   ~0047306

Hi,

In fact, in english there isn't any submenu like in french (with Annotation PDF, Signet PDF...). When you choose French for the first time, and don't close Scribus, menus are in French and there is no submenus to the line Preferences... but nothing happens. When you close and open Scribus, the submenus appear. Shortcut to open Preferences isn't working.

We wanted to use Scribus with french children on macOS Catalina, so it would be better to have a french version.
:-))

PS Why "until december 22nd " ?

ale

2019-12-27 12:32

manager   ~0047309

the 22nd december was a pun on the ongoing strike in france... sorry.

i've tried to see in the code if i see a reason why the menu is wrongly wired in french, but i could not find any.

since i don't have a mac computer at hand, i cannot test it.
on linux i have a "normal" préférences dialog

that "Scribus" menu is a mac specific thing, so there might be an issue that is only visible on a mac...

can you try to download the latest 1.5.6svn snapshot and see if you have the issue there too?

ramuntcho

2019-12-30 15:13

reporter   ~0047310

Hi,

I have made several tests with 1.5.6 svn, same bug.
But i have also try some other languages :
- no problem with hungarian, deutsch, portuguese, swedish
- problem with french, spanish, catalan, italian

In fact, when you choose one of the language of the second group, Scribus freezes and you have to do a force-quit. Sometimes, there is this window which appears. I have also joined the crashlog.

So there's something in common with these languages...

:-))
Crashlog Scribus.txt.zip (217,799 bytes)

ramuntcho

2021-01-12 10:09

reporter   ~0048675

in version 1.5.6.1, 1.5.7 svn (r24369) the bug with Preferences is still present. I have tested on macOS BigSur in French. In this case, i don't have access to Preferences. I don't have the bug if i choose to launch Scibus in english.

ramuntcho

2021-04-08 08:15

reporter   ~0049086

Hello,
We have to use Scribus in our classrooms (macOS Big Sur), but we can't still using it in French, because we don't have access to Preferences. I have seen that this bug affects also spanish language (see 0015834 and 0016044). No problem in english.
We have to use a nightly build Scribus1.5.6rev24052, which isn't affected by this bug.
Can we expect a resolution of this bug in the next weeks ?
Thanks for your work
:-)

Issue History

Date Modified Username Field Change
2019-12-19 11:25 ramuntcho New Issue
2019-12-19 11:25 ramuntcho File Added: French.png
2019-12-19 20:24 ale Note Added: 0047299
2019-12-26 17:36 ramuntcho Note Added: 0047306
2019-12-27 12:32 ale Note Added: 0047309
2019-12-30 15:13 ramuntcho File Added: Capture d'écran 2019-12-30 15.56.34.png
2019-12-30 15:13 ramuntcho File Added: Crashlog Scribus.txt.zip
2019-12-30 15:13 ramuntcho Note Added: 0047310
2020-04-10 21:38 cbradney Assigned To => cbradney
2020-04-10 21:38 cbradney Status new => resolved
2020-04-10 21:38 cbradney Resolution open => duplicate
2020-04-10 21:38 cbradney Fixed in Version => 1.5.6.svn
2020-04-10 21:38 cbradney Relationship added duplicate of 0016044
2020-08-11 20:56 cbradney Status resolved => closed
2021-01-12 10:09 ramuntcho Status closed => feedback
2021-01-12 10:09 ramuntcho Resolution duplicate => reopened
2021-01-12 10:09 ramuntcho Note Added: 0048675
2021-04-08 08:15 ramuntcho Note Added: 0049086
2021-04-08 08:15 ramuntcho Status feedback => assigned
2021-04-13 21:23 cbradney Status assigned => resolved
2021-04-13 21:23 cbradney Resolution reopened => duplicate
2021-04-13 21:23 cbradney Fixed in Version 1.5.6.svn => 1.5.7.svn
2021-04-15 20:37 cbradney Status resolved => closed