View Issue Details

IDProjectCategoryView StatusLast Update
0016119ScribusGeneralpublic2020-08-11 20:56
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016119: the AppImage is crashing at start
DescriptionCurrent thread 0x00007f9236eb3f40 (most recent call first):
Scribus Crash
-------------
Scribus crashes due to Signal 0000006
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize -1, redBufferSize 1,
greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(SingleBuffer), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile QSurfaceFormat::OpenGLContextProfile(NoProfile))
Falling back to using screens root_visual.
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize -1, redBufferSize 1,
greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(SingleBuffer), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile QSurfaceFormat::OpenGLContextProfile(NoProfile))
Falling back to using screens root_visual.
Calling Emergency Save
TagsNo tags attached.
PatchNo

Activities

ale

2020-05-28 21:07

manager   ~0047648

... the master does compile and run correctly on linux...

jghali

2020-05-29 00:13

administrator   ~0047649

The custom AppImage recipe I use to build AppImages for scribus releases currently produce an AppImage which runs. It is not clear why my recipe works, and the one we have in trunk doesn't tho. My recipe currently uses an older version of Qt (5.11.x) and is built on Ubuntu 18.04. That's pretty much the only noticeable differences.

ale

2020-05-30 09:10

manager   ~0047650

i've tried the oldest appimage in the CI and it also crashes.

following https://github.com/RPCS3/rpcs3/issues/4509 i've tried to remove the libxcb libraries but, then, AppRun complains that it can find them. and stops.

ale

2020-05-30 11:38

manager   ~0047651

peter's latest appimage that works is from the 8th of may.

jghali

2020-05-30 17:39

administrator   ~0047653

Last generated AppImage runs. The crash was caused by inconsistencies between Travis CI and GitLab CI platform setup.

ale

2020-05-30 19:30

manager   ~0047654

for future reference: the inconsistencies were not between the travis CI and gitlab CI, but between the docker image used in the gitlab CI and the AppImage build script.

Issue History

Date Modified Username Field Change
2020-05-28 20:30 ale New Issue
2020-05-28 21:07 ale Note Added: 0047648
2020-05-29 00:08 jghali Category - => General
2020-05-29 00:13 jghali Note Added: 0047649
2020-05-30 09:10 ale Note Added: 0047650
2020-05-30 11:38 ale Note Added: 0047651
2020-05-30 17:39 jghali Assigned To => jghali
2020-05-30 17:39 jghali Status new => resolved
2020-05-30 17:39 jghali Resolution open => fixed
2020-05-30 17:39 jghali Fixed in Version => 1.5.6.svn
2020-05-30 17:39 jghali Note Added: 0047653
2020-05-30 17:40 jghali Summary the appimage is crashing at start => the AppImage is crashing at start
2020-05-30 19:30 ale Note Added: 0047654
2020-08-11 20:56 cbradney Status resolved => closed